[Bug 257471] games/openage: failure with recent textproc/py-pygments

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 28 Jul 2021 09:15:53 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257471

            Bug ID: 257471
           Summary: games/openage: failure with recent
                    textproc/py-pygments
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: ports-bugs_at_FreeBSD.org
          Reporter: thierry_at_FreeBSD.org
                CC: freebsd_at_sysctl.cz, nivit_at_FreeBSD.org
                CC: freebsd_at_sysctl.cz, nivit_at_FreeBSD.org
 Attachment #226754 text/plain
         mime type:

Created attachment 226754
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=226754&action=edit
Full log for openage-0.3.0.1262_5 against py38-pygments-2.9.0

games/openage does not build with py38-pygments 2.9.0:

[  0% 3/303] cd
/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49 &&
/usr/local/bin/python3.8 -m buildsystem.pxdgen --file-list
/wrkdirs/usr/ports/games/openage/work/.build/py/pxdgen_sources &&
/usr/local/bin/cmake -E touch
/wrkdirs/usr/ports/games/openage/work/.build/py/pxdgen_timefile
FAILED: py/pxdgen_timefile 
cd /wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49 &&
/usr/local/bin/python3.8 -m buildsystem.pxdgen --file-list
/wrkdirs/usr/ports/games/openage/work/.build/py/pxdgen_sources &&
/usr/local/bin/cmake -E touch
/wrkdirs/usr/ports/games/openage/work/.build/py/pxdgen_timefile
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/runpy.py", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/local/lib/python3.8/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File
"/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/buildsystem/pxdgen.py",
line 437, in <module>
    main()
  File
"/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/buildsystem/pxdgen.py",
line 427, in main
    result = generator.generate(
  File
"/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/buildsystem/pxdgen.py",
line 353, in generate
    result = "\n".join(self.get_pxd_lines())
  File
"/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/buildsystem/pxdgen.py",
line 259, in get_pxd_lines
    self.parse()
  File
"/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/buildsystem/pxdgen.py",
line 227, in parse
    raise self.parser_error(
__main__.ParserError:
/wrkdirs/usr/ports/games/openage/work/openage-0.3.0-1262-ga554ab49/libopenage/main.h:15
expected identifier after 'namespace'
pxdgen: initfile libopenage/__init__.py


It seems that the version in the ports tree is quiet old, and newer releases
are available: see
https://github.com/SFTtech/openage/releases

It is possible to upgrade it and check if it would pass with a recent Pygments?

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Wed Jul 28 2021 - 09:15:53 UTC

Original text of this message