[Bug 257398] emulators/wine-devel and emulators/wine-proton: Fail link if devel/libsysinfo installed: unix/virtual.o: in function `virtual_get_system_info': virtual.c:(.text+0x5bff): undefined reference to `sysinfo'

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 25 Jul 2021 01:20:59 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257398

Kubilay Kocak <koobs_at_FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|emulators/wine-devel and    |emulators/wine-devel and
                   |emulators/wine-proton fails |emulators/wine-proton: Fail
                   |to build: undefined         |link if devel/libsysinfo
                   |reference to `sysinfo' if   |installed: unix/virtual.o:
                   |devel/libsysinfo installed  |in function
                   |                            |`virtual_get_system_info':
                   |                            |virtual.c:(.text+0x5bff):
                   |                            |undefined reference to
                   |                            |`sysinfo'
             Status|New                         |Open
           Severity|Affects Only Me             |Affects Some People
              Flags|                            |maintainer-feedback?(gerald
                   |                            |_at_FreeBSD.org),
                   |                            |maintainer-feedback?(iwtcex
                   |                            |_at_gmail.com),
                   |                            |merge-quarterly?
           Assignee|ports-bugs_at_FreeBSD.org      |gerald_at_FreeBSD.org
           Keywords|                            |needs-patch, needs-qa

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sun Jul 25 2021 - 01:20:59 UTC

Original text of this message