[Bug 257376] editors/vim: nonsensical dependancies

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 24 Jul 2021 05:05:10 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257376

            Bug ID: 257376
           Summary: editors/vim: nonsensical dependancies
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: adamw_at_FreeBSD.org
          Reporter: obrien_at_FreeBSD.org
             Flags: maintainer-feedback?(adamw_at_FreeBSD.org)
          Assignee: adamw_at_FreeBSD.org

$ pkg install vim
...
        spidermonkey78: 78.7.0_5
        sqlite3: 3.35.5_3,1
        tiff: 4.3.0
        tpm-emulator: 0.7.4_2
        trousers: 0.3.14_3
...

Why in the world does an editor need TPM (trust platform module) support?
Much less an emulator giving you a software TPM [vs. the trustable hardware
TPM].

Why does an editor require an SQL backend and a web framework (JavaScript
interpreter)?

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sat Jul 24 2021 - 05:05:10 UTC

Original text of this message