[Bug 257165] math/openblas: fails to build in Poudriere

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 13 Jul 2021 21:30:29 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257165

            Bug ID: 257165
           Summary: math/openblas: fails to build in Poudriere
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: ports-bugs_at_FreeBSD.org
          Reporter: nc_at_FreeBSD.org
                CC: phd_kimberlite_at_yahoo.co.jp
                CC: phd_kimberlite_at_yahoo.co.jp
             Flags: maintainer-feedback?(phd_kimberlite_at_yahoo.co.jp)

When I am attempting to run `poudriere testport` on WIP ports that depend on
openblas, I am getting errors.

Poudriere log: https://www.neelc.org/openblas-0.3.16,1.log

This snippet is interesting:

gfortran10 -O -Wl,-rpath=/usr/local/lib/gcc10 -O2 -m128bit-long-double -Wall
-frecursive -fno-optimize-sibling-calls -m64 -fopenmp  -O2 -m128bit-long-double
-Wall -frecursive -fno-optimize-sibling-calls -m64 -fopenmp  
-Wl,-rpath=/usr/local/lib/gcc10  -L/usr/local/lib/gcc10 -B/usr/local/bin
-fstack-protector-strong  -o zblat2 zblat2.o ../libopenblasp-r0.3.16.a
-lpthread -lgfortran -lpthread -lgfortran -lomp
rm -f ?BLAT2.SUMM
OMP_NUM_THREADS=1 OMP_NUM_THREADS=1 ./sblat2 < ./sblat2.dat

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x80161f6db in ???
#1  0x80161e896 in ???
#2  0x801478dff in ???
#3  0x8014783ce in ???
#4  0x7ffffffff002 in ???
#5  0x8020b08e0 in ???
#6  0x10e2f41 in ???
#7  0x40fb74 in ???
#8  0x40a7a7 in ???
#9  0x40f3f2 in ???
#10  0x401a1e in ???
#11  0x401b1f in _start
        at /usr/src/lib/csu/amd64/crt1_c.c:75
gmake[2]: *** [Makefile:88: level2] Segmentation fault (core dumped)
gmake[2]: Leaving directory
'/wrkdirs/usr/ports/math/openblas/work/OpenBLAS-0.3.16/test'
gmake[1]: *** [Makefile:146: tests] Error 2
gmake[1]: Leaving directory
'/wrkdirs/usr/ports/math/openblas/work/OpenBLAS-0.3.16'
*** Error code 1

This happens in a 13.0-RELEASE poudriere jail on a 14.0-CURRENT host (HP Omen
30L w/ AMD Ryzen 5800X).

Maybe is it lang/gcc10?

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Tue Jul 13 2021 - 21:30:29 UTC

Original text of this message