[Bug 257117] x11-toolkits/qt5-gui: add libmtdev dependency, links to libX11 regardless if X11 option is set

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 11 Jul 2021 19:11:59 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257117

            Bug ID: 257117
           Summary: x11-toolkits/qt5-gui: add libmtdev dependency, links
                    to libX11 regardless if X11 option is set
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: kde_at_FreeBSD.org
          Reporter: bsd_at_philippost.de
          Assignee: kde_at_FreeBSD.org
             Flags: maintainer-feedback?(kde_at_FreeBSD.org)

Created attachment 226375
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=226375&action=edit
x11-toolkits/qt5-gui: add devel/libmtdev to LIB_DEPENDS

stage-qa complains that
/usr/local/lib/qt5/plugins/generic/libqevdevtouchplugin.so is linked to
libmtdev.so.1 from devel/libmtdev which is not declared as a dependency.

The attached patch fixes that.

If X11=off, stage-qa warns about /usr/local/lib/qt5/libQt5XcbQpa.so.5.15.2
being linked to libX11-xcb.so.1 and /usr/local/lib/libX11.so.6. In addition,
when X11=off I get a Makefile warning (Using USE_XORG alone is deprecated,
please use USES=xorg). Adding USES+=xorg unconditionally does indeed silence
that warning, but doesn't that contradict not wanting X11 support?
I wouldn't have expected this. The issue came up because I checked if the
dependency on libmtdev depends on the X11 option being set.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sun Jul 11 2021 - 19:11:59 UTC

Original text of this message