[Bug 256974] security/amavisd-new won't start with jail - Net::Server::Proto::UNIX, later manual start brings it up
- Go to: [ bottom of page ] [ top of archives ] [ this month ]
Date: Sun, 04 Jul 2021 11:39:02 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256974
Bug ID: 256974
Summary: security/amavisd-new won't start with jail -
Net::Server::Proto::UNIX, later manual start brings it
up
Product: Ports & Packages
Version: Latest
Hardware: amd64
OS: Any
Status: New
Severity: Affects Only Me
Priority: ---
Component: Individual Port(s)
Assignee: flo@FreeBSD.org
Reporter: marko.cupac@mimar.rs
Flags: maintainer-feedback?(flo@FreeBSD.org)
Assignee: flo@FreeBSD.org
Hi,
I moved two of my 12.2 jails from 12.2 to 13.0 host, and upgraded them to 13.0.
During the process, all the packages were upgraded to latest main.
After the upgrade, amavisd-new won't start with jail, it throws the following:
Jul 3 18:57:03 mx amavis[76304]: (!)Net::Server: 2021/07/03-18:57:03 Unable to
load module for proto "Net::Server::Proto::UNIX": Can't locate
Net/Server/Proto/UNIX.pm: lib/Net/Server/Proto/UNIX.pm: Permission denied at
/usr/local/lib/perl5/site_perl/Net/Server/Proto.pm line 194, <GEN34> line
6.\n\n at line 194 in file /usr/local/lib/perl5/site_perl/Net/Server/Proto.pm
Manual service start has no problem.
I have another identical 12.2 jail which I moved from 12.2 to 13.0 host, but
haven't upgraded the jail and packages. This one has no problem.
amavisd-new is same on both jails (2.12.0_1,1), however some perl modules are
higher on 13.0 (problematic) jail, including p5-Net-Server (2.009 on jail
without the problem, 2.010 on jail with the problem).
Could it be that p5-Net-Server bump caused amavisd-new to refuse to start with
jail, but still be able to start on later manual start?
Thank you in advance,
--
You are receiving this mail because:
You are the assignee for the bug.