[Bug 257810] x11/gnome3(-lite) & x11/gdm lags significantly on amdgpu

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 13 Aug 2021 15:23:05 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257810

            Bug ID: 257810
           Summary: x11/gnome3(-lite) & x11/gdm lags significantly on
                    amdgpu
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: gnome_at_FreeBSD.org
          Reporter: nc_at_FreeBSD.org
          Assignee: gnome_at_FreeBSD.org
             Flags: maintainer-feedback?(gnome_at_FreeBSD.org)

On both an HP Envy x360 and a 11" Gateway laptop (2020, but forgot which model)
which both use amdgpu integrated graphics, GNOME lags significantly where it's
not usable.

This also happens on the Envy with OpenBSD, on both GNOME 3 and 40, unless I
use scfb. I don't know about Linux as I only booted non-GNOME-based distros via
LiveUSB.

This is an amdgpu problem with GNOME as KDE does not lag on the Envy, with also
being able to play Toontown Rewritten via the Linuxulator. I believe it's AMD
GPUs as scfb on the Envy and Ryzen desktops with Nvidia GPUs don't lag. I don't
know about discrete Radeon GPUs or the older radeonkms driver.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Fri Aug 13 2021 - 15:23:05 UTC

Original text of this message