[package - 140amd64-default][misc/morse] Failed for morse-robotics-1.4.154 in configure

From: <pkg-fallout_at_FreeBSD.org>
Date: Sat, 22 Jun 2024 04:00:48 UTC
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     yuri@FreeBSD.org
Log URL:        https://pkg-status.freebsd.org/beefy22/data/140amd64-default/8ae510027d33/logs/morse-robotics-1.4.154.log
Build URL:      https://pkg-status.freebsd.org/beefy22/build.html?mastername=140amd64-default&build=8ae510027d33
Log:

=>> Building misc/morse
build started at Sat Jun 22 04:00:43 UTC 2024
port directory: /usr/ports/misc/morse
package name: morse-robotics-1.4.154
building for: FreeBSD 140amd64-default-job-32 14.0-RELEASE-p7 FreeBSD 14.0-RELEASE-p7 amd64
maintained by: yuri@FreeBSD.org
Makefile datestamp: -rw-r--r--  1 root wheel 527 May 21 01:01 /usr/ports/misc/morse/Makefile
Ports top last git commit: 8ae510027
Ports top unclean checkout: no
Port dir last git commit: a40e26254
Port dir unclean checkout: no
Poudriere version: poudriere-git-3.4.1-30-g79e3edcd
Host OSVERSION: 1500018
Jail OSVERSION: 1400097
Job Id: 32

---Begin Environment---
SHELL=/bin/sh
OSVERSION=1400097
UNAME_v=FreeBSD 14.0-RELEASE-p7
UNAME_r=14.0-RELEASE-p7
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
MAKE_OBJDIR_CHECK_WRITABLE=0
LOCALBASE=/usr/local
USER=root
POUDRIERE_NAME=poudriere-git
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.4.1-30-g79e3edcd
MASTERMNT=/usr/local/poudriere/data/.m/140amd64-default/ref
LC_COLLATE=C
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
OUTPUT_REDIRECTED_STDERR=4
OUTPUT_REDIRECTED=1
PWD=/usr/local/poudriere/data/.m/140amd64-default/32/.p
OUTPUT_REDIRECTED_STDOUT=3
P_PORTS_FEATURES=FLAVORS SUBPACKAGES SELECTED_OPTIONS
MASTERNAME=140amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
SCRIPTNAME=bulk.sh
OLDPWD=/usr/local/poudriere/data/.m/140amd64-default/ref/.p/pool
POUDRIERE_PKGNAME=poudriere-git-3.4.1-30-g79e3edcd
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for morse-robotics-1.4.154:
     EXAMPLES=on: Build and/or install examples
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
yuri@FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python3.11" XDG_DATA_HOME=/wrkdirs/usr/ports/misc/morse/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/misc/morse/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/misc/morse/work/.cache  HOME=/wrkdirs/usr/ports/misc/morse/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/misc/morse/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin PKG_CONFIG_LIBDIR=/wrkdirs/usr/ports/misc/morse/work/.pkgconfig:/usr/local/libdata/pkgconfig:/usr/local/share/pkgconfig:/usr/libdata/pkgconfig SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
NINJA_STATUS="[%p %s/%t] " XDG_DATA_HOME=/wrkdirs/usr/ports/misc/morse/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/misc/morse/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/misc/morse/work/.cache  HOME=/wrkdirs/usr/ports/misc/morse/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/misc/morse/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin PKG_CONFIG_LIBDIR=/wrkdirs/usr/ports/misc/morse/work/.pkgconfig:/usr/local/libdata/pkgconfig:/usr/local/share/pkgconfig:/usr/libdata/pkgconfig MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES DESTDIR=/wrkdirs/usr/ports/misc/morse/work/stage PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  " BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  
-m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTEXAMPLES="" CMAKE_BUILD_TYPE="release" PYTHON_INCLUDEDIR=include/python3.11  PYTHON_LIBDIR=lib/python3.11  PYTHON_PLATFORM=freebsd14  PYTHON_SITELIBDIR=lib/python3.11/site-packages  PYTHON_SUFFIX=311  PYTHON_EXT_SUFFIX=.cpython-311  PYTHON_VER=3.11  PYTHON_VERSION=python3.11 PYTHON2="@comment " PYTHON3="" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/morse"  EXAMPLESDIR="share/examples/morse"  DATADIR="share/morse"  WWWDIR="www/morse"  ETCDIR="etc/morse"
--End PLIST_SUB--

--SUB_LIST--
 PYTHON_INCLUDEDIR=/usr/local/include/python3.11  PYTHON_LIBDIR=/usr/local/lib/python3.11  PYTHON_PLATFORM=freebsd14  PYTHON_SITELIBDIR=/usr/local/lib/python3.11/site-packages  PYTHON_SUFFIX=311  PYTHON_EXT_SUFFIX=.cpython-311  PYTHON_VER=3.11  PYTHON_VERSION=python3.11 PYTHON2="@comment " PYTHON3="" PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/morse DOCSDIR=/usr/local/share/doc/morse EXAMPLESDIR=/usr/local/share/examples/morse  WWWDIR=/usr/local/www/morse ETCDIR=/usr/local/etc/morse
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
####  ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 3 jobs
MAKE_JOBS_NUMBER=3
#### Misc Poudriere ####
.include "/etc/make.conf.ports_env"
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  8192
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===>   morse-robotics-1.4.154 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.21.3.pkg
[140amd64-default-job-32] Installing pkg-1.21.3...
[140amd64-default-job-32] Extracting pkg-1.21.3: .......... done
===>   morse-robotics-1.4.154 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of morse-robotics-1.4.154
===========================================================================
=======================<phase: fetch-depends  >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===========================================================================
=======================<phase: fetch          >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by morse-robotics-1.4.154 for building
===========================================================================
=======================<phase: checksum       >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by morse-robotics-1.4.154 for building
=> SHA256 Checksum OK for morse-simulator-morse-1.4-154-g53f9eaa8_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===========================================================================
=======================<phase: extract        >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by morse-robotics-1.4.154 for building
===>  Extracting for morse-robotics-1.4.154
=> SHA256 Checksum OK for morse-simulator-morse-1.4-154-g53f9eaa8_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===========================================================================
=======================<phase: patch          >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  Patching for morse-robotics-1.4.154
===>  Applying FreeBSD patches for morse-robotics-1.4.154 from /usr/ports/misc/morse/files
===========================================================================
=======================<phase: build-depends  >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===>   morse-robotics-1.4.154 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-core-3.29.6.pkg
[140amd64-default-job-32] Installing cmake-core-3.29.6...
[140amd64-default-job-32] `-- Installing expat-2.6.2...
[140amd64-default-job-32] `-- Extracting expat-2.6.2: .......... done
[140amd64-default-job-32] `-- Installing jsoncpp-1.9.5...
[140amd64-default-job-32] `-- Extracting jsoncpp-1.9.5: .......... done
[140amd64-default-job-32] `-- Installing libuv-1.48.0...
[140amd64-default-job-32] `-- Extracting libuv-1.48.0: .......... done
[140amd64-default-job-32] `-- Installing rhash-1.4.4_1...
[140amd64-default-job-32] |   `-- Installing gettext-runtime-0.22.5...
[140amd64-default-job-32] |   | `-- Installing indexinfo-0.3.1...
[140amd64-default-job-32] |   | `-- Extracting indexinfo-0.3.1: .... done
[140amd64-default-job-32] |   `-- Extracting gettext-runtime-0.22.5: .......... done
[140amd64-default-job-32] `-- Extracting rhash-1.4.4_1: .......... done
[140amd64-default-job-32] Extracting cmake-core-3.29.6: .......... done
===>   morse-robotics-1.4.154 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of morse-robotics-1.4.154
===>   morse-robotics-1.4.154 depends on executable: ninja - not found
===>   Installing existing package /packages/All/ninja-1.11.1,4.pkg
[140amd64-default-job-32] Installing ninja-1.11.1,4...
[140amd64-default-job-32] `-- Installing python311-3.11.9...
[140amd64-default-job-32] |   `-- Installing libffi-3.4.6...
[140amd64-default-job-32] |   `-- Extracting libffi-3.4.6: .......... done
[140amd64-default-job-32] |   `-- Installing mpdecimal-4.0.0...
[140amd64-default-job-32] |   `-- Extracting mpdecimal-4.0.0: .......... done
[140amd64-default-job-32] |   `-- Installing readline-8.2.10...
[140amd64-default-job-32] |   `-- Extracting readline-8.2.10: .......... done
[140amd64-default-job-32] `-- Extracting python311-3.11.9: .......... done
[140amd64-default-job-32] Extracting ninja-1.11.1,4: ........ done
=====
Message from python311-3.11.9:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py311-gdbm       databases/py-gdbm@py311
py311-sqlite3    databases/py-sqlite3@py311
py311-tkinter    x11-toolkits/py-tkinter@py311
===>   morse-robotics-1.4.154 depends on executable: ninja - found
===>   Returning to build of morse-robotics-1.4.154
===>   morse-robotics-1.4.154 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-2.2.0,1.pkg
[140amd64-default-job-32] Installing pkgconf-2.2.0,1...
[140amd64-default-job-32] Extracting pkgconf-2.2.0,1: .......... done
===>   morse-robotics-1.4.154 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of morse-robotics-1.4.154
===>   morse-robotics-1.4.154 depends on file: /usr/local/bin/python3.11 - found
===========================================================================
=======================<phase: lib-depends    >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===========================================================================
=======================<phase: configure      >============================
===== env: NO_DEPENDS=yes USER=root UID=0 GID=0
===>  Configuring for morse-robotics-1.4.154
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/misc/morse/work/.build
CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required):
  Compatibility with CMake < 3.5 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- The C compiler identification is Clang 16.0.6
-- The CXX compiler identification is Clang 16.0.6
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/local/bin/pkgconf (found version "2.2.0")
-- Found PythonInterp: /usr/local/bin/python3.11 (found suitable version "3.11.9", required is "3.3")
CMake Error at config/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find PythonLibs: Found unsuitable version "3.1", but required is
  exact version "3.11" (found /usr/local/lib/libpython3.11.so)
Call Stack (most recent call first):
  config/FindPackageHandleStandardArgs.cmake:286 (_FPHSA_FAILURE_MESSAGE)
  config/FindPythonLibs.cmake:237 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:35 (find_package)


-- Configuring incomplete, errors occurred!
*** Error code 1

Stop.
make: stopped in /usr/ports/misc/morse