[package - main-i386-default][science/py-nilearn] Failed for py38-nilearn-0.8.1 in stage

From: <pkg-fallout_at_FreeBSD.org>
Date: Sat, 08 Jan 2022 08:17:26 UTC
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     yuri@FreeBSD.org
Log URL:        http://beefy17.nyi.freebsd.org/data/main-i386-default/pfa73e6b7884b_sadc88b9c01/logs/py38-nilearn-0.8.1.log
Build URL:      http://beefy17.nyi.freebsd.org/build.html?mastername=main-i386-default&build=pfa73e6b7884b_sadc88b9c01
Log:

=>> Building science/py-nilearn
build started at Sat Jan  8 08:16:55 UTC 2022
port directory: /usr/ports/science/py-nilearn
package name: py38-nilearn-0.8.1
building for: FreeBSD main-i386-default-job-05 14.0-CURRENT FreeBSD 14.0-CURRENT 1400046 i386
maintained by: yuri@FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-21-g883afb07
Host OSVERSION: 1400042
Jail OSVERSION: 1400046
Job Id: 05




!!! Jail is newer than host. (Jail: 1400046, Host: 1400042) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/sh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1400046
UNAME_v=FreeBSD 14.0-CURRENT 1400046
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-21-g883afb07
MASTERMNT=/usr/local/poudriere/data/.m/main-i386-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=py38
DEPENDS_ARGS=
MAKE_ARGS= FLAVOR=py38
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
yuri@FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python3.8" XDG_DATA_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38  XDG_CONFIG_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38  XDG_CACHE_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38/.cache  HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/science/py-nilearn/work-py38/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38  XDG_CONFIG_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38  XDG_CACHE_HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38/.cache  HOME=/wrkdirs/usr/ports/science/py-nilearn/work-py38 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/science/py-nilearn/work-py38/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LDSHARED="cc -shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="in
 stall  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python3.8  PYTHON_LIBDIR=lib/python3.8  PYTHON_PLATFORM=freebsd14  PYTHON_SITELIBDIR=lib/python3.8/site-packages  PYTHON_SUFFIX=38  PYTHON_EXT_SUFFIX=.cpython-38  PYTHON_VER=3.8  PYTHON_VERSION=python3.8 PYTHON2="@comment " PYTHON3="" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/nilearn"  EXAMPLESDIR="share/examples/nilearn"  DATADIR="share/nilearn"  WWWDIR="www/nilearn"  ETCDIR="etc/nilearn"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/nilearn DOCSDIR=/usr/local/share/doc/nilearn EXAMPLESDIR=/usr/local/share/examples/nilearn  WWWDIR=/usr/local/www/nilearn ETCDIR=/usr/local/etc/nilearn
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-m" "elf_i386_fbsd" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=i386
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400046
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py38-nilearn-0.8.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.5.pkg
[main-i386-default-job-05] Installing pkg-1.17.5...
[main-i386-default-job-05] Extracting pkg-1.17.5: .......... done
===>   py38-nilearn-0.8.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py38-nilearn-0.8.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by py38-nilearn-0.8.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by py38-nilearn-0.8.1 for building
=> SHA256 Checksum OK for nilearn-0.8.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by py38-nilearn-0.8.1 for building
===>  Extracting for py38-nilearn-0.8.1
=> SHA256 Checksum OK for nilearn-0.8.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py38-nilearn-0.8.1
===========================================================================
=======================<phase: build-depends  >============================
===>   py38-nilearn-0.8.1 depends on package: py38-setuptools>0 - not found
===>   Installing existing package /packages/All/py38-setuptools-57.0.0.pkg
[main-i386-default-job-05] Installing py38-setuptools-57.0.0...
[main-i386-default-job-05] `-- Installing python38-3.8.12_1...
[main-i386-default-job-05] |   `-- Installing gettext-runtime-0.21...
<snip>
[main-i386-default-job-05] |   `-- Extracting expat-2.4.2: .......... done
[main-i386-default-job-05] |   `-- Installing freetype2-2.11.1...
[main-i386-default-job-05] |   | `-- Installing png-1.6.37_1...
[main-i386-default-job-05] |   | `-- Extracting png-1.6.37_1: .......... done
[main-i386-default-job-05] |   `-- Extracting freetype2-2.11.1: .......... done
[main-i386-default-job-05] `-- Extracting fontconfig-2.13.94_1,1: .......... done
Running fc-cache to build fontconfig cache...
Font directories:
	/usr/local/share/fonts
	/usr/local/lib/X11/fonts
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
fc-cache: succeeded
[main-i386-default-job-05] `-- Installing py38-cycler-0.11.0...
[main-i386-default-job-05] `-- Extracting py38-cycler-0.11.0: .......... done
[main-i386-default-job-05] `-- Installing py38-dateutil-2.8.1...
[main-i386-default-job-05] `-- Extracting py38-dateutil-2.8.1: .......... done
[main-i386-default-job-05] `-- Installing py38-kiwisolver-1.3.2,1...
[main-i386-default-job-05] `-- Extracting py38-kiwisolver-1.3.2,1: ........ done
[main-i386-default-job-05] `-- Installing py38-pillow-8.2.0...
[main-i386-default-job-05] |   `-- Installing jpeg-turbo-2.1.1_1...
[main-i386-default-job-05] |   `-- Extracting jpeg-turbo-2.1.1_1: .......... done
[main-i386-default-job-05] |   `-- Installing lcms2-2.12...
[main-i386-default-job-05] |   | `-- Installing tiff-4.3.0...
[main-i386-default-job-05] |   |   `-- Installing jbigkit-2.1_1...
[main-i386-default-job-05] |   |   `-- Extracting jbigkit-2.1_1: .......... done
[main-i386-default-job-05] |   | `-- Extracting tiff-4.3.0: .......... done
[main-i386-default-job-05] |   `-- Extracting lcms2-2.12: .......... done
[main-i386-default-job-05] |   `-- Installing libraqm-0.7.1...
[main-i386-default-job-05] |   | `-- Installing fribidi-1.0.11...
[main-i386-default-job-05] |   | `-- Extracting fribidi-1.0.11: .......... done
[main-i386-default-job-05] |   | `-- Installing harfbuzz-3.2.0...
[main-i386-default-job-05] |   |   `-- Installing glib-2.70.2,2...
[main-i386-default-job-05] |   |   | `-- Installing libiconv-1.16...
[main-i386-default-job-05] |   |   | `-- Extracting libiconv-1.16: .......... done
[main-i386-default-job-05] |   |   | `-- Installing pcre-8.45...
[main-i386-default-job-05] |   |   | `-- Extracting pcre-8.45: .......... done
[main-i386-default-job-05] |   |   `-- Extracting glib-2.70.2,2: .......... done
No schema files found: doing nothing.
[main-i386-default-job-05] |   |   `-- Installing graphite2-1.3.14...
[main-i386-default-job-05] |   |   `-- Extracting graphite2-1.3.14: .......... done
[main-i386-default-job-05] |   | `-- Extracting harfbuzz-3.2.0: .......... done
[main-i386-default-job-05] |   `-- Extracting libraqm-0.7.1: .......... done
[main-i386-default-job-05] |   `-- Installing libxcb-1.14_1...
[main-i386-default-job-05] |   | `-- Installing libXau-1.0.9...
[main-i386-default-job-05] |   | `-- Extracting libXau-1.0.9: .......... done
[main-i386-default-job-05] |   | `-- Installing libXdmcp-1.1.3...
[main-i386-default-job-05] |   |   `-- Installing xorgproto-2021.5...
[main-i386-default-job-05] |   |   `-- Extracting xorgproto-2021.5: .......... done
[main-i386-default-job-05] |   | `-- Extracting libXdmcp-1.1.3: ......... done
[main-i386-default-job-05] |   | `-- Installing libpthread-stubs-0.4...
[main-i386-default-job-05] |   | `-- Extracting libpthread-stubs-0.4: .... done
[main-i386-default-job-05] |   `-- Extracting libxcb-1.14_1: .......... done
[main-i386-default-job-05] |   `-- Installing openjpeg-2.4.0...
[main-i386-default-job-05] |   `-- Extracting openjpeg-2.4.0: .......... done
[main-i386-default-job-05] |   `-- Installing py38-olefile-0.46...
[main-i386-default-job-05] |   `-- Extracting py38-olefile-0.46: .......... done
[main-i386-default-job-05] |   `-- Installing py38-tkinter-3.8.12_6...
[main-i386-default-job-05] |   | `-- Installing tcl86-8.6.12...
[main-i386-default-job-05] |   | `-- Extracting tcl86-8.6.12: .......... done
[main-i386-default-job-05] |   | `-- Installing tk86-8.6.12...
[main-i386-default-job-05] |   |   `-- Installing libX11-1.7.2,1...
[main-i386-default-job-05] |   |   `-- Extracting libX11-1.7.2,1: .......... done
[main-i386-default-job-05] |   |   `-- Installing libXScrnSaver-1.2.3_2...
[main-i386-default-job-05] |   |   | `-- Installing libXext-1.3.4,1...
[main-i386-default-job-05] |   |   | `-- Extracting libXext-1.3.4,1: .......... done
[main-i386-default-job-05] |   |   `-- Extracting libXScrnSaver-1.2.3_2: .......... done
[main-i386-default-job-05] |   |   `-- Installing libXft-2.3.4...
[main-i386-default-job-05] |   |   | `-- Installing libXrender-0.9.10_2...
[main-i386-default-job-05] |   |   | `-- Extracting libXrender-0.9.10_2: .......... done
[main-i386-default-job-05] |   |   `-- Extracting libXft-2.3.4: .......... done
[main-i386-default-job-05] |   | `-- Extracting tk86-8.6.12: .......... done
[main-i386-default-job-05] |   `-- Extracting py38-tkinter-3.8.12_6: ........ done
[main-i386-default-job-05] |   `-- Installing webp-1.2.1...
[main-i386-default-job-05] |   | `-- Installing giflib-5.2.1...
[main-i386-default-job-05] |   | `-- Extracting giflib-5.2.1: .......... done
[main-i386-default-job-05] |   `-- Extracting webp-1.2.1: .......... done
[main-i386-default-job-05] `-- Extracting py38-pillow-8.2.0: .......... done
[main-i386-default-job-05] `-- Installing py38-pluggy-0.13.1...
[main-i386-default-job-05] `-- Extracting py38-pluggy-0.13.1: .......... done
[main-i386-default-job-05] `-- Installing py38-pyparsing-3.0.6...
[main-i386-default-job-05] `-- Extracting py38-pyparsing-3.0.6: .......... done
[main-i386-default-job-05] `-- Installing py38-pytz-2021.3,1...
[main-i386-default-job-05] `-- Extracting py38-pytz-2021.3,1: .......... done
[main-i386-default-job-05] `-- Installing py38-tornado-6.1...
[main-i386-default-job-05] `-- Extracting py38-tornado-6.1: .......... done
[main-i386-default-job-05] `-- Installing qhull-7.3.2_2,1...
[main-i386-default-job-05] `-- Extracting qhull-7.3.2_2,1: .......... done
[main-i386-default-job-05] Extracting py38-matplotlib-3.4.3: .......... done
=====
Message from freetype2-2.11.1:

--
The 2.7.x series now uses the new subpixel hinting mode (V40 port's option) as
the default, emulating a modern version of ClearType. This change inevitably
leads to different rendering results, and you might change port's options to
adapt it to your taste (or use the new "FREETYPE_PROPERTIES" environment
variable).

The environment variable "FREETYPE_PROPERTIES" can be used to control the
driver properties. Example:

FREETYPE_PROPERTIES=truetype:interpreter-version=35 \
	cff:no-stem-darkening=1 \
	autofitter:warping=1

This allows to select, say, the subpixel hinting mode at runtime for a given
application.

If LONG_PCF_NAMES port's option was enabled, the PCF family names may include
the foundry and information whether they contain wide characters. For example,
"Sony Fixed" or "Misc Fixed Wide", instead of "Fixed". This can be disabled at
run time with using pcf:no-long-family-names property, if needed. Example:

FREETYPE_PROPERTIES=pcf:no-long-family-names=1

How to recreate fontconfig cache with using such environment variable,
if needed:
# env FREETYPE_PROPERTIES=pcf:no-long-family-names=1 fc-cache -fsv

The controllable properties are listed in the section "Controlling FreeType
Modules" in the reference's table of contents
(/usr/local/share/doc/freetype2/reference/index.html, if documentation was installed).
===>   py38-nilearn-0.8.1 depends on package: py38-matplotlib>0 - found
===>   Returning to build of py38-nilearn-0.8.1
===>   py38-nilearn-0.8.1 depends on package: py38-nibabel>0 - not found
===>   Installing existing package /packages/All/py38-nibabel-3.2.1.pkg
[main-i386-default-job-05] Installing py38-nibabel-3.2.1...
[main-i386-default-job-05] `-- Installing py38-packaging-21.3...
[main-i386-default-job-05] `-- Extracting py38-packaging-21.3: .......... done
[main-i386-default-job-05] Extracting py38-nibabel-3.2.1: .......... done
===>   py38-nilearn-0.8.1 depends on package: py38-nibabel>0 - found
===>   Returning to build of py38-nilearn-0.8.1
===>   py38-nilearn-0.8.1 depends on package: py38-pandas>0 - not found
===>   Installing existing package /packages/All/py38-pandas-1.2.5,1.pkg
[main-i386-default-job-05] Installing py38-pandas-1.2.5,1...
[main-i386-default-job-05] `-- Installing py38-bottleneck-1.3.2...
[main-i386-default-job-05] `-- Extracting py38-bottleneck-1.3.2: .......... done
[main-i386-default-job-05] `-- Installing py38-cython-0.29.24...
[main-i386-default-job-05] `-- Extracting py38-cython-0.29.24: .......... done
[main-i386-default-job-05] `-- Installing py38-numexpr-2.8.0...
[main-i386-default-job-05] `-- Extracting py38-numexpr-2.8.0: .......... done
[main-i386-default-job-05] `-- Installing py38-sqlite3-3.8.12_7...
[main-i386-default-job-05] |   `-- Installing sqlite3-3.37.1,1...
[main-i386-default-job-05] |   | `-- Installing libedit-3.1.20210216,1...
[main-i386-default-job-05] |   | `-- Extracting libedit-3.1.20210216,1: .......... done
[main-i386-default-job-05] |   `-- Extracting sqlite3-3.37.1,1: .......... done
[main-i386-default-job-05] `-- Extracting py38-sqlite3-3.8.12_7: ........ done
[main-i386-default-job-05] Extracting py38-pandas-1.2.5,1: .......... done
=====
Message from py38-pandas-1.2.5,1:

--
Install math/py-statsmodels to enable parts of pandas.stats.
Install devel/py-xarray to enable the to_xarray() function.
===>   py38-nilearn-0.8.1 depends on package: py38-pandas>0 - found
===>   Returning to build of py38-nilearn-0.8.1
===>   py38-nilearn-0.8.1 depends on package: py38-scikit-learn>0 - not found
===>   Installing existing package /packages/All/py38-scikit-learn-1.0.2.pkg
[main-i386-default-job-05] Installing py38-scikit-learn-1.0.2...
[main-i386-default-job-05] `-- Installing py38-scipy-1.7.1...
[main-i386-default-job-05] |   `-- Installing blas-3.10.0...
[main-i386-default-job-05] |   `-- Extracting blas-3.10.0: ........ done
[main-i386-default-job-05] `-- Extracting py38-scipy-1.7.1: .......... done
[main-i386-default-job-05] Extracting py38-scikit-learn-1.0.2: .......... done
===>   py38-nilearn-0.8.1 depends on package: py38-scikit-learn>0 - found
===>   Returning to build of py38-nilearn-0.8.1
===>   py38-nilearn-0.8.1 depends on package: py38-scipy>0 - found
===>   py38-nilearn-0.8.1 depends on executable: bash - not found
===>   Installing existing package /packages/All/bash-5.1.16.pkg
[main-i386-default-job-05] Installing bash-5.1.16...
[main-i386-default-job-05] Extracting bash-5.1.16: .......... done
===>   py38-nilearn-0.8.1 depends on executable: bash - found
===>   Returning to build of py38-nilearn-0.8.1
===>   py38-nilearn-0.8.1 depends on package: py38-setuptools>0 - found
===>   py38-nilearn-0.8.1 depends on file: /usr/local/bin/python3.8 - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for py38-nilearn-0.8.1
===>   Generating temporary packing list
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 65, in <module>
    module_check_fn(is_nilearn_installing=True)
  File "<string>", line 124, in _check_module_dependencies
  File "<string>", line 73, in _import_module_with_version_check
  File "/usr/local/lib/python3.8/site-packages/sklearn/__init__.py", line 82, in <module>
    from .base import clone
  File "/usr/local/lib/python3.8/site-packages/sklearn/base.py", line 17, in <module>
    from .utils import _IS_32BIT
  File "/usr/local/lib/python3.8/site-packages/sklearn/utils/__init__.py", line 28, in <module>
    from .fixes import np_version, parse_version
  File "/usr/local/lib/python3.8/site-packages/sklearn/utils/fixes.py", line 22, in <module>
    import threadpoolctl
ModuleNotFoundError: No module named 'threadpoolctl'. Module "sklearn" could not be found. See http://nilearn.github.io/introduction.html#installation for installation information.
*** Error code 1

Stop.
make: stopped in /usr/ports/science/py-nilearn