[package - main-i386-default][databases/apq-pgsql] Failed for apq-pgsql-3.2.0_3 in stage

From: <pkg-fallout_at_FreeBSD.org>
Date: Sat, 30 Oct 2021 17:03:57 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     ports_at_FreeBSD.org
Log URL:        http://beefy17.nyi.freebsd.org/data/main-i386-default/pa4f15d40a133_s141a53cd58/logs/apq-pgsql-3.2.0_3.log
Build URL:      http://beefy17.nyi.freebsd.org/build.html?mastername=main-i386-default&build=pa4f15d40a133_s141a53cd58
Log:

=>> Building databases/apq-pgsql
build started at Sat Oct 30 17:03:39 UTC 2021
port directory: /usr/ports/databases/apq-pgsql
package name: apq-pgsql-3.2.0_3
building for: FreeBSD main-i386-default-job-05 14.0-CURRENT FreeBSD 14.0-CURRENT 1400039 i386
maintained by: ports_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-21-g883afb07
Host OSVERSION: 1400008
Jail OSVERSION: 1400039
Job Id: 05




!!! Jail is newer than host. (Jail: 1400039, Host: 1400008) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/sh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1400039
UNAME_v=FreeBSD 14.0-CURRENT 1400039
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-21-g883afb07
MASTERMNT=/usr/local/poudriere/data/.m/main-i386-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
ports_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--prefix=/usr/local  --disable-relocatable  --work-path=/wrkdirs/usr/ports/databases/apq-pgsql/work/build  --processors=2
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PATH=/usr/local/gcc6-aux/bin:/wrkdirs/usr/ports/databases/apq-pgsql/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin  ADA_PROJECT_PATH=/usr/local/lib/gnat XDG_DATA_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work/.cache  HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
PATH=/usr/local/gcc6-aux/bin:/wrkdirs/usr/ports/databases/apq-pgsql/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin  ADA_PROJECT_PATH=/usr/local/lib/gnat XDG_DATA_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work/.cache  HOME=/wrkdirs/usr/ports/databases/apq-pgsql/work TMPDIR="/tmp" NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="ada" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BS
 D_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/apq-pgsql"  EXAMPLESDIR="share/examples/apq-pgsql"  DATADIR="share/apq-pgsql"  WWWDIR="www/apq-pgsql"  ETCDIR="etc/apq-pgsql"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/apq-pgsql DOCSDIR=/usr/local/share/doc/apq-pgsql EXAMPLESDIR=/usr/local/share/examples/apq-pgsql  WWWDIR=/usr/local/www/apq-pgsql ETCDIR=/usr/local/etc/apq-pgsql
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-m" "elf_i386_fbsd" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=i386
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400039
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>   NOTICE:

The apq-pgsql port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing

===>  License GPLv2 GMGPL accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.3.pkg
[main-i386-default-job-05] Installing pkg-1.17.3...
[main-i386-default-job-05] Extracting pkg-1.17.3: .......... done
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of apq-pgsql-3.2.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

The apq-pgsql port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing

===>  License GPLv2 GMGPL accepted by the user
===> Fetching all distfiles required by apq-pgsql-3.2.0_3 for building
===========================================================================
<snip>
[main-i386-default-job-05] `-- Extracting gettext-runtime-0.21: .......... done
[main-i386-default-job-05] `-- Installing readline-8.1.1...
[main-i386-default-job-05] `-- Extracting readline-8.1.1: .......... done
[main-i386-default-job-05] Extracting bash-5.1.8: .......... done
===>   apq-pgsql-3.2.0_3 depends on executable: bash - found
===>   Returning to build of apq-pgsql-3.2.0_3
===>   apq-pgsql-3.2.0_3 depends on executable: gprbuild - not found
===>   Installing existing package /packages/All/gprbuild-20160609_1.pkg
[main-i386-default-job-05] Installing gprbuild-20160609_1...
[main-i386-default-job-05] Extracting gprbuild-20160609_1: .......... done
=====
Message from gprbuild-20160609_1:

--
===>   NOTICE:

The gprbuild port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
===>   apq-pgsql-3.2.0_3 depends on executable: gprbuild - found
===>   Returning to build of apq-pgsql-3.2.0_3
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/lib/gnat/apq.gpr - not found
===>   Installing existing package /packages/All/apq-3.2.0_2.pkg
[main-i386-default-job-05] Installing apq-3.2.0_2...
[main-i386-default-job-05] Extracting apq-3.2.0_2: .......... done
=====
Message from apq-3.2.0_2:

--
===>   NOTICE:

The apq port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/lib/gnat/apq.gpr - found
===>   Returning to build of apq-pgsql-3.2.0_3
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/gcc6-aux/bin/ada - not found
===>   Installing existing package /packages/All/gcc6-aux-20180516_2,1.pkg
[main-i386-default-job-05] Installing gcc6-aux-20180516_2,1...
[main-i386-default-job-05] `-- Installing binutils-2.37_1,1...
[main-i386-default-job-05] `-- Extracting binutils-2.37_1,1: .......... done
[main-i386-default-job-05] `-- Installing gmp-6.2.1...
[main-i386-default-job-05] `-- Extracting gmp-6.2.1: .......... done
[main-i386-default-job-05] `-- Installing mpc-1.2.1...
[main-i386-default-job-05] |   `-- Installing mpfr-4.1.0_1...
[main-i386-default-job-05] |   `-- Extracting mpfr-4.1.0_1: .......... done
[main-i386-default-job-05] `-- Extracting mpc-1.2.1: ......... done
[main-i386-default-job-05] Extracting gcc6-aux-20180516_2,1: .......... done
=====
Message from gcc6-aux-20180516_2,1:

--
===>   NOTICE:

The gcc6-aux port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/gcc6-aux/bin/ada - found
===>   Returning to build of apq-pgsql-3.2.0_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   apq-pgsql-3.2.0_3 depends on shared library: libpq.so.5 - not found
===>   Installing existing package /packages/All/postgresql13-client-13.4.pkg
[main-i386-default-job-05] Installing postgresql13-client-13.4...
[main-i386-default-job-05] `-- Installing gcc10-10.3.0...
[main-i386-default-job-05] `-- Extracting gcc10-10.3.0: .......... done
[main-i386-default-job-05] Extracting postgresql13-client-13.4: .......... done
=====
Message from gcc10-10.3.0:

--
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc10

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
=====
Message from postgresql13-client-13.4:

--
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk 
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-psycopg2
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
===>   apq-pgsql-3.2.0_3 depends on shared library: libpq.so.5 - found (/usr/local/lib/libpq.so.5)
===>   Returning to build of apq-pgsql-3.2.0_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for apq-pgsql-3.2.0_3
Looking for gprbuild	... [ok]
Looking for gnatprep	... [ok]
Looking for project apq ...	creating dummy.cgpr
[ok]
Looking for sed	... [ok]
Looking for grep	... [ok]
Looking for pg_config	... [ok]
Generating src/apq-postgresql.ads
	pragma Linker_Options( "-L/usr/local/lib" );
	pragma Linker_Options( "-lpq" );
Copying source files
Copying standard project files
Preparing def file..

################################################
# This is the build environment you did setup: #
################################################
export APQPOSTGRESQL_EXTERNALLY_BUILT="false"
export prefix="/usr/local"
export project_type="library"
export enable_debug="false"
export enable_static="true"
export enable_relocatable="false"
export OS="GNU/Linux"
export include_files="src/*"
export version="3.2.0"
export work_path="/wrkdirs/usr/ports/databases/apq-pgsql/work/build"
export GPRBUILD="gprbuild"
export gprbuild_params="--autoconf=apq.cgpr"
export processors="2"
export project="apq-postgresql"
===========================================================================
=======================<phase: build          >============================
===>  Building for apq-pgsql-3.2.0_3
--- all ---
./scripts/build.sh
##############################
# Building Regular Libraries #
##############################
Building static binary
completed 1 out of 5 (20%)...
gcc: error: unrecognized command line option '-Wimplicit-fallthrough=3'; did you mean '-Wno-fallthrough'?
completed 2 out of 5 (40%)...
gcc: error: unrecognized command line option '-Wimplicit-fallthrough=3'; did you mean '-Wno-fallthrough'?
   compilation of notices.c failed
   compilation of numeric.c failed

gprbuild: *** compilation phase failed
===========================================================================
=======================<phase: run-depends    >============================
===>   apq-pgsql-3.2.0_3 depends on file: /usr/local/lib/gnat/apq.gpr - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for apq-pgsql-3.2.0_3
===>   Generating temporary packing list
/bin/mkdir -p /wrkdirs/usr/ports/databases/apq-pgsql/work/stage/usr/local/lib/gnat  /wrkdirs/usr/ports/databases/apq-pgsql/work/stage/usr/local/lib/apq-postgresql/static  /wrkdirs/usr/ports/databases/apq-pgsql/work/stage/usr/local/include/apq-postgresql
install  -m 0644 /wrkdirs/usr/ports/databases/apq-pgsql/work/build/include/apq-postgresql/*  /wrkdirs/usr/ports/databases/apq-pgsql/work/stage/usr/local/include/apq-postgresql
install  -m 0644 /wrkdirs/usr/ports/databases/apq-pgsql/work/build/lib/apq-postgresql/static/*.a*  /wrkdirs/usr/ports/databases/apq-pgsql/work/stage/usr/local/lib/apq-postgresql/static
install: /wrkdirs/usr/ports/databases/apq-pgsql/work/build/lib/apq-postgresql/static/*.a*: No such file or directory
*** Error code 71

Stop.
make: stopped in /usr/ports/databases/apq-pgsql
Received on Sat Oct 30 2021 - 17:03:57 UTC

Original text of this message