[package - main-arm64-default][databases/postgis24] Failed for postgis24-2.4.9_6 in lib-depends

From: <pkg-fallout_at_FreeBSD.org>
Date: Wed, 27 Oct 2021 10:32:57 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     lbartoletti_at_FreeBSD.org
Log URL:        http://ampere2.nyi.freebsd.org/data/main-arm64-default/pebf5105f9a4d_s179219ea04/logs/postgis24-2.4.9_6.log
Build URL:      http://ampere2.nyi.freebsd.org/build.html?mastername=main-arm64-default&build=pebf5105f9a4d_s179219ea04
Log:

=>> Building databases/postgis24
build started at Wed Oct 27 10:32:06 UTC 2021
port directory: /usr/ports/databases/postgis24
package name: postgis24-2.4.9_6
building for: FreeBSD main-arm64-default-job-07 14.0-CURRENT FreeBSD 14.0-CURRENT 1400039 arm64
maintained by: lbartoletti_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-21-g883afb07
Host OSVERSION: 1400008
Jail OSVERSION: 1400039
Job Id: 07




!!! Jail is newer than host. (Jail: 1400039, Host: 1400008) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/sh
OSVERSION=1400039
UNAME_v=FreeBSD 14.0-CURRENT 1400039
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-21-g883afb07
MASTERMNT=/usr/local/poudriere/data/.m/main-arm64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-arm64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-arm64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-arm64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for postgis24-2.4.9_6:
     ADDRSTD=on: Enable address standardizer
     LOADERGUI=off: Enable shp2pgsql-gui
     SFCGAL=on: Enable sfcgal
     TOPOLOGY=on: Topology support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
lbartoletti_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--with-libiconv=/usr/local NUMERICFLAGS=2.4.9 --with-address-standardizer --without-gui --with-sfcgal=/usr/local/bin/sfcgal-config --with-topology --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl  PERL_USE_UNSAFE_INC=1 PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/databases/postgis24/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/postgis24/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/databases/postgis24/work/.cache  HOME=/wrkdirs/usr/ports/databases/postgis24/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/databases/postgis24/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh CMAKE_PREFIX_PATH="/usr/local" LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=524288
--End CONFIGURE_ENV--

--MAKE_ENV--
PERL_USE_UNSAFE_INC=1 XDG_DATA_HOME=/wrkdirs/usr/ports/databases/postgis24/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/postgis24/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/databases/postgis24/work/.cache  HOME=/wrkdirs/usr/ports/databases/postgis24/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/databases/postgis24/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing "  CPP="cpp" CPPFLAGS="-I/usr/local/include -isystem /usr/local/include"  LDFLAGS=" -L/usr/local/lib -fstack-protector-strong " LIBS="-L/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m
  555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTVERSION=2.4.9 ADDRSTD="" NO_ADDRSTD="_at_comment " LOADERGUI="_at_comment " NO_LOADERGUI="" SFCGAL="" NO_SFCGAL="_at_comment " TOPOLOGY="" NO_TOPOLOGY="_at_comment " GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0"  GTK4_VERSION="4.0.0" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib PERL_VERSION=5.32.1  PERL_VER=5.32  PERL5_MAN1=lib/perl5/site_perl/man/man1  PERL5_MAN3=lib/perl5/site_perl/man/man3  SITE_PERL=lib/perl5/site_perl  SITE_ARCH=lib/perl5/site_perl/mach/5.32 DOCSDIR="share/doc/postgis"  EXAMPLESDIR="share/examples/postgis"  DATADIR="share/postgis"  WWWDIR="www/postgis"  ETCDIR="etc/postgis"
--End PLIST_SUB--

--SUB_LIST--
ADDRSTD="" NO_ADDRSTD="_at_comment " LOADERGUI="_at_comment " NO_LOADERGUI="" SFCGAL="" NO_SFCGAL="_at_comment " TOPOLOGY="" NO_TOPOLOGY="_at_comment " PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/postgis DOCSDIR=/usr/local/share/doc/postgis EXAMPLESDIR=/usr/local/share/examples/postgis  WWWDIR=/usr/local/www/postgis ETCDIR=/usr/local/etc/postgis
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=aarch64
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400039
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  1048576
stack size              (kbytes, -s)  1048576
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   postgis24-2.4.9_6 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.3.pkg
[main-arm64-default-job-07] Installing pkg-1.17.3...
[main-arm64-default-job-07] Extracting pkg-1.17.3: .......... done
===>   postgis24-2.4.9_6 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of postgis24-2.4.9_6
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by postgis24-2.4.9_6 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by postgis24-2.4.9_6 for building
=> SHA256 Checksum OK for postgis-2.4.9.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by postgis24-2.4.9_6 for building
===>  Extracting for postgis24-2.4.9_6
=> SHA256 Checksum OK for postgis-2.4.9.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for postgis24-2.4.9_6
===========================================================================
=======================<phase: build-depends  >============================
===>   postgis24-2.4.9_6 depends on executable: msgfmt - not found
===>   Installing existing package /packages/All/gettext-tools-0.21.pkg
[main-arm64-default-job-07] Installing gettext-tools-0.21...
[main-arm64-default-job-07] `-- Installing gettext-runtime-0.21...
<snip>
https://proj.org/resource_files.html)

# projsync --system-directory --file fr_ign_ntf_r93.tif
Downloading from https://cdn.proj.org into /usr/local/share/proj
Total to download: 93581 bytes
Downloading https://cdn.proj.org/fr_ign_ntf_r93.tif... (1 / 1)

If not using the default, make sure to set PROJ_LIB environment variable
accordingly.
===>   postgis24-2.4.9_6 depends on shared library: libproj.so - found (/usr/local/lib/libproj.so)
===>   Returning to build of postgis24-2.4.9_6
===>   postgis24-2.4.9_6 depends on shared library: libgeos.so - not found
===>   Installing existing package /packages/All/geos-3.9.1.pkg
[main-arm64-default-job-07] Installing geos-3.9.1...
[main-arm64-default-job-07] Extracting geos-3.9.1: .......... done
===>   postgis24-2.4.9_6 depends on shared library: libgeos.so - found (/usr/local/lib/libgeos.so)
===>   Returning to build of postgis24-2.4.9_6
===>   postgis24-2.4.9_6 depends on shared library: libjson-c.so - not found
===>   Installing existing package /packages/All/json-c-0.15_1.pkg
[main-arm64-default-job-07] Installing json-c-0.15_1...
[main-arm64-default-job-07] Extracting json-c-0.15_1: .......... done
===>   postgis24-2.4.9_6 depends on shared library: libjson-c.so - found (/usr/local/lib/libjson-c.so)
===>   Returning to build of postgis24-2.4.9_6
===>   postgis24-2.4.9_6 depends on shared library: libgdal.so - not found
===>   Installing existing package /packages/All/gdal-3.3.2_2.pkg
[main-arm64-default-job-07] Installing gdal-3.3.2_2...
[main-arm64-default-job-07] `-- Installing expat-2.4.1...
[main-arm64-default-job-07] `-- Extracting expat-2.4.1: .......... done
[main-arm64-default-job-07] `-- Installing freexl-1.0.6...
[main-arm64-default-job-07] `-- Extracting freexl-1.0.6: .......... done
[main-arm64-default-job-07] `-- Installing giflib-5.2.1...
[main-arm64-default-job-07] `-- Extracting giflib-5.2.1: .......... done
[main-arm64-default-job-07] `-- Installing hdf5-1.10.6,1...
[main-arm64-default-job-07] |   `-- Installing hdf-szip-2.1.1...
[main-arm64-default-job-07] |   `-- Extracting hdf-szip-2.1.1: .......... done
[main-arm64-default-job-07] `-- Extracting hdf5-1.10.6,1: .......... done
[main-arm64-default-job-07] `-- Installing jasper-2.0.33...
[main-arm64-default-job-07] |   `-- Installing freeglut-3.2.1...
[main-arm64-default-job-07] |   | `-- Installing libGLU-9.0.2_1...
[main-arm64-default-job-07] |   |   `-- Installing libglvnd-1.3.4...
[main-arm64-default-job-07] |   |   | `-- Installing libX11-1.7.2,1...
[main-arm64-default-job-07] |   |   |   `-- Installing libxcb-1.14_1...
[main-arm64-default-job-07] |   |   |   | `-- Installing libXau-1.0.9...
[main-arm64-default-job-07] |   |   |   | `-- Extracting libXau-1.0.9: .......... done
[main-arm64-default-job-07] |   |   |   | `-- Installing libXdmcp-1.1.3...
[main-arm64-default-job-07] |   |   |   |   `-- Installing xorgproto-2021.4...
[main-arm64-default-job-07] |   |   |   |   `-- Extracting xorgproto-2021.4: .......... done
[main-arm64-default-job-07] |   |   |   | `-- Extracting libXdmcp-1.1.3: ......... done
[main-arm64-default-job-07] |   |   |   | `-- Installing libpthread-stubs-0.4...
[main-arm64-default-job-07] |   |   |   | `-- Extracting libpthread-stubs-0.4: .... done
[main-arm64-default-job-07] |   |   |   `-- Extracting libxcb-1.14_1: .......... done
[main-arm64-default-job-07] |   |   | `-- Extracting libX11-1.7.2,1: .......... done
[main-arm64-default-job-07] |   |   | `-- Installing libXext-1.3.4,1...
[main-arm64-default-job-07] |   |   | `-- Extracting libXext-1.3.4,1: .......... done
[main-arm64-default-job-07] |   |   `-- Extracting libglvnd-1.3.4: .......... done
[main-arm64-default-job-07] |   | `-- Extracting libGLU-9.0.2_1: ..... done
[main-arm64-default-job-07] |   | `-- Installing libICE-1.0.10,1...
[main-arm64-default-job-07] |   | `-- Extracting libICE-1.0.10,1: .......... done
[main-arm64-default-job-07] |   | `-- Installing libXi-1.7.10,1...
[main-arm64-default-job-07] |   |   `-- Installing libXfixes-5.0.3_2...
[main-arm64-default-job-07] |   |   `-- Extracting libXfixes-5.0.3_2: .......... done
[main-arm64-default-job-07] |   | `-- Extracting libXi-1.7.10,1: .......... done
[main-arm64-default-job-07] |   | `-- Installing libXrandr-1.5.2...
[main-arm64-default-job-07] |   |   `-- Installing libXrender-0.9.10_2...
[main-arm64-default-job-07] |   |   `-- Extracting libXrender-0.9.10_2: .......... done
[main-arm64-default-job-07] |   | `-- Extracting libXrandr-1.5.2: .......... done
[main-arm64-default-job-07] |   | `-- Installing libXxf86vm-1.1.4_3...
[main-arm64-default-job-07] |   | `-- Extracting libXxf86vm-1.1.4_3: .......... done
[main-arm64-default-job-07] |   `-- Extracting freeglut-3.2.1: .......... done
[main-arm64-default-job-07] |   `-- Installing libXmu-1.1.3,1...
[main-arm64-default-job-07] |   | `-- Installing libXt-1.2.1,1...
[main-arm64-default-job-07] |   |   `-- Installing libSM-1.2.3,1...
[main-arm64-default-job-07] |   |   `-- Extracting libSM-1.2.3,1: .......... done
[main-arm64-default-job-07] |   | `-- Extracting libXt-1.2.1,1: .......... done
[main-arm64-default-job-07] |   `-- Extracting libXmu-1.1.3,1: .......... done
[main-arm64-default-job-07] `-- Extracting jasper-2.0.33: .......... done
[main-arm64-default-job-07] `-- Installing libgeotiff-1.7.0...
[main-arm64-default-job-07] `-- Extracting libgeotiff-1.7.0: .......... done
[main-arm64-default-job-07] `-- Installing libkml-1.3.0_18...
[main-arm64-default-job-07] |   `-- Installing boost-libs-1.72.0_5...
[main-arm64-default-job-07] |   `-- Extracting boost-libs-1.72.0_5: .......... done
[main-arm64-default-job-07] |   `-- Installing googletest-1.11.0...
[main-arm64-default-job-07] |   `-- Extracting googletest-1.11.0: .......... done
[main-arm64-default-job-07] |   `-- Installing minizip-1.2.11...
[main-arm64-default-job-07] |   `-- Extracting minizip-1.2.11: .......... done
[main-arm64-default-job-07] |   `-- Installing uriparser-0.9.5...
[main-arm64-default-job-07] |   `-- Extracting uriparser-0.9.5: .......... done
[main-arm64-default-job-07] `-- Extracting libkml-1.3.0_18: .......... done
[main-arm64-default-job-07] `-- Installing netcdf-4.7.4...
[main-arm64-default-job-07] `-- Extracting netcdf-4.7.4: .......... done
[main-arm64-default-job-07] `-- Installing openjpeg-2.4.0...
[main-arm64-default-job-07] |   `-- Installing lcms2-2.12...
[main-arm64-default-job-07] |   `-- Extracting lcms2-2.12: .......... done
[main-arm64-default-job-07] |   `-- Installing png-1.6.37_1...
[main-arm64-default-job-07] |   `-- Extracting png-1.6.37_1: .......... done
[main-arm64-default-job-07] `-- Extracting openjpeg-2.4.0: .......... done
[main-arm64-default-job-07] `-- Installing pcre-8.45...
[main-arm64-default-job-07] `-- Extracting pcre-8.45: .......... done
[main-arm64-default-job-07] `-- Installing poppler-21.10.0...
[main-arm64-default-job-07] |   `-- Installing cairo-1.17.4,3...
[main-arm64-default-job-07] |   | `-- Installing fontconfig-2.13.94_1,1...
[main-arm64-default-job-07] |   |   `-- Installing freetype2-2.11.0...
[main-arm64-default-job-07] |   |   `-- Extracting freetype2-2.11.0: .......... done
[main-arm64-default-job-07] |   | `-- Extracting fontconfig-2.13.94_1,1: .......... done
Running fc-cache to build fontconfig cache...
Font directories:
	/usr/local/share/fonts
	/usr/local/lib/X11/fonts
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
fc-cache: succeeded
[main-arm64-default-job-07] |   | `-- Installing glib-2.70.0_1,2...
[main-arm64-default-job-07] |   |   `-- Installing libffi-3.3_1...
[main-arm64-default-job-07] |   |   `-- Extracting libffi-3.3_1: .......... done
[main-arm64-default-job-07] |   |   `-- Installing libiconv-1.16...
[main-arm64-default-job-07] |   |   `-- Extracting libiconv-1.16: .......... done
[main-arm64-default-job-07] |   |   `-- Installing python38-3.8.12_1...
[main-arm64-default-job-07] |   |   | `-- Installing mpdecimal-2.5.1...
[main-arm64-default-job-07] |   |   | `-- Extracting mpdecimal-2.5.1: .......... done
[main-arm64-default-job-07] |   |   `-- Extracting python38-3.8.12_1: .......... done
[main-arm64-default-job-07] |   | `-- Extracting glib-2.70.0_1,2: .......... done
No schema files found: doing nothing.
[main-arm64-default-job-07] |   | `-- Installing pixman-0.40.0_1...
[main-arm64-default-job-07] |   | `-- Extracting pixman-0.40.0_1: .......... done
[main-arm64-default-job-07] |   `-- Extracting cairo-1.17.4,3: .......... done
[main-arm64-default-job-07] |   `-- Installing nspr-4.32...
[main-arm64-default-job-07] |   `-- Extracting nspr-4.32: .......... done
[main-arm64-default-job-07] |   `-- Installing nss-3.71...
[main-arm64-default-job-07] |   `-- Extracting nss-3.71: .......... done
[main-arm64-default-job-07] |   `-- Installing poppler-data-0.4.11...
[main-arm64-default-job-07] |   `-- Extracting poppler-data-0.4.11: .......... done
[main-arm64-default-job-07] `-- Extracting poppler-21.10.0: .......... done
[main-arm64-default-job-07] `-- Installing postgresql13-client-13.4...
pkg-static: postgresql13-client-13.4 conflicts with postgresql96-client-9.6.23 (installs files into the same place).  Problematic file: /usr/local/bin/clusterdb

Failed to install the following 1 package(s): /packages/All/gdal-3.3.2_2.pkg
=====
Message from freeglut-3.2.1:

--
Joystick support is untested and it is unknown if it works.

Do not hesitate to contact x11_at_FreeBSD.org if this causes issues.
=====
Message from boost-libs-1.72.0_5:

--
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
=====
Message from freetype2-2.11.0:

--
The 2.7.x series now uses the new subpixel hinting mode (V40 port's option) as
the default, emulating a modern version of ClearType. This change inevitably
leads to different rendering results, and you might change port's options to
adapt it to your taste (or use the new "FREETYPE_PROPERTIES" environment
variable).

The environment variable "FREETYPE_PROPERTIES" can be used to control the
driver properties. Example:

FREETYPE_PROPERTIES=truetype:interpreter-version=35 \
	cff:no-stem-darkening=1 \
	autofitter:warping=1

This allows to select, say, the subpixel hinting mode at runtime for a given
application.

If LONG_PCF_NAMES port's option was enabled, the PCF family names may include
the foundry and information whether they contain wide characters. For example,
"Sony Fixed" or "Misc Fixed Wide", instead of "Fixed". This can be disabled at
run time with using pcf:no-long-family-names property, if needed. Example:

FREETYPE_PROPERTIES=pcf:no-long-family-names=1

How to recreate fontconfig cache with using such environment variable,
if needed:
# env FREETYPE_PROPERTIES=pcf:no-long-family-names=1 fc-cache -fsv

The controllable properties are listed in the section "Controlling FreeType
Modules" in the reference's table of contents
(/usr/local/share/doc/freetype2/reference/index.html, if documentation was installed).
=====
Message from python38-3.8.12_1:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py38-gdbm       databases/py-gdbm_at_py38
py38-sqlite3    databases/py-sqlite3_at_py38
py38-tkinter    x11-toolkits/py-tkinter_at_py38
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/postgis24
Received on Wed Oct 27 2021 - 10:32:57 UTC

Original text of this message