[package - main-armv6-default][mail/rainloop] Failed for rainloop-php80-1.16.0 in stage

From: <pkg-fallout_at_FreeBSD.org>
Date: Sun, 27 Jun 2021 14:54:04 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     yasu_at_utahime.org
Log URL:        http://beefy8.nyi.freebsd.org/data/main-armv6-default/p7e413d93a62b_s5f88df77a6/logs/rainloop-php80-1.16.0.log
Build URL:      http://beefy8.nyi.freebsd.org/build.html?mastername=main-armv6-default&build=p7e413d93a62b_s5f88df77a6
Log:

=>> Building mail/rainloop
build started at Sun Jun 27 14:53:26 UTC 2021
port directory: /usr/ports/mail/rainloop
package name: rainloop-php80-1.16.0
building for: FreeBSD main-armv6-default-job-04 14.0-CURRENT FreeBSD 14.0-CURRENT 1400024 arm
maintained by: yasu_at_utahime.org
Makefile ident: 
Poudriere version: 3.2.8-8-gaf08dbda
Host OSVERSION: 1300121
Jail OSVERSION: 1400024
Job Id: 04




!!! Jail is newer than host. (Jail: 1400024, Host: 1300121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1400024
UNAME_v=FreeBSD 14.0-CURRENT 1400024
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-8-gaf08dbda
MASTERMNT=/usr/local/poudriere/data/.m/main-armv6-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-armv6-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-armv6-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=php80
DEPENDS_ARGS=
MAKE_ARGS= FLAVOR=php80
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for rainloop-php80-1.16.0:
====> Options available for the radio DB: you can only select none or one of them
     MYSQL=off: MySQL database support
     PGSQL=off: PostgreSQL database support
     SQLITE=on: SQLite database support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
yasu_at_utahime.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80  XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80  HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/mail/rainloop/work-php80/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80  XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80  HOME=/wrkdirs/usr/ports/mail/rainloop/work-php80 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/mail/rainloop/work-php80/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
VER="1.16.0" WWWOWN="www" WWWGRP="www" PHP_EXT_DIR=20200930 OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/rainloop"  EXAMPLESDIR="share/examples/rainloop"  DATADIR="share/rainloop"  WWWDIR="www/rainloop"  ETCDIR="etc/rainloop"
--End PLIST_SUB--

--SUB_LIST--
PHP_EXT_DIR=20200930 PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/rainloop DOCSDIR=/usr/local/share/doc/rainloop EXAMPLESDIR=/usr/local/share/examples/rainloop  WWWDIR=/usr/local/www/rainloop ETCDIR=/usr/local/etc/rainloop
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=FreeBSD clang version 12.0.0 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.0-0-gd28af7c654d8) Target: armv6-unknown-freebsd14.0-gnueabihf Thread model: posix InstalledDir: /nxb-bin/usr/bin
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=FreeBSD clang version 12.0.0 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.0-0-gd28af7c654d8) Target: armv6-unknown-freebsd14.0-gnueabihf Thread model: posix InstalledDir: /nxb-bin/usr/bin "/nxb-bin/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=yes
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=yes
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=yes
CC_OUTPUT_9d218390_f00456e5=yes
CC_OUTPUT_9d218390_65ad290d=yes
CC_OUTPUT_9d218390_f2776b26=yes
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=yes
CC_OUTPUT_9d218390_160933ec=yes
CC_OUTPUT_9d218390_fb62803b=yes
_OBJC_CCVERSION_9d218390=FreeBSD clang version 12.0.0 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.0-0-gd28af7c654d8) Target: armv6-unknown-freebsd14.0-gnueabihf Thread model: posix InstalledDir: /nxb-bin/usr/bin
_OBJC_ALTCCVERSION_9d218390=none
ARCH=armv6
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400024
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License RainLoop accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rainloop-php80-1.16.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.16.3.txz
[main-armv6-default-job-04] Installing pkg-1.16.3...
[main-armv6-default-job-04] Extracting pkg-1.16.3: .......... done
===>   rainloop-php80-1.16.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rainloop-php80-1.16.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License RainLoop accepted by the user
=> rainloop-1.16.0.zip doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch https://github.com/RainLoop/rainloop-webmail/releases/download/v1.16.0/rainloop-1.16.0.zip
rainloop-1.16.0.zip                                   6910 kB 6948 kBps    01s
===> Fetching all distfiles required by rainloop-php80-1.16.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License RainLoop accepted by the user
===> Fetching all distfiles required by rainloop-php80-1.16.0 for building
=> SHA256 Checksum OK for rainloop-1.16.0.zip.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License RainLoop accepted by the user
===> Fetching all distfiles required by rainloop-php80-1.16.0 for building
===>  Extracting for rainloop-php80-1.16.0
=> SHA256 Checksum OK for rainloop-1.16.0.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rainloop-php80-1.16.0
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rainloop-php80-1.16.0
===========================================================================
=======================<phase: build          >============================
===========================================================================
=======================<phase: run-depends    >============================
===>   rainloop-php80-1.16.0 depends on file: /usr/local/include/php/main/php.h - not found
===>   Installing existing package /packages/All/php80-8.0.7.txz
[main-armv6-default-job-04] Installing php80-8.0.7...
[main-armv6-default-job-04] `-- Installing libargon2-20190702...
[main-armv6-default-job-04] `-- Extracting libargon2-20190702: .......... done
[main-armv6-default-job-04] `-- Installing libxml2-2.9.10_4...
[main-armv6-default-job-04] `-- Extracting libxml2-2.9.10_4: .......... done
[main-armv6-default-job-04] `-- Installing pcre2-10.37...
[main-armv6-default-job-04] `-- Extracting pcre2-10.37: .......... done
[main-armv6-default-job-04] Extracting php80-8.0.7: .......... done
===>   rainloop-php80-1.16.0 depends on file: /usr/local/include/php/main/php.h - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/curl.so - not found
===>   Installing existing package /packages/All/php80-curl-8.0.7.txz
[main-armv6-default-job-04] Installing php80-curl-8.0.7...
[main-armv6-default-job-04] `-- Installing curl-7.77.0...
[main-armv6-default-job-04] |   `-- Installing ca_root_nss-3.63...
[main-armv6-default-job-04] |   `-- Extracting ca_root_nss-3.63: ........ done
[main-armv6-default-job-04] |   `-- Installing libnghttp2-1.43.0...
[main-armv6-default-job-04] |   `-- Extracting libnghttp2-1.43.0: .......... done
[main-armv6-default-job-04] `-- Extracting curl-7.77.0: .......... done
[main-armv6-default-job-04] Extracting php80-curl-8.0.7: .......... done
=====
Message from ca_root_nss-3.63:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
=====
Message from php80-curl-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-curl.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/curl.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/dom.so - not found
===>   Installing existing package /packages/All/php80-dom-8.0.7.txz
[main-armv6-default-job-04] Installing php80-dom-8.0.7...
[main-armv6-default-job-04] Extracting php80-dom-8.0.7: .......... done
=====
Message from php80-dom-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-dom.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/dom.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/iconv.so - not found
===>   Installing existing package /packages/All/php80-iconv-8.0.7.txz
[main-armv6-default-job-04] Installing php80-iconv-8.0.7...
[main-armv6-default-job-04] `-- Installing libiconv-1.16...
[main-armv6-default-job-04] `-- Extracting libiconv-1.16: .......... done
[main-armv6-default-job-04] Extracting php80-iconv-8.0.7: ........ done
=====
Message from php80-iconv-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-iconv.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/iconv.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/openssl.so - not found
===>   Installing existing package /packages/All/php80-openssl-8.0.7.txz
[main-armv6-default-job-04] Installing php80-openssl-8.0.7...
[main-armv6-default-job-04] Extracting php80-openssl-8.0.7: ........ done
=====
Message from php80-openssl-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-openssl.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/openssl.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/simplexml.so - not found
===>   Installing existing package /packages/All/php80-simplexml-8.0.7.txz
[main-armv6-default-job-04] Installing php80-simplexml-8.0.7...
[main-armv6-default-job-04] Extracting php80-simplexml-8.0.7: ......... done
=====
Message from php80-simplexml-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-simplexml.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/simplexml.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/xml.so - not found
===>   Installing existing package /packages/All/php80-xml-8.0.7.txz
[main-armv6-default-job-04] Installing php80-xml-8.0.7...
[main-armv6-default-job-04] Extracting php80-xml-8.0.7: ......... done
=====
Message from php80-xml-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-xml.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/xml.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/zlib.so - not found
===>   Installing existing package /packages/All/php80-zlib-8.0.7.txz
[main-armv6-default-job-04] Installing php80-zlib-8.0.7...
[main-armv6-default-job-04] Extracting php80-zlib-8.0.7: ........ done
=====
Message from php80-zlib-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-zlib.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/zlib.so - found
===>   Returning to build of rainloop-php80-1.16.0
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/pdo_sqlite.so - not found
===>   Installing existing package /packages/All/php80-pdo_sqlite-8.0.7.txz
[main-armv6-default-job-04] Installing php80-pdo_sqlite-8.0.7...
[main-armv6-default-job-04] `-- Installing php80-pdo-8.0.7...
[main-armv6-default-job-04] `-- Extracting php80-pdo-8.0.7: .......... done
[main-armv6-default-job-04] `-- Installing sqlite3-3.35.5_3,1...
[main-armv6-default-job-04] |   `-- Installing libedit-3.1.20210216,1...
[main-armv6-default-job-04] |   `-- Extracting libedit-3.1.20210216,1: .......... done
[main-armv6-default-job-04] `-- Extracting sqlite3-3.35.5_3,1: .......... done
[main-armv6-default-job-04] Extracting php80-pdo_sqlite-8.0.7: ......... done
=====
Message from php80-pdo-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-20-pdo.ini
=====
Message from php80-pdo_sqlite-8.0.7:

--
This file has been added to automatically load the installed extension:
/usr/local/etc/php/ext-30-pdo_sqlite.ini
===>   rainloop-php80-1.16.0 depends on file: /usr/local/lib/php/20200930/pdo_sqlite.so - found
===>   Returning to build of rainloop-php80-1.16.0
===========================================================================
=======================<phase: stage          >============================
===>  Staging for rainloop-php80-1.16.0
===>   Generating temporary packing list
install  -m 0644 /wrkdirs/usr/ports/mail/rainloop/work-php80/rainloop-php80-1.16.0/data/* /wrkdirs/usr/ports/mail/rainloop/work-php80/stage/usr/local/www/rainloop/data
install  -m 0644 /wrkdirs/usr/ports/mail/rainloop/work-php80/rainloop-php80-1.16.0/index.php /wrkdirs/usr/ports/mail/rainloop/work-php80/stage/usr/local/www/rainloop
(cd /wrkdirs/usr/ports/mail/rainloop/work-php80/rainloop-php80-1.16.0 && /bin/sh -c '(/usr/bin/find -Ed $1 $3 | /usr/bin/cpio -dumpl $2 >/dev/null 2>&1) &&  /usr/bin/find -Ed $1 $3 \(   -type d -exec /bin/sh -c '\''cd '\''$2'\'' && chmod 755 "$_at_"'\'' . {} +  -o -type f -exec /bin/sh -c '\''cd '\''$2'\'' && chmod 0644 "$_at_"'\'' . {} + \)' COPYTREE_SHARE rainloop /wrkdirs/usr/ports/mail/rainloop/work-php80/stage/usr/local/www/rainloop)
*** Error code 1

Stop.
make: stopped in /usr/ports/mail/rainloop
Received on Sun Jun 27 2021 - 14:54:04 UTC

Original text of this message