[package - 122powerpc64-quarterly][comms/hackrf-devel] Failed for hackrf-devel-g2021.01.24_1 in build

From: <pkg-fallout_at_FreeBSD.org>
Date: Sun, 27 Jun 2021 03:48:26 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mr_at_freebsd.org
Log URL:        http://foul1.nyi.freebsd.org/data/122powerpc64-quarterly/3a6240c21278/logs/hackrf-devel-g2021.01.24_1.log
Build URL:      http://foul1.nyi.freebsd.org/build.html?mastername=122powerpc64-quarterly&build=3a6240c21278
Log:

=>> Building comms/hackrf-devel
build started at Sun Jun 27 03:47:28 UTC 2021
port directory: /usr/ports/comms/hackrf-devel
package name: hackrf-devel-g2021.01.24_1
building for: FreeBSD 122powerpc64-quarterly-job-12 12.2-RELEASE FreeBSD 12.2-RELEASE powerpc
maintained by: mr_at_freebsd.org
Makefile ident: 
Poudriere version: 3.2.8-8-gaf08dbda
Host OSVERSION: 1400008
Jail OSVERSION: 1202000
Job Id: 12

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1202000
UNAME_v=FreeBSD 12.2-RELEASE
UNAME_r=12.2-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-8-gaf08dbda
MASTERMNT=/usr/local/poudriere/data/.m/122powerpc64-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/122powerpc64-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=122powerpc64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/122powerpc64-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
mr_at_freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work  HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/comms/hackrf-devel/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work  HOME=/wrkdirs/usr/ports/comms/hackrf-devel/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/comms/hackrf-devel/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES DESTDIR=/wrkdirs/usr/ports/comms/hackrf-devel/work/stage PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release" OSREL=12.2 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/hackrf"  EXAMPLESDIR="share/examples/hackrf"  DATADIR="share/hackrf"  WWWDIR="www/hackrf"  ETCDIR="etc/hackrf"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/hackrf DOCSDIR=/usr/local/share/doc/hackrf EXAMPLESDIR=/usr/local/share/examples/hackrf  WWWDIR=/usr/local/www/hackrf ETCDIR=/usr/local/etc/hackrf
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 2007 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=Using built-in specs. Target: powerpc64-undermydesk-freebsd Configured with: FreeBSD/powerpc64 system compiler Thread model: posix gcc version 4.2.1 20070831 patched [FreeBSD] "/usr/bin/ld" "--eh-frame-hdr" "-Qy" "-melf64ppc_fbsd" "--enable-new-dtags" "-dynamic-linker" "/libexec/ld-elf.so.1" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "-L/usr/lib" "/dev/null" "-lstdc++" "-lm" "-lgcc_s" "-lgcc" "-lc" "-lgcc_s" "-lgcc" "/usr/lib/crtsavres.o" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=cc1: error: unrecognized command line option "-std=c11"
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=cc1: error: unrecognized command line option "-std=gnu11"
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=cc1plus: error: unrecognized command line option "-std=c++0x"
CC_OUTPUT_921dbbb2_f00456e5=cc1plus: error: unrecognized command line option "-std=c++11"
CC_OUTPUT_921dbbb2_65ad290d=cc1plus: error: unrecognized command line option "-std=c++14"
CC_OUTPUT_921dbbb2_f2776b26=cc1plus: error: unrecognized command line option "-std=c++17"
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=cc1plus: error: unrecognized command line option "-std=gnu++11"
CC_OUTPUT_921dbbb2_160933ec=cc1plus: error: unrecognized command line option "-std=gnu++14"
CC_OUTPUT_921dbbb2_fb62803b=cc1plus: error: unrecognized command line option "-std=gnu++17"
_OBJC_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 2007 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=powerpc64
PPC_ABI=ELFv1
OPSYS=FreeBSD
_OSRELEASE=12.2-RELEASE
OSREL=12.2
OSVERSION=1202000
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   hackrf-devel-g2021.01.24_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.16.3.txz
[122powerpc64-quarterly-job-12] Installing pkg-1.16.3...
[122powerpc64-quarterly-job-12] Extracting pkg-1.16.3: .......... done
===>   hackrf-devel-g2021.01.24_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of hackrf-devel-g2021.01.24_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by hackrf-devel-g2021.01.24_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by hackrf-devel-g2021.01.24_1 for building
=> SHA256 Checksum OK for mossmann-hackrf-g2021.01.24-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by hackrf-devel-g2021.01.24_1 for building
===>  Extracting for hackrf-devel-g2021.01.24_1
=> SHA256 Checksum OK for mossmann-hackrf-g2021.01.24-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for hackrf-devel-g2021.01.24_1
===>  Applying FreeBSD patches for hackrf-devel-g2021.01.24_1 from /usr/ports/comms/hackrf-devel/files
===========================================================================
=======================<phase: build-depends  >============================
===>   hackrf-devel-g2021.01.24_1 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.19.6.txz
[122powerpc64-quarterly-job-12] Installing cmake-3.19.6...
[122powerpc64-quarterly-job-12] `-- Installing curl-7.76.0...
[122powerpc64-quarterly-job-12] |   `-- Installing ca_root_nss-3.63...
[122powerpc64-quarterly-job-12] |   `-- Extracting ca_root_nss-3.63: ........ done
[122powerpc64-quarterly-job-12] |   `-- Installing libnghttp2-1.43.0...
[122powerpc64-quarterly-job-12] |   | `-- Installing gcc10-10.2.0_1...
[122powerpc64-quarterly-job-12] |   |   `-- Installing binutils-2.33.1_4,1...
[122powerpc64-quarterly-job-12] |   |   | `-- Installing gettext-runtime-0.21...
[122powerpc64-quarterly-job-12] |   |   |   `-- Installing indexinfo-0.3.1...
[122powerpc64-quarterly-job-12] |   |   |   `-- Extracting indexinfo-0.3.1: .... done
[122powerpc64-quarterly-job-12] |   |   | `-- Extracting gettext-runtime-0.21: .......... done
[122powerpc64-quarterly-job-12] |   |   `-- Extracting binutils-2.33.1_4,1: .......... done
[122powerpc64-quarterly-job-12] |   |   `-- Installing gcc9-9.3.0_3...
[122powerpc64-quarterly-job-12] |   |   | `-- Installing gmp-6.2.1...
[122powerpc64-quarterly-job-12] |   |   | `-- Extracting gmp-6.2.1: .......... done
[122powerpc64-quarterly-job-12] |   |   | `-- Installing mpc-1.2.0...
[122powerpc64-quarterly-job-12] |   |   |   `-- Installing mpfr-4.1.0...
[122powerpc64-quarterly-job-12] |   |   |   `-- Extracting mpfr-4.1.0: .......... done
<snip>
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
=====
Message from gcc9-9.3.0_3:

--
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc9

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
=====
Message from gcc10-10.2.0_1:

--
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc10

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   hackrf-devel-g2021.01.24_1 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of hackrf-devel-g2021.01.24_1
===>   hackrf-devel-g2021.01.24_1 depends on executable: ninja - not found
===>   Installing existing package /packages/All/ninja-1.10.2,2.txz
[122powerpc64-quarterly-job-12] Installing ninja-1.10.2,2...
[122powerpc64-quarterly-job-12] `-- Installing python37-3.7.10...
[122powerpc64-quarterly-job-12] |   `-- Installing libffi-3.3_1...
[122powerpc64-quarterly-job-12] |   `-- Extracting libffi-3.3_1: .......... done
[122powerpc64-quarterly-job-12] |   `-- Installing readline-8.1.0...
[122powerpc64-quarterly-job-12] |   `-- Extracting readline-8.1.0: .......... done
[122powerpc64-quarterly-job-12] `-- Extracting python37-3.7.10: .......... done
[122powerpc64-quarterly-job-12] Extracting ninja-1.10.2,2: ........ done
=====
Message from python37-3.7.10:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py37-gdbm       databases/py-gdbm_at_py37
py37-sqlite3    databases/py-sqlite3_at_py37
py37-tkinter    x11-toolkits/py-tkinter_at_py37
===>   hackrf-devel-g2021.01.24_1 depends on executable: ninja - found
===>   Returning to build of hackrf-devel-g2021.01.24_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   hackrf-devel-g2021.01.24_1 depends on shared library: libfftw3.so - not found
===>   Installing existing package /packages/All/fftw3-3.3.9.txz
[122powerpc64-quarterly-job-12] Installing fftw3-3.3.9...
[122powerpc64-quarterly-job-12] Extracting fftw3-3.3.9: .......... done
===>   hackrf-devel-g2021.01.24_1 depends on shared library: libfftw3.so - found (/usr/local/lib/libfftw3.so)
===>   Returning to build of hackrf-devel-g2021.01.24_1
===>   hackrf-devel-g2021.01.24_1 depends on shared library: libfftw3f.so - not found
===>   Installing existing package /packages/All/fftw3-float-3.3.9.txz
[122powerpc64-quarterly-job-12] Installing fftw3-float-3.3.9...
[122powerpc64-quarterly-job-12] Extracting fftw3-float-3.3.9: .......... done
===>   hackrf-devel-g2021.01.24_1 depends on shared library: libfftw3f.so - found (/usr/local/lib/libfftw3f.so)
===>   Returning to build of hackrf-devel-g2021.01.24_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for hackrf-devel-g2021.01.24_1
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/comms/hackrf-devel/work/.build
CMake Deprecation Warning at CMakeLists.txt:3 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- The C compiler identification is GNU 4.2.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
CMake Deprecation Warning at libhackrf/CMakeLists.txt:24 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Check if the system is big endian
-- Searching 16 bit integer
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of unsigned short
-- Check size of unsigned short - done
-- Searching 16 bit integer - Using unsigned short
-- Check if the system is big endian - big endian
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
CMake Warning (dev) at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
  The package name passed to `find_package_handle_standard_args` (LIBUSB)
  does not match the name of the calling package (USB1).  This can lead to
  problems in calling code that expects `find_package` result variables
  (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
  cmake/modules/FindUSB1.cmake:39 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  libhackrf/CMakeLists.txt:48 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Found LIBUSB: /usr/lib/libusb.so  
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
CMake Warning (dev) at cmake/modules/FindThreads.cmake:161 (IF):
  Policy CMP0054 is not set: Only interpret if() arguments as variables or
  keywords when unquoted.  Run "cmake --help-policy CMP0054" for policy
  details.  Use the cmake_policy command to set the policy and suppress this
  warning.

  Quoted variables like "THREADS_HAVE_PTHREAD_ARG" will no longer be
  dereferenced when the policy is set to NEW.  Since the policy is not set
  the OLD behavior will be used.
Call Stack (most recent call first):
  libhackrf/CMakeLists.txt:49 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Found Threads: TRUE  
CMake Deprecation Warning at hackrf-tools/CMakeLists.txt:24 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Found FFTW: /usr/local/lib/libfftw3.so  
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_COLOR_MAKEFILE
    CMAKE_CXX_COMPILER
    CMAKE_CXX_FLAGS
    CMAKE_CXX_FLAGS_DEBUG
    CMAKE_CXX_FLAGS_RELEASE
    CMAKE_C_FLAGS_DEBUG
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_VERBOSE_MAKEFILE


-- Build files have been written to: /wrkdirs/usr/ports/comms/hackrf-devel/work/.build
===========================================================================
=======================<phase: build          >============================
===>  Building for hackrf-devel-g2021.01.24_1
[1/21] /usr/bin/cc -DHACKRF_BIG_ENDIAN -DLIBRARY_RELEASE=\"unknown\" -DLIBRARY_VERSION=\"0.5\" -Dhackrf_EXPORTS  -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -fPIC   -Wall -MD -MT libhackrf/src/CMakeFiles/hackrf.dir/hackrf.c.o -MF libhackrf/src/CMakeFiles/hackrf.dir/hackrf.c.o.d -o libhackrf/src/CMakeFiles/hackrf.dir/hackrf.c.o -c /wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/libhackrf/src/hackrf.c
[2/21] : && /usr/bin/cc -fPIC -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing  -fstack-protector-strong -shared -Wl,-soname,libhackrf.so.0 -o libhackrf/src/libhackrf.so.0.5.0 libhackrf/src/CMakeFiles/hackrf.dir/hackrf.c.o  -lusb  -pthread && :
[3/21] /usr/bin/cc -DHACKRF_BIG_ENDIAN -DLIBRARY_RELEASE=\"unknown\" -DLIBRARY_VERSION=\"0.5\"  -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing   -Wall -MD -MT libhackrf/src/CMakeFiles/hackrf-static.dir/hackrf.c.o -MF libhackrf/src/CMakeFiles/hackrf-static.dir/hackrf.c.o.d -o libhackrf/src/CMakeFiles/hackrf-static.dir/hackrf.c.o -c /wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/libhackrf/src/hackrf.c
[4/21] /usr/local/bin/cmake -E cmake_symlink_library libhackrf/src/libhackrf.so.0.5.0  libhackrf/src/libhackrf.so.0 libhackrf/src/libhackrf.so && :
[5/21] : && /usr/local/bin/cmake -E rm -f libhackrf/src/libhackrf.a && /usr/bin/ar qc libhackrf/src/libhackrf.a  libhackrf/src/CMakeFiles/hackrf-static.dir/hackrf.c.o && /usr/bin/ranlib libhackrf/src/libhackrf.a && :
[6/21] /usr/bin/cc -DTOOL_RELEASE=\"unknown\" -I/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/libhackrf/src -I/usr/local/include -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing   -Wall -MD -MT hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o -MF hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o.d -o hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o -c /wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c
FAILED: hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o 
/usr/bin/cc -DTOOL_RELEASE=\"unknown\" -I/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/libhackrf/src -I/usr/local/include -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing   -Wall -MD -MT hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o -MF hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o.d -o hackrf-tools/src/CMakeFiles/hackrf_transfer.dir/hackrf_transfer.c.o -c /wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c: In function 'rx_callback':
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:410: warning: implicit declaration of function '__atomic_store_n'
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:410: error: '__ATOMIC_RELEASE' undeclared (first use in this function)
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:410: error: (Each undeclared identifier is reported only once
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:410: error: for each function it appears in.)
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c: In function 'main':
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:1043: warning: implicit declaration of function '__atomic_load_n'
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:1043: error: '__ATOMIC_ACQUIRE' undeclared (first use in this function)
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:1056: warning: implicit declaration of function '__atomic_exchange_n'
/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_transfer.c:1056: error: '__ATOMIC_SEQ_CST' undeclared (first use in this function)
[7/21] /usr/bin/cc -DTOOL_RELEASE=\"unknown\" -I/wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/libhackrf/src -I/usr/local/include -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing   -Wall -MD -MT hackrf-tools/src/CMakeFiles/hackrf_cpldjtag.dir/hackrf_cpldjtag.c.o -MF hackrf-tools/src/CMakeFiles/hackrf_cpldjtag.dir/hackrf_cpldjtag.c.o.d -o hackrf-tools/src/CMakeFiles/hackrf_cpldjtag.dir/hackrf_cpldjtag.c.o -c /wrkdirs/usr/ports/comms/hackrf-devel/work/hackrf-ee44d2d62e2dd24648599172f90fc8fc2e3b3cc3/host/hackrf-tools/src/hackrf_cpldjtag.c
ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/comms/hackrf-devel
Received on Sun Jun 27 2021 - 03:48:26 UTC

Original text of this message