[package - main-i386-default][x11-toolkits/swt] Failed for swt-4.20 in build

From: <pkg-fallout_at_FreeBSD.org>
Date: Thu, 29 Jul 2021 09:12:23 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     makc_at_FreeBSD.org
Log URL:        http://beefy17.nyi.freebsd.org/data/main-i386-default/pd69639d824b8_s7cbf1de38e/logs/swt-4.20.log
Build URL:      http://beefy17.nyi.freebsd.org/build.html?mastername=main-i386-default&build=pd69639d824b8_s7cbf1de38e
Log:

=>> Building x11-toolkits/swt
build started at Thu Jul 29 09:11:35 UTC 2021
port directory: /usr/ports/x11-toolkits/swt
package name: swt-4.20
building for: FreeBSD main-i386-default-job-07 14.0-CURRENT FreeBSD 14.0-CURRENT 1400027 i386
maintained by: makc_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-20-g137a4a48
Host OSVERSION: 1400008
Jail OSVERSION: 1400027
Job Id: 07




!!! Jail is newer than host. (Jail: 1400027, Host: 1400008) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1400027
UNAME_v=FreeBSD 14.0-CURRENT 1400027
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-20-g137a4a48
MASTERMNT=/usr/local/poudriere/data/.m/main-i386-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-i386-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for swt-4.20:
     CAIRO=on: Cairo graphics library support
     WEBKIT=off: WebKit webpage renderer support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
makc_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work  HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/x11-toolkits/swt/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
SWT_VERSION=4944r26 MAKE_CAIRO=make_cairo BUILD_WEBKIT2EXTENSION=no JAVA_HOME=/usr/local/openjdk8 XDG_DATA_HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work  HOME=/wrkdirs/usr/ports/x11-toolkits/swt/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/x11-toolkits/swt/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
SWT_VERSION=4944r26 CAIRO="" NO_CAIRO="_at_comment " WEBKIT="_at_comment " NO_WEBKIT="" JAVASHAREDIR="share/java"  JAVAJARDIR="share/java/classes" GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0"  GTK4_VERSION="4.0.0" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/swt"  EXAMPLESDIR="share/examples/swt"  DATADIR="share/swt"  WWWDIR="www/swt"  ETCDIR="etc/swt"
--End PLIST_SUB--

--SUB_LIST--
CAIRO="" NO_CAIRO="_at_comment " WEBKIT="_at_comment " NO_WEBKIT="" JAVASHAREDIR="/usr/local/share/java"  JAVAJARDIR="/usr/local/share/java/classes"  JAVALIBDIR="/usr/local/share/java/classes" JAVA_OS="native" PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/swt DOCSDIR=/usr/local/share/doc/swt EXAMPLESDIR=/usr/local/share/examples/swt  WWWDIR=/usr/local/www/swt ETCDIR=/usr/local/etc/swt
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-m" "elf_i386_fbsd" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: i386-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=i386
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400027
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License EPL accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   swt-4.20 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.1.pkg
[main-i386-default-job-07] Installing pkg-1.17.1...
[main-i386-default-job-07] Extracting pkg-1.17.1: .......... done
===>   swt-4.20 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of swt-4.20
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License EPL accepted by the user
=> swt-4.20-gtk-linux-x86_64.zip doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch http://archive.eclipse.org/eclipse/downloads/drops4/R-4.20-202106111600/swt-4.20-gtk-linux-x86_64.zip
swt-4.20-gtk-linux-x86_64.zip                         3719 kB   16 MBps    00s
===> Fetching all distfiles required by swt-4.20 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License EPL accepted by the user
===> Fetching all distfiles required by swt-4.20 for building
=> SHA256 Checksum OK for swt-4.20-gtk-linux-x86_64.zip.
===========================================================================
=======================<phase: extract-depends>============================
===>   swt-4.20 depends on file: /usr/local/bin/unzip - not found
===>   Installing existing package /packages/All/unzip-6.0_8.pkg
[main-i386-default-job-07] Installing unzip-6.0_8...
[main-i386-default-job-07] Extracting unzip-6.0_8: .......... done
===>   swt-4.20 depends on file: /usr/local/bin/unzip - found
===>   Returning to build of swt-4.20
===========================================================================
=======================<phase: extract        >============================
===>  License EPL accepted by the user
===> Fetching all distfiles required by swt-4.20 for building
===>  Extracting for swt-4.20
<snip>
[main-i386-default-job-07] |   |   `-- Installing nspr-4.32...
[main-i386-default-job-07] |   |   `-- Extracting nspr-4.32: .......... done
[main-i386-default-job-07] |   | `-- Extracting spidermonkey78-78.7.0_5: .......... done
===> Creating groups.
Creating group 'polkitd' with gid '565'.
===> Creating users
Creating user 'polkitd' with uid '565'.
[main-i386-default-job-07] |   `-- Extracting polkit-0.119: ......... done
[main-i386-default-job-07] |   `-- Installing sqlite3-3.35.5_3,1...
[main-i386-default-job-07] |   | `-- Installing libedit-3.1.20210216,1...
[main-i386-default-job-07] |   | `-- Extracting libedit-3.1.20210216,1: .......... done
[main-i386-default-job-07] |   `-- Extracting sqlite3-3.35.5_3,1: .......... done
===> Creating groups.
Creating group 'colord' with gid '970'.
===> Creating users
Creating user 'colord' with uid '970'.
[main-i386-default-job-07] `-- Extracting colord-1.3.5_1: .......... done
[main-i386-default-job-07] `-- Installing cups-2.3.3op2...
[main-i386-default-job-07] |   `-- Installing avahi-app-0.8...
[main-i386-default-job-07] |   | `-- Installing dbus-glib-0.112...
[main-i386-default-job-07] |   | `-- Extracting dbus-glib-0.112: .......... done
[main-i386-default-job-07] |   | `-- Installing gdbm-1.20...
[main-i386-default-job-07] |   | `-- Extracting gdbm-1.20: .......... done
[main-i386-default-job-07] |   | `-- Installing gnome_subr-1.0...
[main-i386-default-job-07] |   | `-- Extracting gnome_subr-1.0: .... done
[main-i386-default-job-07] |   | `-- Installing libdaemon-0.14_1...
[main-i386-default-job-07] |   | `-- Extracting libdaemon-0.14_1: .......... done
[main-i386-default-job-07] |   | `-- Installing libevent-2.1.12...
[main-i386-default-job-07] |   | `-- Extracting libevent-2.1.12: .......... done
===> Creating groups.
Creating group 'avahi' with gid '558'.
===> Creating users
Creating user 'avahi' with uid '558'.
[main-i386-default-job-07] |   `-- Extracting avahi-app-0.8: .......... done
[main-i386-default-job-07] |   `-- Installing gnutls-3.6.16...
[main-i386-default-job-07] |   | `-- Installing ca_root_nss-3.68...
[main-i386-default-job-07] |   | `-- Extracting ca_root_nss-3.68: ........ done
[main-i386-default-job-07] |   | `-- Installing gmp-6.2.1...
[main-i386-default-job-07] |   | `-- Extracting gmp-6.2.1: .......... done
[main-i386-default-job-07] |   | `-- Installing libidn2-2.3.2...
[main-i386-default-job-07] |   |   `-- Installing libunistring-0.9.10_1...
[main-i386-default-job-07] |   |   `-- Extracting libunistring-0.9.10_1: .......... done
[main-i386-default-job-07] |   | `-- Extracting libidn2-2.3.2: .......... done
[main-i386-default-job-07] |   | `-- Installing libtasn1-4.17.0...
[main-i386-default-job-07] |   | `-- Extracting libtasn1-4.17.0: .......... done
[main-i386-default-job-07] |   | `-- Installing nettle-3.7.3...
[main-i386-default-job-07] |   | `-- Extracting nettle-3.7.3: .......... done
[main-i386-default-job-07] |   | `-- Installing p11-kit-0.24.0...
[main-i386-default-job-07] |   | `-- Extracting p11-kit-0.24.0: .......... done
[main-i386-default-job-07] |   | `-- Installing trousers-0.3.14_3...
[main-i386-default-job-07] |   |   `-- Installing tpm-emulator-0.7.4_2...
===> Creating groups.
Creating group '_tss' with gid '601'.
===> Creating users
Creating user '_tss' with uid '601'.
[main-i386-default-job-07] |   |   `-- Extracting tpm-emulator-0.7.4_2: ......... done
===> Creating groups.
Using existing group '_tss'.
===> Creating users
Using existing user '_tss'.
[main-i386-default-job-07] |   | `-- Extracting trousers-0.3.14_3: .......... done
[main-i386-default-job-07] |   `-- Extracting gnutls-3.6.16: .......... done
[main-i386-default-job-07] |   `-- Installing libpaper-1.1.24.4...
[main-i386-default-job-07] |   `-- Extracting libpaper-1.1.24.4: .......... done
===> Creating groups.
Creating group 'cups' with gid '193'.
===> Creating users
Creating user 'cups' with uid '193'.
[main-i386-default-job-07] `-- Extracting cups-2.3.3op2: .......... done
[main-i386-default-job-07] `-- Installing gsettings-desktop-schemas-3.38.0...
[main-i386-default-job-07] `-- Extracting gsettings-desktop-schemas-3.38.0: .......... done
[main-i386-default-job-07] `-- Installing hicolor-icon-theme-0.17...
[main-i386-default-job-07] `-- Extracting hicolor-icon-theme-0.17: . done
[main-i386-default-job-07] `-- Installing libXcomposite-0.4.5,1...
[main-i386-default-job-07] `-- Extracting libXcomposite-0.4.5,1: .......... done
[main-i386-default-job-07] `-- Installing libXcursor-1.2.0...
[main-i386-default-job-07] `-- Extracting libXcursor-1.2.0: .......... done
[main-i386-default-job-07] `-- Installing libXdamage-1.1.5...
[main-i386-default-job-07] `-- Extracting libXdamage-1.1.5: ......... done
[main-i386-default-job-07] `-- Installing libepoxy-1.5.8_1...
[main-i386-default-job-07] `-- Extracting libepoxy-1.5.8_1: .......... done
[main-i386-default-job-07] `-- Installing libgsf-1.14.47_1...
[main-i386-default-job-07] `-- Extracting libgsf-1.14.47_1: .......... done
[main-i386-default-job-07] `-- Installing librsvg2-rust-2.50.3_4...
[main-i386-default-job-07] `-- Extracting librsvg2-rust-2.50.3_4: .......... done
[main-i386-default-job-07] `-- Installing wayland-protocols-1.21...
[main-i386-default-job-07] `-- Extracting wayland-protocols-1.21: .......... done
[main-i386-default-job-07] Extracting gtk3-3.24.29_1: .......... done
=====
Message from wayland-1.19.0_1:

--
Wayland requires XDG_RUNTIME_DIR to be defined to a path that will
contain "wayland-%d" unix(4) sockets. This is usually handled by
consolekit2 (via ck-launch-session) or pam_xdg (via login).
=====
Message from libxkbcommon-1.3.0:

--
If arrow keys don't work under X11 switch to legacy rules e.g.,

For sh/bash/ksh/zsh run and (optionally) add into ~/.profile:
  export XKB_DEFAULT_RULES=xorg

For csh/tcsh run and (optionally) add into ~/.login:
  setenv XKB_DEFAULT_RULES xorg
=====
Message from ca_root_nss-3.68:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
=====
Message from trousers-0.3.14_3:

--
To run tcsd automatically, add the following line to /etc/rc.conf:

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

If you want to use tcsd with software TPM emulator, use the following
configuration in /etc/rc.conf:

tcsd_enable="YES"
tcsd_mode="emulator"
tpmd_enable="YES"

To use TPM, add your_account to '_tss' group like following:

# pw groupmod _tss -m your_account
===>   swt-4.20 depends on shared library: libgtk-3.so - found (/usr/local/lib/libgtk-3.so)
===>   Returning to build of swt-4.20
===>   swt-4.20 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for swt-4.20
===========================================================================
=======================<phase: build          >============================
===>  Building for swt-4.20
Buildfile: /wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20/build.xml

init:

build.classes:
    [mkdir] Created dir: /wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20/classes
    [javac] /wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20/build.xml:32: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 439 source files to /wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20/classes
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.

build.nativeLibraries:
     [exec] Cairo found, compiling SWT support for the cairo graphics library.
     [exec] libjawt.so found, the SWT/AWT integration library will be compiled.
     [exec] Building SWT/GTK+ for Architectures: freebsd i386
     [exec] *** Warning: Cannot compile Webkit2 Extension because 'pkg-config --exists webkit2gtk-web-extension-4.0' check failed. Please install webkitgtk4-devel.ARCH on your system.
     [exec] Building GTK3 bindings:
     [exec] gmake[1]: Entering directory '/wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20'
     [exec] cc -O -Wall -fPIC -DSWT_VERSION=4944r26    -DLINUX -DGTK -I/usr/local/openjdk8/include -I/usr/local/openjdk8/include/freebsd -I/usr/local/include  -Werror -c swt.c
     [exec] cc -O -Wall -fPIC -DSWT_VERSION=4944r26    -DLINUX -DGTK -I/usr/local/openjdk8/include -I/usr/local/openjdk8/include/freebsd -I/usr/local/include  -Werror   -c -o c.o c.c
     [exec] cc -O -Wall -fPIC -DSWT_VERSION=4944r26    -DLINUX -DGTK -I/usr/local/openjdk8/include -I/usr/local/openjdk8/include/freebsd -I/usr/local/include  -Werror   -c -o c_stats.o c_stats.c
     [exec] cc -O -Wall -fPIC -DSWT_VERSION=4944r26    -DLINUX -DGTK -I/usr/local/openjdk8/include -I/usr/local/openjdk8/include/freebsd -I/usr/local/include  -Werror `pkg-config --cflags gtk+-3.0 gtk+-unix-print-3.0` -DUSE_ASSEMBLER -c callback.c
     [exec] callback.c:1497:2: error: initializer element is not a compile-time constant
     [exec]         FN_A_BLOCK(0)    
     [exec]         ^~~~~~~~~~~~~
     [exec] callback.c:1235:2: note: expanded from macro 'FN_A_BLOCK'
     [exec]         (jlong)FN(0, args), \
     [exec]         ^~~~~~~~~~~~~~~~~~
     [exec] gmake[1]: Leaving directory '/wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20'
     [exec] *** GTK3 Build failed, aborting further actions..
     [exec] 1 error generated.
     [exec] gmake[1]: *** [make_freebsd.mak:153: callback.o] Error 1

BUILD FAILED
/wrkdirs/usr/ports/x11-toolkits/swt/work/swt-4.20/build.xml:62: exec returned: 2

Total time: 6 seconds
*** Error code 1

Stop.
make: stopped in /usr/ports/x11-toolkits/swt
Received on Thu Jul 29 2021 - 09:12:23 UTC

Original text of this message