[package - 130releng-riscv64-quarterly][biology/ncbi-blast+] Failed for ncbi-blast+-2.12.0 in configure

From: <pkg-fallout_at_FreeBSD.org>
Date: Thu, 29 Jul 2021 03:28:58 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jwb_at_FreeBSD.org
Log URL:        http://beefy7.nyi.freebsd.org/data/130releng-riscv64-quarterly/03c599c1eb7a/logs/ncbi-blast+-2.12.0.log
Build URL:      http://beefy7.nyi.freebsd.org/build.html?mastername=130releng-riscv64-quarterly&build=03c599c1eb7a
Log:

=>> Building biology/ncbi-blast+
build started at Thu Jul 29 03:27:53 UTC 2021
port directory: /usr/ports/biology/ncbi-blast+
package name: ncbi-blast+-2.12.0
building for: FreeBSD 130releng-riscv64-quarterly-job-14 13.0-RELEASE-p3 FreeBSD 13.0-RELEASE-p3 1300139 riscv
maintained by: jwb_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-20-g137a4a48
Host OSVERSION: 1400008
Jail OSVERSION: 1300139
Job Id: 14

---Begin Environment---
SHELL=/bin/csh
UNAME_p=riscv64
UNAME_m=riscv
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1300139
UNAME_v=FreeBSD 13.0-RELEASE-p3 1300139
UNAME_r=13.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-20-g137a4a48
MASTERMNT=/usr/local/poudriere/data/.m/130releng-riscv64-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/130releng-riscv64-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=130releng-riscv64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/130releng-riscv64-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
jwb_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--
AR="ar cr" --without-boost --libdir=/usr/local/lib/ncbi-tools++ --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl  PERL_USE_UNSAFE_INC=1 PYTHON="/usr/local/bin/python3.8" XDG_DATA_HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work  HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/biology/ncbi-blast+/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh CMAKE_PREFIX_PATH="/usr/local" CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=524288
--End CONFIGURE_ENV--

--MAKE_ENV--
PERL_USE_UNSAFE_INC=1 XDG_DATA_HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work  HOME=/wrkdirs/usr/ports/biology/ncbi-blast+/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/biology/ncbi-blast+/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -march=rv64imafdc -mabi=lp64d  -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing "  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS="-isystem /usr/local/include"  LDFLAGS=" -fstack-protector-strong -L/usr/local/lib " LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="insta
 ll  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python3.8  PYTHON_LIBDIR=lib/python3.8  PYTHON_PLATFORM=freebsd13  PYTHON_SITELIBDIR=lib/python3.8/site-packages  PYTHON_SUFFIX=38  PYTHON_EXT_SUFFIX=.cpython-38  PYTHON_VER=3.8  PYTHON_VERSION=python3.8 PYTHON2="_at_comment " PYTHON3="" OSREL=13.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib PERL_VERSION=5.32.1  PERL_VER=5.32  PERL5_MAN1=lib/perl5/site_perl/man/man1  PERL5_MAN3=lib/perl5/site_perl/man/man3  SITE_PERL=lib/perl5/site_perl  SITE_ARCH=lib/perl5/site_perl/mach/5.32 DOCSDIR="share/doc/ncbi-blast+"  EXAMPLESDIR="share/examples/ncbi-blast+"  DATADIR="share/ncbi-blast+"  WWWDIR="www/ncbi-blast+"  ETCDIR="etc/ncbi-blast+"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/ncbi-blast+ DOCSDIR=/usr/local/share/doc/ncbi-blast+ EXAMPLESDIR=/usr/local/share/examples/ncbi-blast+  WWWDIR=/usr/local/www/ncbi-blast+ ETCDIR=/usr/local/etc/ncbi-blast+
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=riscv
MACHINE_ARCH=riscv64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=FreeBSD clang version 11.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-11.0.1-0-g43ff75f2c3fe) Target: riscv64-unknown-freebsd13.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=FreeBSD clang version 11.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-11.0.1-0-g43ff75f2c3fe) Target: riscv64-unknown-freebsd13.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin "/nxb-bin/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-m" "elf64lriscv" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=yes
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=yes
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=yes
CC_OUTPUT_9d218390_f00456e5=yes
CC_OUTPUT_9d218390_65ad290d=yes
CC_OUTPUT_9d218390_f2776b26=yes
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=yes
CC_OUTPUT_9d218390_160933ec=yes
CC_OUTPUT_9d218390_fb62803b=yes
_OBJC_CCVERSION_9d218390=FreeBSD clang version 11.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-11.0.1-0-g43ff75f2c3fe) Target: riscv64-unknown-freebsd13.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin
_OBJC_ALTCCVERSION_9d218390=none
ARCH=riscv64
OPSYS=FreeBSD
_OSRELEASE=13.0-RELEASE-p3
OSREL=13.0
OSVERSION=1300139
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License PD accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ncbi-blast+-2.12.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.16.3.txz
[130releng-riscv64-quarterly-job-14] Installing pkg-1.16.3...
[130releng-riscv64-quarterly-job-14] Extracting pkg-1.16.3: .......... done
===>   ncbi-blast+-2.12.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ncbi-blast+-2.12.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License PD accepted by the user
===> Fetching all distfiles required by ncbi-blast+-2.12.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License PD accepted by the user
===> Fetching all distfiles required by ncbi-blast+-2.12.0 for building
=> SHA256 Checksum OK for ncbi-blast-2.12.0+-src.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License PD accepted by the user
===> Fetching all distfiles required by ncbi-blast+-2.12.0 for building
===>  Extracting for ncbi-blast+-2.12.0
=> SHA256 Checksum OK for ncbi-blast-2.12.0+-src.tar.gz.
===========================================================================
<snip>
[130releng-riscv64-quarterly-job-14] `-- Installing libidn2-2.3.1...
[130releng-riscv64-quarterly-job-14] |   `-- Installing libunistring-0.9.10_1...
[130releng-riscv64-quarterly-job-14] |   `-- Extracting libunistring-0.9.10_1: .......... done
[130releng-riscv64-quarterly-job-14] `-- Extracting libidn2-2.3.1: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing libtasn1-4.17.0...
[130releng-riscv64-quarterly-job-14] `-- Extracting libtasn1-4.17.0: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing nettle-3.7.3...
[130releng-riscv64-quarterly-job-14] `-- Extracting nettle-3.7.3: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing p11-kit-0.24.0...
[130releng-riscv64-quarterly-job-14] |   `-- Installing glib-2.66.8,2...
[130releng-riscv64-quarterly-job-14] |   | `-- Installing libiconv-1.16...
[130releng-riscv64-quarterly-job-14] |   | `-- Extracting libiconv-1.16: .......... done
[130releng-riscv64-quarterly-job-14] |   | `-- Installing libxml2-2.9.12...
[130releng-riscv64-quarterly-job-14] |   | `-- Extracting libxml2-2.9.12: .......... done
[130releng-riscv64-quarterly-job-14] |   `-- Extracting glib-2.66.8,2: .......... done
No schema files found: doing nothing.
[130releng-riscv64-quarterly-job-14] `-- Extracting p11-kit-0.24.0: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing trousers-0.3.14_3...
[130releng-riscv64-quarterly-job-14] |   `-- Installing tpm-emulator-0.7.4_2...
===> Creating groups.
Creating group '_tss' with gid '601'.
===> Creating users
Creating user '_tss' with uid '601'.
[130releng-riscv64-quarterly-job-14] |   `-- Extracting tpm-emulator-0.7.4_2: ......... done
===> Creating groups.
Using existing group '_tss'.
===> Creating users
Using existing user '_tss'.
[130releng-riscv64-quarterly-job-14] `-- Extracting trousers-0.3.14_3: .......... done
[130releng-riscv64-quarterly-job-14] Extracting gnutls-3.6.15: .......... done
=====
Message from ca_root_nss-3.63:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
=====
Message from trousers-0.3.14_3:

--
To run tcsd automatically, add the following line to /etc/rc.conf:

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

If you want to use tcsd with software TPM emulator, use the following
configuration in /etc/rc.conf:

tcsd_enable="YES"
tcsd_mode="emulator"
tpmd_enable="YES"

To use TPM, add your_account to '_tss' group like following:

# pw groupmod _tss -m your_account
===>   ncbi-blast+-2.12.0 depends on shared library: libgnutls.so - found (/usr/local/lib/libgnutls.so)
===>   Returning to build of ncbi-blast+-2.12.0
===>   ncbi-blast+-2.12.0 depends on shared library: libtspi.so - found (/usr/local/lib/libtspi.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libgmp.so - found (/usr/local/lib/libgmp.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libidn2.so - found (/usr/local/lib/libidn2.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libnettle.so - found (/usr/local/lib/libnettle.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libhogweed.so - found (/usr/local/lib/libhogweed.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libtasn1.so - found (/usr/local/lib/libtasn1.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libp11-kit.so - found (/usr/local/lib/libp11-kit.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libgcrypt.so - not found
===>   Installing existing package /packages/All/libgcrypt-1.9.3.txz
[130releng-riscv64-quarterly-job-14] Installing libgcrypt-1.9.3...
[130releng-riscv64-quarterly-job-14] `-- Installing libgpg-error-1.42...
[130releng-riscv64-quarterly-job-14] `-- Extracting libgpg-error-1.42: .......... done
[130releng-riscv64-quarterly-job-14] Extracting libgcrypt-1.9.3: .......... done
===>   ncbi-blast+-2.12.0 depends on shared library: libgcrypt.so - found (/usr/local/lib/libgcrypt.so)
===>   Returning to build of ncbi-blast+-2.12.0
===>   ncbi-blast+-2.12.0 depends on shared library: libgpg-error.so - found (/usr/local/lib/libgpg-error.so)
===>   ncbi-blast+-2.12.0 depends on shared library: libsqlite3.so - not found
===>   Installing existing package /packages/All/sqlite3-3.35.5_3,1.txz
[130releng-riscv64-quarterly-job-14] Installing sqlite3-3.35.5_3,1...
[130releng-riscv64-quarterly-job-14] `-- Installing libedit-3.1.20210216,1...
[130releng-riscv64-quarterly-job-14] `-- Extracting libedit-3.1.20210216,1: .......... done
[130releng-riscv64-quarterly-job-14] Extracting sqlite3-3.35.5_3,1: .......... done
===>   ncbi-blast+-2.12.0 depends on shared library: libsqlite3.so - found (/usr/local/lib/libsqlite3.so)
===>   Returning to build of ncbi-blast+-2.12.0
===>   ncbi-blast+-2.12.0 depends on shared library: libuv.so - not found
===>   Installing existing package /packages/All/libuv-1.41.0.txz
[130releng-riscv64-quarterly-job-14] Installing libuv-1.41.0...
[130releng-riscv64-quarterly-job-14] Extracting libuv-1.41.0: .......... done
===>   ncbi-blast+-2.12.0 depends on shared library: libuv.so - found (/usr/local/lib/libuv.so)
===>   Returning to build of ncbi-blast+-2.12.0
===>   ncbi-blast+-2.12.0 depends on shared library: libnghttp2.so - not found
===>   Installing existing package /packages/All/libnghttp2-1.43.0.txz
[130releng-riscv64-quarterly-job-14] Installing libnghttp2-1.43.0...
[130releng-riscv64-quarterly-job-14] Extracting libnghttp2-1.43.0: .......... done
===>   ncbi-blast+-2.12.0 depends on shared library: libnghttp2.so - found (/usr/local/lib/libnghttp2.so)
===>   Returning to build of ncbi-blast+-2.12.0
===>   ncbi-blast+-2.12.0 depends on shared library: libgrpc.so - not found
===>   Installing existing package /packages/All/grpc-1.38.1_1,2.txz
[130releng-riscv64-quarterly-job-14] Installing grpc-1.38.1_1,2...
[130releng-riscv64-quarterly-job-14] `-- Installing abseil-20210324.2...
[130releng-riscv64-quarterly-job-14] `-- Extracting abseil-20210324.2: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing benchmark-1.5.5...
[130releng-riscv64-quarterly-job-14] `-- Extracting benchmark-1.5.5: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing c-ares-1.17.1...
[130releng-riscv64-quarterly-job-14] `-- Extracting c-ares-1.17.1: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing gflags-2.2.2_2...
[130releng-riscv64-quarterly-job-14] `-- Extracting gflags-2.2.2_2: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing protobuf-3.14.0,1...
[130releng-riscv64-quarterly-job-14] `-- Extracting protobuf-3.14.0,1: .......... done
[130releng-riscv64-quarterly-job-14] `-- Installing re2-20210601...
[130releng-riscv64-quarterly-job-14] `-- Extracting re2-20210601: .......... done
[130releng-riscv64-quarterly-job-14] Extracting grpc-1.38.1_1,2: .......... done
===>   ncbi-blast+-2.12.0 depends on shared library: libgrpc.so - found (/usr/local/lib/libgrpc.so)
===>   Returning to build of ncbi-blast+-2.12.0
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ncbi-blast+-2.12.0
configure: loading site script /usr/ports/Templates/config.site
configure: creating cache config.cache
checking TeamCity build number... none
checking Subversion revision... unknown
checking NCBI stable components' version... unknown
checking build system type... riscv64-portbld-freebsd13.0
checking host system type... riscv64-portbld-freebsd13.0
checking for a BSD-compatible install... /usr/bin/install -c
checking for gcc... /nxb-bin/usr/bin/cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /nxb-bin/usr/bin/cc accepts -g... yes
checking for /nxb-bin/usr/bin/cc option to accept ISO C89... none needed
checking how to run the C preprocessor... /nxb-bin/usr/bin/cpp
checking for riscv64-portbld-freebsd13.0-gcc... no
checking for gcc... no
checking for riscv64-portbld-freebsd13.0-cc... no
checking for cc... cc
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking how to run the C preprocessor... cc -E
checking whether we are using the GNU C++ compiler... yes
checking whether /nxb-bin/usr/bin/c++ accepts -g... yes
adjusted C   compiler: /nxb-bin/usr/bin/cc 
adjusted C++ compiler: /nxb-bin/usr/bin/c++ 
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether /nxb-bin/usr/bin/cc  has an option to export all symbols... no
checking whether /nxb-bin/usr/bin/cc  supports -Wl,--{en,dis}able-new-dtags... no
checking whether /nxb-bin/usr/bin/cc  has an option to discard unneeded shared libraries... no
checking whether /nxb-bin/usr/bin/cc  has an option to link in whole static archives... no
checking whether /nxb-bin/usr/bin/c++  supports -stdlib=libc++... no
checking whether _LIBCPP_VERSION is declared... yes
checking how to enable C++ '14 features in /nxb-bin/usr/bin/c++ ... no
configure: error: Please upgrade to a compiler supporting C++ '14, such as GCC 5 or newer.
===>  Script "configure" failed unexpectedly.
Please report the problem to jwb_at_FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/biology/ncbi-blast+/work/ncbi-blast-2.12.0+-src/c++/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/biology/ncbi-blast+
Received on Thu Jul 29 2021 - 03:28:58 UTC

Original text of this message