[package - 122arm64-quarterly][games/anki] Failed for anki-2.1.35_11 in build

From: <pkg-fallout_at_FreeBSD.org>
Date: Tue, 27 Jul 2021 15:11:03 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     kai_at_FreeBSD.org
Log URL:        http://ampere1.nyi.freebsd.org/data/122arm64-quarterly/861e2a11357f/logs/anki-2.1.35_11.log
Build URL:      http://ampere1.nyi.freebsd.org/build.html?mastername=122arm64-quarterly&build=861e2a11357f
Log:

=>> Building games/anki
build started at Tue Jul 27 15:09:17 UTC 2021
port directory: /usr/ports/games/anki
package name: anki-2.1.35_11
building for: FreeBSD 122arm64-quarterly-job-11 12.2-RELEASE FreeBSD 12.2-RELEASE arm64
maintained by: kai_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-16-g00a37fcb
Host OSVERSION: 1400008
Jail OSVERSION: 1202000
Job Id: 11

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1202000
UNAME_v=FreeBSD 12.2-RELEASE
UNAME_r=12.2-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-16-g00a37fcb
MASTERMNT=/usr/local/poudriere/data/.m/122arm64-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/122arm64-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=122arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/122arm64-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for anki-2.1.35_11:
     NLS=on: Native Language Support
====> Options available for the group PLAYER
     MPLAYER=off: MPlayer media player support
     MPV=on: mpv media player support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
kai_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl  PERL_USE_UNSAFE_INC=1 PYTHON="/usr/local/bin/python3.8" XDG_DATA_HOME=/wrkdirs/usr/ports/games/anki/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/anki/work  HOME=/wrkdirs/usr/ports/games/anki/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/games/anki/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
CARGO_HOME=/wrkdirs/usr/ports/games/anki/work/cargo-home  CARGO_BUILD_JOBS=2  CARGO_TARGET_DIR=/wrkdirs/usr/ports/games/anki/work/target  RUST_BACKTRACE=1  RUSTC=/usr/local/bin/rustc  RUSTDOC=/usr/local/bin/rustdoc  RUSTFLAGS=" -C linker=cc -C link-arg=-fstack-protector-strong" OPENSSL_LIB_DIR=/usr/lib  OPENSSL_INCLUDE_DIR=/usr/include npm_config_offline=true PERL_USE_UNSAFE_INC=1 OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/games/anki/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/anki/work  HOME=/wrkdirs/usr/ports/games/anki/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/games/anki/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS="  -fstack-protector-strong " LIBS=""
   CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
_PY_SONAME=.cpython-38 MPLAYER="_at_comment " NO_MPLAYER="" MPV="" NO_MPV="_at_comment " NLS="" NO_NLS="_at_comment " PYQT_APIDIR=share/PyQt5/3.8/qsci  PYQT_DOCDIR=share/doc/PyQt5/3.8  PYQT_EXAMPLEDIR=share/examples/PyQt5/3.8  PYQT_SIPDIR=/usr/local/lib/python3.8/site-packages/PyQt5/bindings  PYQT_DESIGNERDIR=/designer/PyQt5/3.8  PYQT_QMLDIR=/PyQt5/3.8  PYQT_SIPVERSION=5.5.0  PYQT_QSCIVERSION=2.12.0  PYQT_PYQTVERSION=5.15.4 PYTHON_INCLUDEDIR=include/python3.8  PYTHON_LIBDIR=lib/python3.8  PYTHON_PLATFORM=freebsd12  PYTHON_SITELIBDIR=lib/python3.8/site-packages  PYTHON_SUFFIX=38  PYTHON_EXT_SUFFIX=.cpython-38  PYTHON_VER=3.8  PYTHON_VERSION=python3.8 PYTHON2="_at_comment " PYTHON3="" OSREL=12.2 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib PERL_VERSION=5.32.1  PERL_VER=5.32  PERL5_MAN1=lib/perl5/site_perl/man/man1  PERL5_MAN3=lib/perl5/site_perl/man/man3  SITE_PERL=lib/perl5/site_perl  SITE_ARCH=lib/perl5/site_perl/mach/5.32 DOCSDIR="share/doc/anki"  EXAMPLESDIR="share/examp
 les/anki"  DATADIR="share/anki"  WWWDIR="www/anki"  ETCDIR="etc/anki"
--End PLIST_SUB--

--SUB_LIST--
MPLAYER="_at_comment " NO_MPLAYER="" MPV="" NO_MPV="_at_comment " NLS="" NO_NLS="_at_comment " PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/anki DOCSDIR=/usr/local/share/doc/anki EXAMPLESDIR=/usr/local/share/examples/anki  WWWDIR=/usr/local/www/anki ETCDIR=/usr/local/etc/anki
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 10.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-10.0.1-0-gef32c611aa2) Target: aarch64-unknown-freebsd12.2 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 10.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-10.0.1-0-gef32c611aa2) Target: aarch64-unknown-freebsd12.2 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 10.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-10.0.1-0-gef32c611aa2) Target: aarch64-unknown-freebsd12.2 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=aarch64
OPSYS=FreeBSD
_OSRELEASE=12.2-RELEASE
OSREL=12.2
OSVERSION=1202000
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  1048576
stack size              (kbytes, -s)  1048576
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses EOL Python 2.7 via www/py-qt5-webengine.

It is scheduled to be removed on or after 2021-06-23.

===>  License AGPLv3+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   anki-2.1.35_11 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.16.3.txz
[122arm64-quarterly-job-11] Installing pkg-1.16.3...
[122arm64-quarterly-job-11] Extracting pkg-1.16.3: .......... done
===>   anki-2.1.35_11 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of anki-2.1.35_11
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses EOL Python 2.7 via www/py-qt5-webengine.

It is scheduled to be removed on or after 2021-06-23.

===>  License AGPLv3+ accepted by the user
===> Fetching all distfiles required by anki-2.1.35_11 for building
===========================================================================
=======================<phase: checksum       >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses EOL Python 2.7 via www/py-qt5-webengine.

It is scheduled to be removed on or after 2021-06-23.

===>  License AGPLv3+ accepted by the user
===> Fetching all distfiles required by anki-2.1.35_11 for building
=> SHA256 Checksum OK for python/anki-npm-cache-2.1.35.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/addr2line-0.13.0.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/adler-0.2.3.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/aho-corasick-0.7.14.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/anyhow-1.0.33.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/arc-swap-0.4.7.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/arrayref-0.3.6.tar.gz.
=> SHA256 Checksum OK for python/rust/crates/arrayvec-0.4.12.tar.gz.
<snip>
[122arm64-quarterly-job-11] |   |   | `-- Extracting polkit-0.119: ......... done
[122arm64-quarterly-job-11] |   |   `-- Extracting consolekit2-1.2.3: ......... done
[122arm64-quarterly-job-11] |   |   `-- Installing fftw3-3.3.9...
[122arm64-quarterly-job-11] |   |   `-- Extracting fftw3-3.3.9: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing fftw3-float-3.3.9...
[122arm64-quarterly-job-11] |   |   `-- Extracting fftw3-float-3.3.9: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing libXtst-1.2.3_2...
[122arm64-quarterly-job-11] |   |   `-- Extracting libXtst-1.2.3_2: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing libltdl-2.4.6...
[122arm64-quarterly-job-11] |   |   `-- Extracting libltdl-2.4.6: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing libsndfile-1.0.31...
[122arm64-quarterly-job-11] |   |   | `-- Installing flac-1.3.3_1...
[122arm64-quarterly-job-11] |   |   | `-- Extracting flac-1.3.3_1: .......... done
[122arm64-quarterly-job-11] |   |   `-- Extracting libsndfile-1.0.31: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing libsoxr-0.1.3_2...
[122arm64-quarterly-job-11] |   |   `-- Extracting libsoxr-0.1.3_2: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing orc-0.4.31...
[122arm64-quarterly-job-11] |   |   `-- Extracting orc-0.4.31: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing speexdsp-1.2.0...
[122arm64-quarterly-job-11] |   |   `-- Extracting speexdsp-1.2.0: .......... done
[122arm64-quarterly-job-11] |   |   `-- Installing webrtc-audio-processing0-0.3.1_2...
[122arm64-quarterly-job-11] |   |   `-- Extracting webrtc-audio-processing0-0.3.1_2: .......... done
===> Creating groups.
Creating group 'pulse' with gid '563'.
Creating group 'pulse-access' with gid '564'.
Creating group 'pulse-rt' with gid '557'.
===> Creating users
Creating user 'pulse' with uid '563'.
[122arm64-quarterly-job-11] |   | `-- Extracting pulseaudio-14.2: .......... done
[122arm64-quarterly-job-11] |   `-- Extracting alsa-plugins-1.2.2: .......... done
[122arm64-quarterly-job-11] |   `-- Installing jsoncpp-1.9.4...
[122arm64-quarterly-job-11] |   `-- Extracting jsoncpp-1.9.4: .......... done
[122arm64-quarterly-job-11] |   `-- Installing libXcomposite-0.4.5,1...
[122arm64-quarterly-job-11] |   `-- Extracting libXcomposite-0.4.5,1: .......... done
[122arm64-quarterly-job-11] |   `-- Installing libXcursor-1.2.0...
[122arm64-quarterly-job-11] |   `-- Extracting libXcursor-1.2.0: .......... done
[122arm64-quarterly-job-11] |   `-- Installing libpci-3.7.0_1...
[122arm64-quarterly-job-11] |   `-- Extracting libpci-3.7.0_1: .......... done
[122arm64-quarterly-job-11] |   `-- Installing nss-3.68...
[122arm64-quarterly-job-11] |   `-- Extracting nss-3.68: .......... done
[122arm64-quarterly-job-11] |   `-- Installing re2-20210601...
[122arm64-quarterly-job-11] |   `-- Extracting re2-20210601: .......... done
[122arm64-quarterly-job-11] |   `-- Installing snappy-1.1.9_1...
[122arm64-quarterly-job-11] |   `-- Extracting snappy-1.1.9_1: .......... done
[122arm64-quarterly-job-11] `-- Extracting qt5-webengine-5.15.2_3: .......... done
[122arm64-quarterly-job-11] Extracting py38-qt5-webengine-5.15.4_1: .......... done
=====
Message from alsa-lib-1.2.2:

--
===>   NOTICE:

The alsa-lib port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
=====
Message from pulseaudio-14.2:

--
Pulseaudio tries to determine default values for FreeBSD OSS driver at first
start, based on /dev/sndstat output. The hw.snd.default_unit sysctl may affect
these values, but restart of the Pulseaudio might be needed to rescan it again,
e.g. `pacmd exit`.

Pulseaudio has separate input and output configure lines. You can change them
with using following commands:

To change the default sink (output):
# pacmd set-default-sink 3
To change the default source (input):
# pacmd set-default-source 3

This can also be set in /usr/local/etc/pulse/default.pa

Replace the number '3' with the new default you want to set.

The audio/freedesktop-sound-theme is needed if the default sound files
are uncommented in the /usr/local/etc/pulse/default.pa file.
=====
Message from alsa-plugins-1.2.2:

--
===>   NOTICE:

The alsa-plugins port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
=====
Message from qt5-webengine-5.15.2_3:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py38-qt5-webengine-5.15.4_1:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses EOL Python 2.7 via www/qt5-webengine.

It is scheduled to be removed on or after 2021-06-23.
===>   anki-2.1.35_11 depends on package: py38-qt5-webengine>=5.15.4 - found
===>   Returning to build of anki-2.1.35_11
===>   anki-2.1.35_11 depends on package: py38-qt5-widgets>=5.15.4 - found
===>   anki-2.1.35_11 depends on file: /usr/local/bin/python3.8 - found
===>   anki-2.1.35_11 depends on package: rust>=1.53.0 - not found
===>   Installing existing package /packages/All/rust-1.53.0.txz
[122arm64-quarterly-job-11] Installing rust-1.53.0...
[122arm64-quarterly-job-11] `-- Installing curl-7.77.0...
[122arm64-quarterly-job-11] `-- Extracting curl-7.77.0: .......... done
[122arm64-quarterly-job-11] Extracting rust-1.53.0: .......... done
===>   anki-2.1.35_11 depends on package: rust>=1.53.0 - found
===>   Returning to build of anki-2.1.35_11
===>   anki-2.1.35_11 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-1.7.4,1.txz
[122arm64-quarterly-job-11] Installing pkgconf-1.7.4,1...
[122arm64-quarterly-job-11] Extracting pkgconf-1.7.4,1: .......... done
===>   anki-2.1.35_11 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of anki-2.1.35_11
===>   anki-2.1.35_11 depends on executable: update-desktop-database - found
===>   anki-2.1.35_11 depends on package: gmake>=4.3 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-core>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-gui>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-network>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-printsupport>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-sip>=5.5.0 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-svg>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-webchannel>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-webengine>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-widgets>=5.15.4 - found
===>   anki-2.1.35_11 depends on package: py38-qt5-xml>=5.15.4 - not found
===>   Installing existing package /packages/All/py38-qt5-xml-5.15.4.txz
[122arm64-quarterly-job-11] Installing py38-qt5-xml-5.15.4...
[122arm64-quarterly-job-11] `-- Installing qt5-xml-5.15.2_1...
[122arm64-quarterly-job-11] `-- Extracting qt5-xml-5.15.2_1: .......... done
[122arm64-quarterly-job-11] Extracting py38-qt5-xml-5.15.4: .......... done
===>   anki-2.1.35_11 depends on package: py38-qt5-xml>=5.15.4 - found
===>   Returning to build of anki-2.1.35_11
===>   anki-2.1.35_11 depends on file: /usr/local/bin/python3.8 - found
===>   anki-2.1.35_11 depends on executable: msgfmt - not found
===>   Installing existing package /packages/All/gettext-tools-0.21.txz
[122arm64-quarterly-job-11] Installing gettext-tools-0.21...
[122arm64-quarterly-job-11] `-- Installing libtextstyle-0.21...
[122arm64-quarterly-job-11] `-- Extracting libtextstyle-0.21: .......... done
[122arm64-quarterly-job-11] Extracting gettext-tools-0.21: .......... done
===>   anki-2.1.35_11 depends on executable: msgfmt - found
===>   Returning to build of anki-2.1.35_11
===>   anki-2.1.35_11 depends on package: perl5>=5.32.r0<5.33 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   anki-2.1.35_11 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for anki-2.1.35_11
/bin/mkdir -p /wrkdirs/usr/ports/games/anki/work/.bin && /bin/ln -s /usr/local/bin/python3.8 /wrkdirs/usr/ports/games/anki/work/.bin/python
===========================================================================
=======================<phase: build          >============================
===>  Building for anki-2.1.35_11
echo 84dcaa86 > /wrkdirs/usr/ports/games/anki/work/anki-2.1.35/meta/buildhash
gmake[1]: Entering directory '/wrkdirs/usr/ports/games/anki/work/anki-2.1.35'
gmake[2]: Entering directory '/wrkdirs/usr/ports/games/anki/work/anki-2.1.35'
gmake[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
sed -i.bak 's/.*automatically updated.*/version = "2.1.35"  # automatically updated/' Cargo.toml
rm Cargo.toml.bak
touch ../proto/backend.proto
FTL_TEMPLATE_DIRS="../qt/ftl" FTL_LOCALE_DIRS="../qt/ftl/repo/desktop" CARGO_TARGET_DIR="target" MACOSX_DEPLOYMENT_TARGET=10.7 \
	maturin build -i "/usr/local/bin/python3.8" -o "../dist" --cargo-extra-args=' --release --verbose'
💥 maturin failed
  Caused by: Could guess the current platform
gmake[2]: *** [Makefile:72: .build/build] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/games/anki/work/anki-2.1.35/rspy'
gmake[1]: *** [Makefile:119: build] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/games/anki/work/anki-2.1.35'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/games/anki
Received on Tue Jul 27 2021 - 15:11:03 UTC

Original text of this message