[package - main-arm64-default][emulators/yaze-ag] Failed for yaze-ag-2.51.0 in build

From: <pkg-fallout_at_FreeBSD.org>
Date: Tue, 27 Jul 2021 12:22:16 GMT
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     se_at_FreeBSD.org
Log URL:        http://ampere2.nyi.freebsd.org/data/main-arm64-default/pe8cfea34d340_s47aeda7b70/logs/yaze-ag-2.51.0.log
Build URL:      http://ampere2.nyi.freebsd.org/build.html?mastername=main-arm64-default&build=pe8cfea34d340_s47aeda7b70
Log:

=>> Building emulators/yaze-ag
build started at Tue Jul 27 12:22:10 UTC 2021
port directory: /usr/ports/emulators/yaze-ag
package name: yaze-ag-2.51.0
building for: FreeBSD main-arm64-default-job-06 14.0-CURRENT FreeBSD 14.0-CURRENT 1400026 arm64
maintained by: se_at_FreeBSD.org
Makefile ident: 
Poudriere version: 3.2.8-8-gaf08dbda
Host OSVERSION: 1400008
Jail OSVERSION: 1400026
Job Id: 06




!!! Jail is newer than host. (Jail: 1400026, Host: 1400008) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1400026
UNAME_v=FreeBSD 14.0-CURRENT 1400026
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-8-gaf08dbda
MASTERMNT=/usr/local/poudriere/data/.m/main-arm64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-arm64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-arm64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-arm64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for yaze-ag-2.51.0:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
se_at_FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work  HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/emulators/yaze-ag/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
BINDIR=/usr/local/bin  DESTDIR="/wrkdirs/usr/ports/emulators/yaze-ag/work/stage"  DOCDIR=/usr/local/share/doc/yaze-ag  DOCHTMLDIR=/usr/local/share/doc/yaze-ag/html  DSKDIR=/usr/local/share/yaze-ag/disks  LIBDIR=/usr/local/share/yaze-ag  LIBEXECDIR=/usr/local/libexec  MANDIR=/usr/local/man/man1  OPTIMIZE="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing " XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work  HOME=/wrkdirs/usr/ports/emulators/yaze-ag/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/emulators/yaze-ag/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-alia
 sing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/yaze-ag"  EXAMPLESDIR="share/examples/yaze-ag"  DATADIR="share/yaze-ag"  WWWDIR="www/yaze-ag"  ETCDIR="etc/yaze-ag"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/yaze-ag DOCSDIR=/usr/local/share/doc/yaze-ag EXAMPLESDIR=/usr/local/share/examples/yaze-ag  WWWDIR=/usr/local/www/yaze-ag ETCDIR=/usr/local/etc/yaze-ag
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 12.0.1 (git_at_github.com:llvm/llvm-project.git llvmorg-12.0.1-0-gfed41342a82f) Target: aarch64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=aarch64
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400026
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  1048576
stack size              (kbytes, -s)  1048576
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   yaze-ag-2.51.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.0.pkg
[main-arm64-default-job-06] Installing pkg-1.17.0...
[main-arm64-default-job-06] Extracting pkg-1.17.0: .......... done
===>   yaze-ag-2.51.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of yaze-ag-2.51.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
=> yaze-ag-2.51.0.tar.gz doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/devel/yaze-ag-2.51.0.tar.gz
yaze-ag-2.51.0.tar.gz                                 3751 kB 2247 kBps    01s
===> Fetching all distfiles required by yaze-ag-2.51.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by yaze-ag-2.51.0 for building
=> SHA256 Checksum OK for yaze-ag-2.51.0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by yaze-ag-2.51.0 for building
===>  Extracting for yaze-ag-2.51.0
=> SHA256 Checksum OK for yaze-ag-2.51.0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for yaze-ag-2.51.0
===>  Applying FreeBSD patches for yaze-ag-2.51.0 from /usr/ports/emulators/yaze-ag/files
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===>   yaze-ag-2.51.0 depends on shared library: libreadline.so - not found
===>   Installing existing package /packages/All/readline-8.1.1.pkg
[main-arm64-default-job-06] Installing readline-8.1.1...
[main-arm64-default-job-06] `-- Installing indexinfo-0.3.1...
[main-arm64-default-job-06] `-- Extracting indexinfo-0.3.1: .... done
[main-arm64-default-job-06] Extracting readline-8.1.1: .......... done
===>   yaze-ag-2.51.0 depends on shared library: libreadline.so - found (/usr/local/lib/libreadline.so)
===>   Returning to build of yaze-ag-2.51.0
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for yaze-ag-2.51.0
===========================================================================
=======================<phase: build          >============================
===>  Building for yaze-ag-2.51.0
--- yaze.o ---
--- mem_mmu.o ---
--- yaze.o ---
clang  -pedantic -Wall -Wshadow  -Wpointer-arith -Wnested-externs -Winline  -Wno-attributes -Wno-char-subscripts -Wno-unused-variable -O3 -march=x86-64 -DBIOS -D__EXTENSIONS__ -DMMU -DBOOTSYS -DMULTIO -DLIBDIR=\"/usr/local/share/yaze-ag/\"  -DBUILD=\"" (build for AMD (barcelona, 64Bit))"\" -c yaze.c -o yaze.o
--- mem_mmu.o ---
clang  -pedantic -Wall -Wshadow  -Wpointer-arith -Wnested-externs -Winline  -Wno-attributes -Wno-char-subscripts -Wno-unused-variable -O3 -march=x86-64 -DBIOS -D__EXTENSIONS__ -DMMU -DBOOTSYS -DMULTIO -DLIBDIR=\"/usr/local/share/yaze-ag/\"  -DBUILD=\"" (build for AMD (barcelona, 64Bit))"\" -c mem_mmu.c -o mem_mmu.o
--- yaze.o ---
clang: error: the clang compiler does not support '-march=x86-64'
--- mem_mmu.o ---
clang: error: the clang compiler does not support '-march=x86-64'
*** [mem_mmu.o] Error code 1

make[1]: stopped in /wrkdirs/usr/ports/emulators/yaze-ag/work/yaze-ag-2.51.0
--- yaze.o ---
*** [yaze.o] Error code 1

make[1]: stopped in /wrkdirs/usr/ports/emulators/yaze-ag/work/yaze-ag-2.51.0
2 errors

make[1]: stopped in /wrkdirs/usr/ports/emulators/yaze-ag/work/yaze-ag-2.51.0
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/yaze-ag
Received on Tue Jul 27 2021 - 12:22:16 UTC

Original text of this message