[package - main-riscv64-default][comms/telldus-core] Failed for telldus-core-2.1.2_7 in build

From: <pkg-fallout_at_FreeBSD.org>
Date: Sat, 04 Dec 2021 22:28:43 UTC
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     johan@stromnet.se
Log URL:        http://beefy7.nyi.freebsd.org/data/main-riscv64-default/pd684832c1aed_sfc21aafe5f/logs/telldus-core-2.1.2_7.log
Build URL:      http://beefy7.nyi.freebsd.org/build.html?mastername=main-riscv64-default&build=pd684832c1aed_sfc21aafe5f
Log:

=>> Building comms/telldus-core
build started at Sat Dec  4 22:27:44 UTC 2021
port directory: /usr/ports/comms/telldus-core
package name: telldus-core-2.1.2_7
building for: FreeBSD main-riscv64-default-job-12 14.0-CURRENT FreeBSD 14.0-CURRENT 1400043 riscv
maintained by: johan@stromnet.se
Makefile ident: 
Poudriere version: 3.2.8-21-g883afb07
Host OSVERSION: 1400008
Jail OSVERSION: 1400043
Job Id: 12




!!! Jail is newer than host. (Jail: 1400043, Host: 1400008) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/sh
UNAME_p=riscv64
UNAME_m=riscv
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1400043
UNAME_v=FreeBSD 14.0-CURRENT 1400043
UNAME_r=14.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
MM_CHARSET=UTF-8
LANG=C.UTF-8
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-21-g883afb07
MASTERMNT=/usr/local/poudriere/data/.m/main-riscv64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/main-riscv64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=main-riscv64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/main-riscv64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
johan@stromnet.se
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/comms/telldus-core/work/.cache  HOME=/wrkdirs/usr/ports/comms/telldus-core/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/comms/telldus-core/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
NINJA_STATUS="[%p %s/%t] " XDG_DATA_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  XDG_CACHE_HOME=/wrkdirs/usr/ports/comms/telldus-core/work/.cache  HOME=/wrkdirs/usr/ports/comms/telldus-core/work TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/comms/telldus-core/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES DESTDIR=/wrkdirs/usr/ports/comms/telldus-core/work/stage PREFIX=/usr/local  LOCALBASE=/usr/local  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -march=rv64imafdc -mabi=lp64d  -fstack-protector-strong -fno-strict-aliasing "  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -fno-strict-aliasing  -Wno-c++11-narrowing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_I
 NSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release" OSREL=14.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/telldus-core"  EXAMPLESDIR="share/examples/telldus-core"  DATADIR="share/telldus-core"  WWWDIR="www/telldus-core"  ETCDIR="etc/telldus-core"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/telldus-core DOCSDIR=/usr/local/share/doc/telldus-core EXAMPLESDIR=/usr/local/share/examples/telldus-core  WWWDIR=/usr/local/www/telldus-core ETCDIR=/usr/local/etc/telldus-core
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=riscv
MACHINE_ARCH=riscv64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: riscv64-unknown-freebsd14.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: riscv64-unknown-freebsd14.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin "/nxb-bin/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-m" "elf64lriscv" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=yes
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=yes
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=yes
CC_OUTPUT_9d218390_f00456e5=yes
CC_OUTPUT_9d218390_65ad290d=yes
CC_OUTPUT_9d218390_f2776b26=yes
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=yes
CC_OUTPUT_9d218390_160933ec=yes
CC_OUTPUT_9d218390_fb62803b=yes
_OBJC_CCVERSION_9d218390=FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303) Target: riscv64-unknown-freebsd14.0 Thread model: posix InstalledDir: /nxb-bin/usr/bin
_OBJC_ALTCCVERSION_9d218390=none
ARCH=riscv64
OPSYS=FreeBSD
_OSRELEASE=14.0-CURRENT
OSREL=14.0
OSVERSION=1400043
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   telldus-core-2.1.2_7 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.17.5.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing pkg-1.17.5...
[main-riscv64-default-job-12] Extracting pkg-1.17.5: .......... done
===>   telldus-core-2.1.2_7 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of telldus-core-2.1.2_7
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by telldus-core-2.1.2_7 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
<snip>
===>   telldus-core-2.1.2_7 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.21.4_1.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing cmake-3.21.4_1...
[main-riscv64-default-job-12] `-- Installing curl-7.80.0...
[main-riscv64-default-job-12] |   `-- Installing ca_root_nss-3.71...
[main-riscv64-default-job-12] |   `-- Extracting ca_root_nss-3.71: ........ done
[main-riscv64-default-job-12] |   `-- Installing libnghttp2-1.46.0...
[main-riscv64-default-job-12] |   `-- Extracting libnghttp2-1.46.0: .......... done
[main-riscv64-default-job-12] |   `-- Installing libssh2-1.9.0_3,3...
[main-riscv64-default-job-12] |   `-- Extracting libssh2-1.9.0_3,3: .......... done
[main-riscv64-default-job-12] `-- Extracting curl-7.80.0: .......... done
[main-riscv64-default-job-12] `-- Installing expat-2.4.1...
[main-riscv64-default-job-12] `-- Extracting expat-2.4.1: .......... done
[main-riscv64-default-job-12] `-- Installing jsoncpp-1.9.5...
[main-riscv64-default-job-12] `-- Extracting jsoncpp-1.9.5: .......... done
[main-riscv64-default-job-12] `-- Installing libarchive-3.5.2,1...
[main-riscv64-default-job-12] |   `-- Installing liblz4-1.9.3,1...
[main-riscv64-default-job-12] |   `-- Extracting liblz4-1.9.3,1: .......... done
[main-riscv64-default-job-12] |   `-- Installing zstd-1.5.0...
[main-riscv64-default-job-12] |   `-- Extracting zstd-1.5.0: .......... done
[main-riscv64-default-job-12] `-- Extracting libarchive-3.5.2,1: .......... done
[main-riscv64-default-job-12] `-- Installing libuv-1.42.0...
[main-riscv64-default-job-12] `-- Extracting libuv-1.42.0: .......... done
[main-riscv64-default-job-12] `-- Installing rhash-1.4.2...
[main-riscv64-default-job-12] `-- Extracting rhash-1.4.2: .......... done
[main-riscv64-default-job-12] Extracting cmake-3.21.4_1: .......... done
=====
Message from ca_root_nss-3.71:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
===>   telldus-core-2.1.2_7 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of telldus-core-2.1.2_7
===>   telldus-core-2.1.2_7 depends on executable: ninja - not found
===>   Installing existing package /packages/All/ninja-1.10.2,2.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing ninja-1.10.2,2...
[main-riscv64-default-job-12] `-- Installing python38-3.8.12_1...
[main-riscv64-default-job-12] |   `-- Installing libffi-3.3_1...
[main-riscv64-default-job-12] |   `-- Extracting libffi-3.3_1: .......... done
[main-riscv64-default-job-12] |   `-- Installing mpdecimal-2.5.1...
[main-riscv64-default-job-12] |   `-- Extracting mpdecimal-2.5.1: .......... done
[main-riscv64-default-job-12] |   `-- Installing readline-8.1.1...
[main-riscv64-default-job-12] |   `-- Extracting readline-8.1.1: .......... done
[main-riscv64-default-job-12] `-- Extracting python38-3.8.12_1: .......... done
[main-riscv64-default-job-12] Extracting ninja-1.10.2,2: ........ done
=====
Message from python38-3.8.12_1:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py38-gdbm       databases/py-gdbm@py38
py38-sqlite3    databases/py-sqlite3@py38
py38-tkinter    x11-toolkits/py-tkinter@py38
===>   telldus-core-2.1.2_7 depends on executable: ninja - found
===>   Returning to build of telldus-core-2.1.2_7
===========================================================================
=======================<phase: lib-depends    >============================
===>   telldus-core-2.1.2_7 depends on shared library: libftdi.so - not found
===>   Installing existing package /packages/All/libftdi-0.20_16.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing libftdi-0.20_16...
[main-riscv64-default-job-12] `-- Installing boost-libs-1.72.0_6...
[main-riscv64-default-job-12] |   `-- Installing icu-70.1_1,1...
[main-riscv64-default-job-12] |   `-- Extracting icu-70.1_1,1: .......... done
[main-riscv64-default-job-12] `-- Extracting boost-libs-1.72.0_6: .......... done
[main-riscv64-default-job-12] Extracting libftdi-0.20_16: .......... done
=====
Message from boost-libs-1.72.0_6:

--
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   telldus-core-2.1.2_7 depends on shared library: libftdi.so - found (/usr/local/lib/libftdi.so)
===>   Returning to build of telldus-core-2.1.2_7
===>   telldus-core-2.1.2_7 depends on shared library: libconfuse.so - not found
===>   Installing existing package /packages/All/libconfuse-3.3_2.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing libconfuse-3.3_2...
[main-riscv64-default-job-12] Extracting libconfuse-3.3_2: .......... done
===>   telldus-core-2.1.2_7 depends on shared library: libconfuse.so - found (/usr/local/lib/libconfuse.so)
===>   Returning to build of telldus-core-2.1.2_7
===>   telldus-core-2.1.2_7 depends on shared library: libargp.so - not found
===>   Installing existing package /packages/All/argp-standalone-1.3_4.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing argp-standalone-1.3_4...
[main-riscv64-default-job-12] Extracting argp-standalone-1.3_4: ......... done
=====
Message from argp-standalone-1.3_4:

--
===>   NOTICE:

The argp-standalone port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing
===>   telldus-core-2.1.2_7 depends on shared library: libargp.so - found (/usr/local/lib/libargp.so)
===>   Returning to build of telldus-core-2.1.2_7
===>   telldus-core-2.1.2_7 depends on shared library: libiconv.so - not found
===>   Installing existing package /packages/All/libiconv-1.16.pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
[main-riscv64-default-job-12] Installing libiconv-1.16...
[main-riscv64-default-job-12] Extracting libiconv-1.16: .......... done
===>   telldus-core-2.1.2_7 depends on shared library: libiconv.so - found (/usr/local/lib/libiconv.so)
===>   Returning to build of telldus-core-2.1.2_7
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for telldus-core-2.1.2_7
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/comms/telldus-core/work/.build
-- The C compiler identification is Clang 13.0.0
-- The CXX compiler identification is Clang 13.0.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /nxb-bin/usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Deprecation Warning at CMakeLists.txt:3 (CMAKE_MINIMUM_REQUIRED):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Looking for pthread.h
-- Looking for pthread.h - found
-- Found Threads: TRUE  
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Checking for one of the modules 'libftdi'
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_COLOR_MAKEFILE
    CMAKE_CXX_FLAGS_DEBUG
    CMAKE_C_FLAGS_DEBUG
    CMAKE_C_FLAGS_RELEASE
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_VERBOSE_MAKEFILE
    ICONV_INCLUDE_DIR
    ICONV_LIBRARIES
    LIBICONV_INCLUDE_DIR
    LIBICONV_LIBRARIES
    LIBICONV_LIBRARY


-- Build files have been written to: /wrkdirs/usr/ports/comms/telldus-core/work/.build
===========================================================================
=======================<phase: build          >============================
===>  Building for telldus-core-2.1.2_7
[  1% 1/57] /nxb-bin/usr/bin/c++ -D_FREEBSD -I/usr/local/include -I/wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2 -O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -fno-strict-aliasing  -Wno-c++11-narrowing -O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -fno-strict-aliasing  -Wno-c++11-narrowing -fPIC -fvisibility=hidden -MD -MT common/CMakeFiles/TelldusCommon.dir/Event.cpp.o -MF common/CMakeFiles/TelldusCommon.dir/Event.cpp.o.d -o common/CMakeFiles/TelldusCommon.dir/Event.cpp.o -c /wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/common/Event.cpp
FAILED: common/CMakeFiles/TelldusCommon.dir/Event.cpp.o 
/nxb-bin/usr/bin/c++ -D_FREEBSD -I/usr/local/include -I/wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2 -O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -fno-strict-aliasing  -Wno-c++11-narrowing -O2 -pipe -march=rv64imafdc -mabi=lp64d -fstack-protector-strong -fno-strict-aliasing  -Wno-c++11-narrowing -fPIC -fvisibility=hidden -MD -MT common/CMakeFiles/TelldusCommon.dir/Event.cpp.o -MF common/CMakeFiles/TelldusCommon.dir/Event.cpp.o.d -o common/CMakeFiles/TelldusCommon.dir/Event.cpp.o -c /wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/common/Event.cpp
In file included from /wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/common/Event.cpp:7:
/wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/common/Event.h:12:11: fatal error: 'tr1/memory' file not found
        #include <tr1/memory>
                 ^~~~~~~~~~~~
1 error generated.
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make: stopped in /usr/ports/comms/telldus-core