Re: Mic does not work with Zoom on Chromium 92.0.4515.159.

From: Dave Cottlehuber <dch_at_skunkwerks.at>
Date: Thu, 07 Oct 2021 14:28:10 +0000
On Thu, 7 Oct 2021, at 12:10, Tomasz CEDRO wrote:
> Daaamn I am on a cal right now Chromium + Teams and no matter what
> setting sndio sound always goes to external speakers.
>
> Anyother change in Chrome???
>
> Please stay PulseAudio enadbled for f-- sake this is the only sensible
> solution that works on the fly.
>
> How more world will work like this :-(

funny, I find pulse audio infinitely frustrating.

Tomasz, 

your sndio tips help on my setup, now I can do audio confs in chromium,
with appropriate x11 screen sharing [1]:

                                             vvvvv
pcm0: <USB audio> at ? kld snd_uaudio (0p:0v/1r:2v) webcamd audio+video
pcm1: <USB audio> at ? kld snd_uaudio (1p:5v/0r:0v) default mojo+speakers
                                       ^^^^^
$ touch /dev/dsp0 /dev/dsp1
$ export AUDIORECDEVICE=rsnd/0
$ export AUDIOPLAYDEVICE=rsnd/1
$ sndiod -ddd &                  
  snd0 pst=cfg.default: rec=0:1 play=0:1 vol=32768 dup
  listen(/tmp/sndio-1002/sock0|ini): created
$ chrome --incognito --new-window --user-data-dir=$(mktemp -d -t incognito) https://whereby.com/ &

I enabled sndio as a daemon, including the env vars:

# /etc/rc.conf.d/sndiod 
sndiod_enable=YES
sndiod_env="AUDIORECDEVICE=rsnd/0 AUDIOPLAYDEVICE=rsnd/1"

I do notice that lossless music (e.g. flac or similar) isn't sounding as crisp, though, compared to my mojo chord USB-DAC. But I can live with this for meetings.

It would be nicer when this upstream firefox bug finally gets merged, and sharing a single monitor becomes possible:

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1412333

A+
Dave

# full /dev/sndstat
FreeBSD Audio Driver (64bit 2009061500/amd64)
Installed devices:
pcm0: <USB audio> at ? kld snd_uaudio (0p:0v/1r:2v)
	snddev flags=0x2e3<SIMPLEX,AUTOVCHAN,BUSY,MPSAFE,REGISTERED,VPC>
	[pcm0:record:dsp0.r0]: spd 32000, fmt 0x00200010, flags 0x00002100, 0x00000005
	interrupts 22788, overruns 0, feed 45576, hfree 2048, sfree 2048 [b:2048/1024/2|bs:2048/1024/2]
	channel flags=0x2100<BUSY,HAS_VCHAN>
	{hardware} -> feeder_root(0x00200010) -> feeder_mixer(0x00200010) -> {userland}
	pcm0:record:dsp0.r0[pcm0:virtual:dsp0.vr0]: spd 48000/32000, fmt 0x00200010, flags 0x10000000, 0x00000029
	interrupts 0, overruns 0, feed 0, hfree 0, sfree 32768 [b:0/0/0|bs:32768/256/128]
	channel flags=0x10000000<VIRTUAL>
	{hardware} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> feeder_rate(0x00200010 q:1 32000 -> 48000) -> {userland}
	pcm0:record:dsp0.r0[pcm0:virtual:dsp0.vr1]: spd 8000/32000, fmt 0x00100008/0x00200010, flags 0x10000000, 0x0000006b
	interrupts 0, overruns 0, feed 0, hfree 0, sfree 2048 [b:0/0/0|bs:2048/16/128]
	channel flags=0x10000000<VIRTUAL>
	{hardware} -> feeder_root(0x00200010) -> feeder_matrix(2.0 -> 1.0) -> feeder_volume(0x00100010) -> feeder_rate(0x00100010 q:1 32000 -> 8000) -> feeder_format(0x00100010 -> 0x00100008) -> {userland}
pcm1: <USB audio> at ? kld snd_uaudio (1p:5v/0r:0v) default
	snddev flags=0x2e3<SIMPLEX,AUTOVCHAN,BUSY,MPSAFE,REGISTERED,VPC>
	[pcm1:play:dsp1.p0]: spd 48000, fmt 0x00200010/0x00201000, flags 0x00002100, 0x00000006
	interrupts 27303, underruns 0, feed 27302, ready 0 [b:6144/3072/2|bs:4096/2048/2]
	channel flags=0x2100<BUSY,HAS_VCHAN>
	{userland} -> feeder_mixer(0x00200010) -> feeder_format(0x00200010 -> 0x00201000) -> {hardware}
	pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp0]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021
	interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8]
	channel flags=0x10000000<VIRTUAL>
	{userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware}
	pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp1]: spd 48000, fmt 0x00100010/0x00200010, flags 0x10000000, 0x00000061
	interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:4096/512/8]
	channel flags=0x10000000<VIRTUAL>
	{userland} -> feeder_root(0x00100010) -> feeder_matrix(1.0 -> 2.0) -> feeder_volume(0x00200010) -> {hardware}
	pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp2]: spd 48000, fmt 0x00100010/0x00200010, flags 0x10000000, 0x00000061
	interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:4096/512/8]
	channel flags=0x10000000<VIRTUAL>
	{userland} -> feeder_root(0x00100010) -> feeder_matrix(1.0 -> 2.0) -> feeder_volume(0x00200010) -> {hardware}
	pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp3]: spd 48000, fmt 0x00100010/0x00200010, flags 0x10000000, 0x00000061
	interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:4096/512/8]
	channel flags=0x10000000<VIRTUAL>
	{userland} -> feeder_root(0x00100010) -> feeder_matrix(1.0 -> 2.0) -> feeder_volume(0x00200010) -> {hardware}
	pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp4]: spd 44100/48000, fmt 0x00200010, flags 0x10000000, 0x00000029
	interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8]
	channel flags=0x10000000<VIRTUAL>
	{userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> feeder_rate(0x00200010 q:1 44100 -> 48000) -> {hardware}
No devices installed from userspace.
Received on Thu Oct 07 2021 - 14:28:10 UTC

Original text of this message