[Bug 274017] graphics/evince: fails to configure in poudriere with Dependency "gnome-desktop-3.0" not found

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 08 Dec 2023 03:58:02 UTC

Mikhail T. <mi@ALDAN.algebra.com> changed:

           What    |Removed                     |Added
                 CC|                            |mi@ALDAN.algebra.com

--- Comment #10 from Mikhail T. <mi@ALDAN.algebra.com> ---
Created attachment 246892
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=246892&action=edit

I have the same problem today with the (unmodified) port (evince-43.1):

Dependency libsecret-1 skipped: feature keyring disabled
Run-time dependency gtk+-unix-print-3.0 found: YES 3.24.34
Run-time dependency gio-unix-2.0 found: YES 2.78.1
Run-time dependency gobject-introspection-1.0 found: YES 1.78.1
Found CMake: /opt/bin/cmake (3.27.9)
Run-time dependency gnome-desktop-3.0 found: NO (tried pkgconfig and cmake)

meson.build:243:20: ERROR: Dependency "gnome-desktop-3.0" not found, tried
pkgconfig and cmake

Attaching the meson-log.txt.

> The culprit must have been my older (12/2020) ports options which I removed now for the build:

If a certain combination of options causes such a failure, that's still a bug,
is not it?

You are receiving this mail because:
You are the assignee for the bug.