[Bug 257063] archivers/star: Do not install 'gnutar' for it is broken

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 08 Jul 2021 23:33:10 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257063

--- Comment #3 from Robert Clausecker <fuz_at_fuz.su> ---
(In reply to ice from comment #2)

Okay I get your point.  Here's a proposed action plan:

 - I have reported the incompatible GNU tar emulation upstream, so with some
   luck, star will get better at mimicking GNU tar in the future.

 - I am going to make installing a gnutar binary optional with a
   non-default option as I agree that the behaviour is a bit surprising.
   I am planning to push this change with the next schilytools release
   which upstream told me will come in a week or two.

 - as a temporary workaround, unlink the gnutar binary:

       rm /usr/local/bin/gnutar

 - I believe I have identified the problem with firefox-esr.  In the file
   toolkit/moz.configure there is a line that says.

       check_prog('TAR', ('gnutar', 'gtar', 'tar'))

   If you change this line to say just

       check_prog('TAR', ('tar'))

   the problem should go away.  Please test this change and let me know if
   it fixes the issue for you.  If yes, I'll go ahead and file a patch
   for www/firefox-esr to harden its build in the presence of devel/star
   with the gnutar binary installed.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Thu Jul 08 2021 - 23:33:10 UTC

Original text of this message