[Bug 260239] www/firefox: Can't open URL in running instance

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 05 Dec 2021 12:12:07 UTC

            Bug ID: 260239
           Summary: www/firefox: Can't open URL in running instance
           Product: Ports & Packages
           Version: Latest
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: Individual Port(s)
          Assignee: gecko@FreeBSD.org
          Reporter: mer@klockrike.net
             Flags: maintainer-feedback?(gecko@FreeBSD.org)
          Assignee: gecko@FreeBSD.org

Created attachment 229923
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=229923&action=edit
Log printout from firefox-esr (good) and firefox (broken)

Executing "firefox <URL>" to open a URL in a running instance does not work
with the recent versions of the firefox port, the latest I have tried with is
firefox-95.0,2. It still works with firefox-esr.

Symptoms when running "firefox freebsd.org" when another Firefox instance is

1. A popup window is shown with the text "Firefox is already running, but is
not responding. To use Firefox, you must first close the existing Firefox
process, restart your device, or use a different profile."

2. Firefox writes this five times to standard error:
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't
find profile directory.

I have tested in a completely empty home directory (by setting $HOME). The logs
from the running instances are attached. The file includes two logs:

- firefox-esr-91.4.0,1, where opening the URL worked
- firefox-95.0,2, where opening the URL failed

You are receiving this mail because:
You are the assignee for the bug.