[Bug 256024] [zfs] `zpool upgrade' doesn't warn about updating bootloader anymore

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 21 May 2021 12:21:17 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256024

--- Comment #15 from Michael Gmelin <grembo_at_FreeBSD.org> ---
(In reply to stephan from comment #14)

Assuming the boot loader stays compatible with previous zpool versions it
wouldn't hurt - at least if freebsd-update can actually reliably determine the
bootloader setup used (e.g., label the boot partitions of *all* driver
containing the boot pool, not just the first one and then not be able to boot
in case one of the drives dies, and also not drives not used for booting,
including removable media).

Being able to do it in cases where it's clear cut and warn in other cases that
it might need to be done manually, might be a start - and of course realize all
the cases in which freebsd-update is run on something that doesn't involve the
bootloader, e.g., updating jails.

There's a lot of potential for breaking things in the process though.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Fri May 21 2021 - 12:21:17 UTC

Original text of this message