[Bug 258372] x11-fonts/fontconfig: cannot install as user (into non-default prefix)

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 26 Jan 2023 11:58:11 UTC

--- Comment #4 from Gerald Pfeifer <gerald@FreeBSD.org> ---
(In reply to John Hein from comment #2)
> I just tried 'make -C x11-fonts/fontconfig INSTALL_AS_USER=1
> LOCALBASE=/usr/local.user PKG_DBDIR=/usr/local.user/var/db/pkg
> PORT_DBDIR=/usr/local.user/var/db/ports install' as a non-root user.
> This is with pkg-1.18.4.  I did not get 'Fail to create
> /var/d/fontconfig:Permission denied'.

When I just tried again, and got that error, it was pkg 1.19.0 and
and PREFIX, LOCALBASE and PKG_DBDIR set to paths in my home directory.

Ahh, maybe I have an idea on why I am still getting this error and you
are not:

  % ll /var/db/fontconfig
  ls: /var/db/fontconfig: No such file or directory

Does /var/db/fontconfig exist on your system? If so, that might explain
why it does not try to generate that directory, whereas it does it in my
case - and fails.

You are receiving this mail because:
You are the assignee for the bug.