[Bug 221452] sysutils/consolekit2: session's active state lost when switching between virtual terminals

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 29 Oct 2021 16:10:33 UTC

--- Comment #37 from Jesper Schmitz Mouridsen <jsm@FreeBSD.org> ---
(In reply to Gleb Popov from comment #36)
Some years ago I tried to solve the x-display device thing, and I think it
worked well back then..

Since Linux and FreeBSD differ in tty values of processes: Linux ps gives the
actual tty of Xorg IIRC,  FreeBSD does not.

So in FreeBSD the get_x11_device in consolekit is obtained effectively by 
sudo  fstat /dev/ttyv*
USER     CMD          PID   FD MOUNT      INUM MODE         SZ|DV R/W NAME
root     Xorg        1652   13 /dev         93 crw-------   ttyv8 rw 

Is not vtnr9 == ttvy8 I do not recall if Console kit counts from zero, I do not
think so. But the above X is started with vt09 which is apparently ttyv8 if I
am not mistaken. So TL;DR I do not think it is a CK issue. Can you check if
slim works? or ck-launch-session startDEOFCHOICE, just narrow down the issue...

You are receiving this mail because:
You are the assignee for the bug.