Intel 7265 Bluetooth VID=0x8087 PID=0x0a2a ng_ubt / firmware problem

From: Tomasz CEDRO <>
Date: Mon, 11 Oct 2021 18:00:45 UTC
Hello world :-)

I have problem running Intel Bluetooth adapter that seems to be a part
of Intel WiFi AC7265 card (wifi works fine). This VID/PID seems to be
already inside ng_ubt module.

I have tried iwmbt-firmware with iwmbtfw utility but no success.
Running 13.0-STABLE.

# uname -a
FreeBSD 0xCFMX4 13.0-STABLE FreeBSD 13.0-STABLE #1
stable/13-n247289-13b194766e2: Wed Sep 15 02:49:53 CEST 2021
root@0xCFMX4:/usr/obj/usr/src/amd64.amd64/sys/GENERIC amd64

# hccontrol -n ubt0hci inquiry
hccontrol: Could not find HCI nodes
# hccontrol inquiry
hccontrol: Could not find HCI nodes

# usbconfig
ugen0.6: at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)

# grep -ri 0x0a2a /usr/src/*
sys/netgraph/bluetooth/drivers/ubt/ng_ubt_intel.c: {

# iwmbtfw -D -d ugen0.6
main: opening dev 0.6
iwmbtfw: main: device not found
iwmbtfw: main: Firmware download failed!

I even tried providing every single firmware file in a scripted loop
but none matches.

Did anyone run this interface with success on FreeBSD? :-)

Any hints appreciated :-)