EFI/loader show garbage in console when set to some resolution in loader.conf

From: Karel Gardas <gardask_at_gmail.com>
Date: Mon, 6 Sep 2021 18:44:13 +0200
Hello,

I'm attempting to set EFI console resolution in loader to 1920x1920. 
This is working fine on all 3 tested* combinations when interrupting 
loader with '3' key and then
issueing 'gop set 11' command and then 'boot' command.

However I'd like to make that permanent and here issue comes. I've tried 
both:

- edit /boot/loader.conf by adding
  'exec="gop set 11"'

- edit /boot/loader.conf by adding
  'efi_max_resolution="1920x1920"'

neither of those works on neither of 3 tested combinations where tested 
combinations are:

(1) 13.0 release
(2) 13.0-p4 (stable)
(3) 14.0 snapshot from 2.9.

The behavior is still the same. Screen blanks (like it would do gop set 
11), then switches to text mode to show loader UI and when kernel
is loaded it correctly shows that efi resolution is 1920x1920 but then 
when kernels boot, it produce just garbage to the console like loader 
and kernel resolution would be off
by some unknown number...

Is this is known issue, is there a known workaround for it? Or shall I 
report it properly to bugzilla?

Thanks!
Karel
Received on Mon Sep 06 2021 - 16:44:13 UTC

Original text of this message