Re: wlan0 no longer functional after n249128-a0c64a443e4c -> n249146-cb5c07649aa0

From: Oleg V. Nauman <oleg_at_theweb.org.ua>
Date: Mon, 06 Sep 2021 15:40:24 +0300
On 2021 M09 6, Mon 08:50:21 EEST Cy Schubert wrote:
> In message <2838567.hHqAuc6tWs_at_sigill.theweb.org.ua>, "Oleg V. Nauman"
> 
> writes:
> > On 2021 M09 5, Sun 15:52:50 EEST David Wolfskill wrote:
> > > Sorry I hadn't noticed this yesterday (so I could have repported it
> > > then), but after updating the "head" slice of my laptopp from:
> > > 
> > > FreeBSD g1-51.catwhisker.org 14.0-CURRENT FreeBSD 14.0-CURRENT #340
> > > main-n249128-a0c64a443e4c: Fri Sep  3 04:06:12 PDT 2021
> > > root_at_g1-55.catwhisker.org:/common/S4/obj/usr/src/amd64.amd64/sys/CANARY
> > > amd64 1400032 1400032
> > > 
> > > to:
> > > 
> > > FreeBSD g1-51.catwhisker.org 14.0-CURRENT FreeBSD 14.0-CURRENT #341
> > > main-n249146-cb5c07649aa0: Sat Sep  4 04:28:27 PDT 2021
> > > root_at_g1-51.catwhisker.org:/common/S4/obj/usr/src/amd64.amd64/sys/CANARY
> > > amd64 1400032 1400032
> > > 
> > > I find that while the em0 NIC still works, wlan0 (iwn(4) HW) does not:
> > > the WLAN LED doesn't light up.
> >  
> >  I am also experiencing issues with wlan after my current update to
> > 
> > 1f7a6325fe1b. I have checked ath(4) , run(4), rtwn(4) and all of them
> > demonstrating the same behavior  - wlan can not associate.
> > You can mitigate it by using security/wpa_supplicant from ports as
> > replacemen t
> > of wpa_supplicant in base.
> > 
> > .....
> > 
> > > I note that exactly the same hardware works OK in stable/12 and
> > > stable/13.
> > > 
> > > Peace,
> > > david
> 
> Can you grep wpa_supplicant in /var/log/messages? This will give us a clue.

/var/log/messages:Sep  6 15:21:55 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:21:56 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:21:57 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:22:44 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:30:11 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:30:32 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:30:34 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1
/var/log/messages:Sep  6 15:30:50 asus wpa_supplicant[310]: wlan0: CTRL-EVENT-
SCAN-FAILED ret=-1 retry=1

Compare it to successful association attempt while I was using wpa_supplicant 
from ports:

/var/log/messages:Sep  6 15:19:21 asus wpa_supplicant[326]: wlan0: 
Authentication with MAC timed out.
/var/log/messages:Sep  6 15:19:21 asus wpa_supplicant[326]: wlan0: CTRL-EVENT-
DISCONNECTED bssid=MAC reason=3 locally_generated=1
/var/log/messages:Sep  6 15:19:21 asus wpa_supplicant[326]: wlan0: CTRL-EVENT-
SSID-TEMP-DISABLED id=0 ssid="..." auth_failures=1 duration=10 
reason=CONN_FAILED
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: wlan0: CTRL-EVENT-
SSID-REENABLED id=0 ssid="..."
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: wlan0: Trying to 
associate with MAC (SSID='...' freq=2447 MHz)
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: Failed to add 
supported operating classes IE
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: wlan0: Associated 
with MAC
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: wlan0: WPA: Key 
negotiation completed with MAC [PTK=CCMP GTK=CCMP]
/var/log/messages:Sep  6 15:19:31 asus wpa_supplicant[326]: wlan0: CTRL-EVENT-
CONNECTED - Connection to MAC completed [id=0 id_str=]

wlan related settings from /etc/rc.conf

wlans_ath0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"


Thank you
Received on Mon Sep 06 2021 - 12:40:24 UTC

Original text of this message