Re: wlan0 no longer functional after n249128-a0c64a443e4c -> n249146-cb5c07649aa0

From: Idwer Vollering <vidwer_at_gmail.com>
Date: Mon, 6 Sep 2021 16:50:18 +0200
There's no core dump in /, wpa_supplicant connects to 802.11b/g/n
(there's no way to lock this, instead of having a mix of standards) on
2,4GHz.

/etc/wpa_supplicant.conf:
network={
ssid="some ssid"
scan_ssid=1
key_mgmt=WPA-PSK
psk="some key"
}

Op ma 6 sep. 2021 om 15:23 schreef Cy Schubert <Cy.Schubert_at_cschubert.com>:
>
> In message <CAPp9Orn0RYod1h+e_K171dk9ZiG4X9CK8XFHmqDT6DL4BRacBg_at_mail.gmail.c
> om>
> , Idwer Vollering writes:
> > Op ma 6 sep. 2021 om 07:53 schreef Cy Schubert <Cy.Schubert_at_cschubert.com>:
> > >
> > > In message <2838567.hHqAuc6tWs_at_sigill.theweb.org.ua>, "Oleg V. Nauman"
> > > writes:
> > > > On 2021 M09 5, Sun 15:52:50 EEST David Wolfskill wrote:
> > > > > Sorry I hadn't noticed this yesterday (so I could have repported it
> > > > > then), but after updating the "head" slice of my laptopp from:
> > > > >
> > > > > FreeBSD g1-51.catwhisker.org 14.0-CURRENT FreeBSD 14.0-CURRENT #340
> > > > > main-n249128-a0c64a443e4c: Fri Sep  3 04:06:12 PDT 2021
> > > > > root_at_g1-55.catwhisker.org:/common/S4/obj/usr/src/amd64.amd64/sys/CANARY
> > > > > amd64 1400032 1400032
> > > > >
> > > > > to:
> > > > >
> > > > > FreeBSD g1-51.catwhisker.org 14.0-CURRENT FreeBSD 14.0-CURRENT #341
> > > > > main-n249146-cb5c07649aa0: Sat Sep  4 04:28:27 PDT 2021
> > > > > root_at_g1-51.catwhisker.org:/common/S4/obj/usr/src/amd64.amd64/sys/CANARY
> > > > > amd64 1400032 1400032
> > > > >
> > > > > I find that while the em0 NIC still works, wlan0 (iwn(4) HW) does not:
> > > > > the WLAN LED doesn't light up.
> > > >
> > > >  I am also experiencing issues with wlan after my current update to
> > > > 1f7a6325fe1b. I have checked ath(4) , run(4), rtwn(4) and all of them
> > > > demonstrating the same behavior  - wlan can not associate.
> > > > You can mitigate it by using security/wpa_supplicant from ports as replac
> > emen
> > > > t
> > > > of wpa_supplicant in base.
> > > >
> > > > .....
> > > > >
> > > > > I note that exactly the same hardware works OK in stable/12 and stable/
> > 13.
> > > > >
> > > > > Peace,
> > > > > david
> > > >
> > >
> > > Can you grep wpa_supplicant in /var/log/messages? This will give us a clue.
> >
> > wpa_supplicant stops in wpa_driver_bsd_scan() -
> > https://github.com/freebsd/freebsd-src/blob/bd452dcbede69b1862c769f244948f94b
> > 86448b5/contrib/wpa/src/drivers/driver_bsd.c#L1315
> >
> > Here's some selected output from /var/log/messages.
> >
> > Before (built from commit a0c64a443e4cae67a5eea3a61a47d746866de3ee):
> >
> > Sep  6 13:29:40 <hostname> wpa_supplicant[45348]: Successfully
> > initialized wpa_supplicant
> > Sep  6 13:29:40 <hostname> wpa_supplicant[45348]: ioctl[SIOCS80211,
> > op=20, val=0, arg_len=7]: Invalid argument
> > Sep  6 13:29:40 <hostname> syslogd: last message repeated 1 times
> > Sep  6 13:29:46 <hostname> wpa_supplicant[45349]: wlan1: Trying to
> > associate with <mac> (SSID='<ssid>' freq=2447 MHz)
> > Sep  6 13:29:46 <hostname> wpa_supplicant[45349]: Failed to add
> > supported operating classes IE
> > Sep  6 13:29:46 <hostname> kernel: wlan1: link state changed to UP
> > Sep  6 13:29:46 <hostname> wpa_supplicant[45349]: wlan1: Associated with <mac
> > >
> > Sep  6 13:29:46 <hostname> dhclient[45401]: send_packet: No buffer
> > space available
> > Sep  6 13:29:46 <hostname> wpa_supplicant[45349]: wlan1: WPA: Key
> > negotiation completed with <mac> [PTK=CCMP GTK=CCMP]
> > Sep  6 13:29:46 <hostname> wpa_supplicant[45349]: wlan1:
> > CTRL-EVENT-CONNECTED - Connection to <mac> completed [id=0 id_str=]
> >
> > After (built from main):
> >
> > Sep  6 12:19:50 <hostname> wpa_supplicant[1236]: Successfully
> > initialized wpa_supplicant
> > Sep  6 12:19:50 <hostname> kernel: wlan1: Ethernet address: <mac>
> > Sep  6 12:19:50 <hostname> wpa_supplicant[1236]: ioctl[SIOCS80211,
> > op=20, val=0, arg_len=7]: Invalid argument
> > Sep  6 12:19:50 <hostname> syslogd: last message repeated 1 times
> > Sep  6 12:19:50 <hostname> wpa_supplicant[1237]: wlan1:
> > CTRL-EVENT-SCAN-FAILED ret=-1 retry=1
>
> Is there a wpa_supplicant.core dump in / ?
>
> Can you also send me a sanitized copy of wpa_supplicant.conf, please? I'm
> interested in the lines proto=, key_mgmt=, pairwise=, group=, eap=, and
> phase2=. You may not be using eap= or phase2=, which is fine. I'd like to
> see if there are any differences from what was tested. Though, looking at
> your outputs above you're probably using something like:
>
>         proto=RSN WPA
>         key_mgmt=WPA-PSK
>         pairwise=CCMP
>         group=CCMP
>
> Is this correct?
>
> If you try ports/securitiy/wpa_supplicant-devel (same codebase as in
> 14-CURRENT), does it work? (ports/security/wpa_supplicant is the old 2.9
> codebase.)
>
> What is your AP set for? 802.11g, 802.11n, 802.11ac?
>
>
> --
> Cheers,
> Cy Schubert <Cy.Schubert_at_cschubert.com>
> FreeBSD UNIX:  <cy_at_FreeBSD.org>   Web:  https://FreeBSD.org
> NTP:           <cy_at_nwtime.org>    Web:  https://nwtime.org
>
>         The need of the many outweighs the greed of the few.
>
>
Received on Mon Sep 06 2021 - 14:50:18 UTC

Original text of this message