Re: Updating to FreeBSD-current, can't mount -uw / : update: seemingly solved

From: Thomas Mueller <mueller6722_at_twc.com>
Date: Mon, 07 Jun 2021 22:11:09 +0000
> In both cases, the entry is INcorrect. Juraj is correct. The swap entry is
> missing sw
> IOW the line MUST read as:

> /dev/gpt/Sea1-18        none    swap    sw      0       0

> or

> /dev/gpt/Sea1-18        none    swap    sw,trimonce     0       0

> as appropriate for the media referenced.

>-Chris

As my last message stated, I found the missing field in /etc/fstab and corrected it.

Then "mount -u /" worked smoothly.

Perhaps one field too few makes the system look to the next line, so the whole /etc/fstab is misinterpreted.

I also pointed out that, from previous messages on this list, that etcupdate was replacing mergemaster.

But UPDATING at the top of the src tree still specifies mergemaster, so that would need to be updated.

There needs to be better documentation on the newer etcupdate.

Parameters for etcupdate are somewhat different in FreeBSD than in NetBSD, so the documentation needs to be updated.

I don't want to mess up by doing the wrong thing in NetBSD or FreeBSD.

Tom
Received on Mon Jun 07 2021 - 22:11:09 UTC

Original text of this message