Re: dumpdev AUTO in rc.conf does not work

From: Gary Jennejohn <gljennjohn_at_gmail.com>
Date: Mon, 9 Aug 2021 17:54:06 +0200
On Mon, 09 Aug 2021 15:45:19 +0000
"Dave Cottlehuber" <dch_at_skunkwerks.at> wrote:

> On Mon, 9 Aug 2021, at 06:54, Gary Jennejohn wrote:
> > On Sun, 8 Aug 2021 18:01:18 -0400
> > Daniel Morante via freebsd-current <freebsd-current_at_freebsd.org> wrote:  
> > > It looks though that this issue might only happen on arm64? I tried
> > >  to reproduce on amd64 without any luck.  
> 
> seems fine on arm64 14.0-CURRENT to me, this is built from src today BTW:
> 
> root_at_a01 /u/h/dch# gpart show
> =>      40  97677232  da0  GPT  (47G)  
>         40    532480    1  efi  (260M)
>     532520      2008       - free -  (1.0M)
>     534528   8388608    2  freebsd-swap  (4.0G)
>    8923136  88754136    3  freebsd-zfs  (42G)
> 
> root_at_a01 /u/h/dch# swapinfo -h
> Device              Size     Used    Avail Capacity
> /dev/da0p2          4.0G       0B     4.0G     0%
> 
> root_at_a01 /u/h/dch# dumpon -l
> da0p2
> 
> root_at_a01 /u/h/dch# sysrc dumpdev
> dumpdev: AUTO
> 
> root_at_a01 /u/h/dch# grep swap /etc/fstab 
> /dev/da0p2	none		swap	sw			0	
> 

Maybe his problem arises from use of /dev/gpt/swap?  That's a difference
between his setup and your setup.

> root_at_a01 /u/h/dch# grep -i dump /etc/rc.conf
> # Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
> dumpdev=AUTO
> 
> root_at_a01 /u/h/dch# uname -a
> FreeBSD a01.cabal5.net 14.0-CURRENT FreeBSD 14.0-CURRENT
> main-n248554-66b8eced972 GENERIC arm64
> 
> I've not got geli or gbde encrypted swap enabled, though, happy to
> try that out later.
> 


-- 
Gary Jennejohn
Received on Mon Aug 09 2021 - 15:54:06 UTC

Original text of this message