[Bug 283492] Please rename the "mb" macro in /usr/include/machine/atomic.h on arm7 to prevent collisions with mb variables in various projects

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 16 Jul 2026 14:16:19 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=283492

--- Comment #10 from commit-hook@FreeBSD.org ---
A commit in branch main references this bug:

URL:
https://cgit.FreeBSD.org/ports/commit/?id=3a7ad3ed54851dd27d5ed8a65c8aa77b246c5472

commit 3a7ad3ed54851dd27d5ed8a65c8aa77b246c5472
Author:     Robert Clausecker <fuz@FreeBSD.org>
AuthorDate: 2026-07-15 09:48:16 +0000
Commit:     Robert Clausecker <fuz@FreeBSD.org>
CommitDate: 2026-07-16 14:15:14 +0000

    audio/libopenshot-audio: patch armv7 build issue properly

    juce_BasicNativeHeaders.h pulls in <sys/user.h> which in turn pulls in
    <machine/atomic.h> transitively, which then defines a mb macro polluting
    the name space.  <sys/user.h> is only needed for struct kproc_info,
    which is only needed in juce_SystemStats_linux.cpp to check for
    P_TRACED.  Remove <sys/user.h> from juce_BasicNativeHeaders.h and only
    include it in juce_SystemStats_linux.cpp to avoid namespace pollution
    issues.

    I'll try to tackle the other ports using or bundling JUCE in a future
    commit.  As always, please try to unbundle dependencies if possible.

    Approved by:    portmgr (build fix blanket)
    MFH:            2026Q3
    PR:             283492

 ...LibraryCode_modules_juce__core_juce__core.cpp (gone) | 14 --------------
 ...s_juce__core_native_juce__BasicNativeHeaders.h (new) | 10 ++++++++++
 ...dules_juce__core_native_juce__SystemStats__linux.cpp | 17 ++++++++++++++---
 3 files changed, 24 insertions(+), 17 deletions(-)

-- 
You are receiving this mail because:
You are the assignee for the bug.