[Bug 269919] Cannot boot GENERIC-KASAN kernel

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 02 Mar 2023 18:20:23 UTC

            Bug ID: 269919
           Summary: Cannot boot GENERIC-KASAN kernel
           Product: Base System
           Version: CURRENT
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: bugs@FreeBSD.org
          Reporter: ashafer@badland.io

I'm having issues getting past the loader stage while trying to boot a
GENERIC-KASAN kernel on a Legion 5 laptop (FreeBSD 14.0-CURRENT #1
main-n261043-357492c99597). The kernel is loaded, zfs.ko is loaded, then it
hangs for a few seconds and prints out:

efi_check_space: Unable to expand staging area

This gets printed a couple of times, then the EFI frambuffer location is
printed, then the boot hangs.

I've tried bumpin the EFI_STAGING_AREA size to 512, and also to a ridiculously
high number, but that doesn't seem to do anything. I also tried reverting the
fix for PR 265019, but that didn't change anything either.

Any suggestions? Anyone else seeing something like this?

You are receiving this mail because:
You are the assignee for the bug.