[Bug 261181] 13-STABLE hang: swap_pager: indefinite wait buffer

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 15 Jan 2022 02:40:48 UTC

--- Comment #8 from tech-lists@zyxst.net ---
(In reply to ldoujin from comment #7)

(I thought I'd mention in passing that the initial issue should have been
raised on either the mailing lists or the forums, then if a bug is discovered
or no resolution there then it goes here in bugzilla, but we're here now, so)

I think the wired memory issue is a symptom with many potential causes and you
need to find the underlying problem. I don't think it's an OS problem (yet)
because firstly I'm running recent stable/13 on a number of servers and am not
seeing the issue and secondly the mailing lists would be very busy indeed if it
was a kernel problem concerning memory exhaustion.

When you're running 'git pull', from where is it pulling? 
Have you tried cloning to a different location?

I'd expect that if git had trouble writing to disk, that there'd be an error
message somewhere but maybe it never gets to that point before the whole system
freezes. If you can clone to a different location, then you've found the

The git that you're running, is it built from ports or is it a binary install
from freebsd's pkg servers?

What kernel are you using/is it modified? What does uname -a show?
If the kernel is modified, is the kernel config file (the one with the working
kernel) the same as the one that built the latest kernel?

What sysctls do you have set? Have you tried running systat immediately after
booting but just before running git? Have a look at man(1) systat for all the
options. Have you tried running git with truss(1) ? Are you using zfs with nfs?
Where is git meant to write to and how is it mounted?

You are receiving this mail because:
You are the assignee for the bug.