[Bug 260399] freebsd-update: Downloading patches often fails repeatedly

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 06 Jan 2022 23:07:54 UTC

--- Comment #9 from Some Signup <somesignup@icloud.com> ---
My apologies for the delay in trying to update my machines. It's such a pain
that I put it off until I can't put it off any longer.

If I run freebsd-update with --debug I get to see thousands of errors
downloading files. I can post them all here, but I don't think it's necessary.
A couple of sample but unrelated entries:

404 Error (ignored)

400 Error (ignored)

Some of these errors are wrong - the files exist, and in other cases the files
are indeed missing. A couple of examples:

<head><title>404 Not Found</title></head>
<center><h1>404 Not Found</h1></center>

curl --output thisoneisok.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   869  100   869    0     0   4456      0 --:--:-- --:--:-- --:--:--  4456

So there appear to be two errors here: genuinely missing files, and files which
exist but freebsd-update treats as missing.

Interestingly, when I tried in a browser to get to
'http://ipv4.aws.portsnap.freebsd.org/bp' I see an error in my browser trying
to get to 'http://ipv4.aws.portsnap.freebsd.org:8080/bp/'. I did not add this
8080 to the URL so I don't know where it's coming from (definitely not
something locally, no proxies). It would appear to be a redirection coming from

You are receiving this mail because:
You are on the CC list for the bug.