[Bug 268194] ntdp fails to start

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 06 Dec 2022 09:43:14 UTC

            Bug ID: 268194
           Summary: ntdp fails to start
           Product: Base System
           Version: 12.4-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: bin
          Assignee: bugs@FreeBSD.org
          Reporter: mdv@dualis.me

I upgraded two servers to FreeBSD 12.4-RELEASE using freebsd-update as soon as
it became available. After rebooting, ntpd fails to start:

+FreeBSD 12.4-RELEASE r372781 GENERIC amd64
+FreeBSD clang version 13.0.0 (git@github.com:llvm/llvm-project.git
+CPU: Intel Xeon E312xx (Sandy Bridge) (4245.58-MHz K8-class CPU)
+Launching APs: 2 1 3
+pid 695 (ntpd), jid 0, uid 123: exited on signal 11

I ran 'freebsd-update install' again as is mandatory and then tried to start
the daemon myself:
$ /usr/sbin/ntpd -n
 6 Dec 10:41:24 ntpd[39682]: ntpd 4.2.8p15-a (1): Starting
 6 Dec 10:41:24 ntpd[39682]: Command line: /usr/sbin/ntpd -n
 6 Dec 10:41:24 ntpd[39682]:
 6 Dec 10:41:24 ntpd[39682]: ntp-4 is maintained by Network Time Foundation,
 6 Dec 10:41:24 ntpd[39682]: Inc. (NTF), a non-profit 501(c)(3) public-benefit
 6 Dec 10:41:24 ntpd[39682]: corporation.  Support and training for ntp-4 are
 6 Dec 10:41:24 ntpd[39682]: available at https://www.nwtime.org/support
 6 Dec 10:41:24 ntpd[39682]:
Segmentation fault

This happens on both (identical) systems. 

Please let me know what additional information to provide in order to solve

You are receiving this mail because:
You are the assignee for the bug.