[Bug 263632] framework laptop crashes a few seconds after resuming from sleep

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 28 Apr 2022 20:09:11 UTC

--- Comment #7 from Jonathan Vasquez <jon@xyinn.org> ---
Some minor updates. I originally said that I have dumps disabled since this
system is running ZFS (and I remember there was an issue with ZFS + crash
dumps). Checking my servers config, I noticed I had written a comment about
this, which was that I disabled crash dumps because it caused issues when using
a mirrored swap configuration on ZFS. Since my laptop isn't using mirrored
swap, I re-enabled it (dumpdev="YES" (rather than "AUTO" or "NO)). The first
few tries I tried to put the computer to sleep and then wake it, the computer
didn't actually crash. I then switched dumpdev back to NO and the computer
crashed within seconds. Switching it back to YES started crashing again so
unfortunately that didn't lead to anything. However, I then tried to leave
dumpdev enabled and attempted to try and get some crash dumps from the sleep
wake. Since I originally installed FreeBSD with only 16 gb of physical swap
space, and this machine had 32 gb, I received messages regarding their is no
suitable dump device and that the save core is not run. To mitigate this, I
tried to just create a 64 GB swap file but that didn't work either.
Furthermore, trying to do a 'dumpon /dev/md0' yielded the following:

root@leslie:~ # dumpon -l
root@leslie:~ # dumpon /dev/md0
dumpon: ioctl(DIOCSKERNELDUMP): Operation not supported

I suppose this is related to swapfiles not being supported for crash dumps?


SirDice also mentioned that swap files probably can't be used for this. Since
it was pretty time consuming to get my system up to this point, I don't want to
do the work to reinstall the entire system just to realign the physical swap..
eventually I'll need to do it if I want to properly test out FreeBSD's
hibernate support however.

To finish off, the few times that I did wake up the system and it didn't
immediately crash, I did notice the following lines in dmesg, maybe this helps
in some way:

drmn0: GPU HANG: ecode 12:1:85dffffb, in MainThread [100939]
drmn0: Resetting rcs0 for stopped heartbeat on rcs0

You are receiving this mail because:
You are the assignee for the bug.