[Bug 263632] framework laptop crashes a few seconds after resuming from sleep

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 28 Apr 2022 17:17:34 UTC

--- Comment #5 from Jonathan Vasquez <jon@xyinn.org> ---
Hey Mark, Graham,


Thanks for that. I tried to ssh into the system but it was completely down. (I
connected before hand and verified I was able to actually ssh into the system,
then put it to sleep, resumed, and wasn't able to connect at all.. it probably
would have taken a few seconds for the network to come back up but by the time
it would have been available, the system had already crashed).

Also sounds good about the "ng_ubt" situation, that makes sense since I didn't
notice any USB enumeration delays necessarily during my boots recently so this
issue would have been fixed a while ago when it was first reported.


Funny you mentioned that. So I installed this system a few times over the past
few days on 13.0-RELEASE, 13.1-RC4, and a few times on a FreeBSD 14-CURRENT
snapshot (FreeBSD-14.0-CURRENT-amd64-20220421-b91a48693a5-254961) and when I
had tried to do a `pkg install drm-devel-kmod`. A few days ago when I was on
14-CURRENT and installed drm-devel-kmod, it worked fine. However when I
reinstalled it from the same snapshot on 14-CURRENT, the drm-devel-kmod package
wouldn't install anymore, I believe it complained about the version number
being too new (FreeBSD version specifically, I think it was incremented by 1).
At that point I decided it probably would be better for me to just check out
the latest CURRENT sources and rebuild world/kernel. Once I did that, I built
drm-devel-kmod from source, and that's what I'm using atm :).

You are receiving this mail because:
You are the assignee for the bug.