[Bug 263557] ACPI S3 doesn't resume on a MateBook X Pro 2021

From: <bugzilla-noreply_at_freebsd.org>
Date: Mon, 25 Apr 2022 08:54:49 UTC

            Bug ID: 263557
           Summary: ACPI S3 doesn't resume on a MateBook X Pro 2021
           Product: Base System
           Version: 13.1-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: kern
          Assignee: bugs@FreeBSD.org
          Reporter: freebsd.68fba@nospam.spacesurfer.com

Created attachment 233469
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=233469&action=edit

I have a MateBook X Pro 2021 with FreeBSD installed, ACPI S3 doesn't work, when
I run

acpiconf -s 3

the laptop appears to suspend fine, however it will not resume. When I press
the power button to resume the screen stays blank and eventually (after a
couple of minutes) the machine just reboots normally.
After booting back to FreeBSD the last entry in /var/log/messages is the
suspend message.

The laptop suspends and resumes fine on linux.

I tried building a minimal test kernel (MINIMAL config with NO_MODULES and nvme
and nvd devices added). I used FreeBSD 13 stable (commit
bb8e1dfbff30e5df97fa31c88f8218af054fe166). The test kernel had the same issues.

Debugging with:

sysctl debug.bootverbose=1
sysctl debug.acpi.suspend_bounce=1
acpiconf -s 3

worked fine.

I have attached the dmesg.boot, and the /var/log/messages for the
suspend/resume trial (messages.on.suspend) and for when I tried debugging
(messages.on.suspend.test). All theses were taken with the minimal test kernel.

You are receiving this mail because:
You are the assignee for the bug.