[Bug 209821] UEFI - installation media hangs when booting on ASUS P6P67 DELUXE

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 28 May 2021 15:47:11 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209821

David Sebek <dasebek_at_gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |dasebek_at_gmail.com

--- Comment #37 from David Sebek <dasebek_at_gmail.com> ---
I fixed the problem on my machine! The boot process always got stuck after it
printed the EFI framebuffer information. This is just before the kernel is
started.
The EFI bootloader first loads the kernel to a staging area (which is 64MB
large). Then, just before the kernel is started, the bootloader copies the
contents of the staging area to the address 0x200000 and jumps to the kernel
entry point that is now located at the expected location.
In my case, the LoaderCode and LoaderData memory pages of the EFI bootloader
happened to be located at addresses 0x2d1e000 and 0x2e01000, which were
overwritten by the contents of the staging area.
I made some changes to the code to avoid this issue, and now my system boots
just fine.

These bug reports also seem to be similar to this one: Bug 255073, Bug 219957

I am attaching a patch against the main git branch, please test if it fixes the
problem for you too.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Fri May 28 2021 - 15:47:11 UTC

Original text of this message