[Bug 256906] Network bridging settings are not fully applied from "rc .conf"

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 30 Jun 2021 14:31:32 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256906

            Bug ID: 256906
           Summary: Network bridging settings are not fully applied from
                    "rc .conf"
           Product: Base System
           Version: 13.0-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: conf
          Assignee: bugs_at_FreeBSD.org
          Reporter: assiszoom_at_gmail.com

I warn you right away that the network card, I-350T, is in good working order
and works without errors in bridge mode!

In the beginning, I even assembled my kernel and checked all the settings ...
Then I decided that an error might have crept in when assembling the driver or
something ...
I installed a readable system and first of all began to check the bridge
settings !:

4-port network card ...
Clean installation of the system!
Bridge settings:
ifconfig bridge create
ifconfig bridge0 addm igb0 addm igb1 addm igb2 addm igb3 up
ifconfig igb0 up
ifconfig igb1 up
ifconfig igb2 up
ifconfig igb3 up
ifconfig bridge0 inet 192.168.1.1/24

The bridge is working, the network is pinging ... everything is fine!
I enter this configuration into "rc.conf":
cloned_interfaces="bridge0"
ifconfig_bridge0="addm igb0 addm igb1 addm igb2 addm igb3 up"
ifconfig_igb0="up"
ifconfig_igb1="up"
ifconfig_igb2="up"
ifconfig_igb3="up"
ifconfig_bridge0="inet 192.168.1.1 netmask 255.255.255.0"

After rebooting the system, I see:
All igb0-igb3 UP interfaces...
bridge0 UP
There are NO connected interfaces to the bridge "bridge0"!
If you add the required interface to the bridge, the network will work!
ifconfig bridge0 addm igb0 up
ifconfig igb0 up

I tried to change the settings to rearrange them ... - either a bridge with all
interfaces or only a bridge with an IP address!

Tried adding additional settings to "rc.conf":
if_bridge_load="YES"
bridgestp_load="YES"
firewall_enable="YES"
firewall_type="open"
gateway_enable="YES"
,but that doesn't solve the problem!

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Wed Jun 30 2021 - 14:31:32 UTC

Original text of this message