[Bug 256836] Enable powerd by default on Raspbery Pi images

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 25 Jun 2021 19:18:17 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256836

            Bug ID: 256836
           Summary: Enable powerd by default on Raspbery Pi images
           Product: Base System
           Version: 13.0-RELEASE
          Hardware: arm64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: conf
          Assignee: bugs_at_FreeBSD.org
          Reporter: freebsd_at_darkain.com

During a normal installer process, the installer asks if a number of services
should be enabled by default. On the Raspberry Pi pre-built image, this is a
pre-installed system where these configuration options are never presented.

By default, the Raspberry Pi 4 is locked to only 600 MHz unless powerd is
running.

There is currently no obvious way to know that the performance of this board is
being limited without digging into sysctl. This could lead users to assume that
"FreeBSD is unoptimized and slow" compared to other OSes.

Right now, the only note I'm aware of about this particular issue is at the
very bottom of a Wiki page. This isn't a good end-user experience to have to
hunt down this information, especially if they don't even know what to look for
to begin with.

https://wiki.freebsd.org/arm/Raspberry%20Pi#RPI4

Because of these, I believe that powerd should be enabled by default in the
Raspberry Pi specific images that are generated.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Fri Jun 25 2021 - 19:18:17 UTC

Original text of this message