[Bug 257373] Problem on nasm? ld? open syscall? My assembly code?

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 24 Jul 2021 01:57:37 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257373

            Bug ID: 257373
           Summary: Problem on nasm? ld? open syscall? My assembly code?
           Product: Base System
           Version: 13.0-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: bin
          Assignee: bugs_at_FreeBSD.org
          Reporter: mazoti_at_gmail.com

Hi!

I did an assembly project using nasm and ld on various OSs and archs.
The project worked on all of them but it has problems on FREEBSD 13 - x64.
On FreeBSD 13 - x86 also worked, but on x64 it's not opening the file passed in
command line parameter.

The sources could be found at:
https://github.com/mazoti/adler32/tree/main/unix-x64

(to see other sources check the root)

The binaries could be found at:
https://github.com/mazoti/adler32/blob/main/releases/

Using the code inside a C program also worked.
I still don't know if the problem is in my code, on nasm, ld or open syscall.


Thanks for you time!

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sat Jul 24 2021 - 01:57:37 UTC

Original text of this message