[Bug 257318] uma consumes memory when reattaching device

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 21 Jul 2021 19:25:30 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257318

            Bug ID: 257318
           Summary: uma consumes memory when reattaching device
           Product: Base System
           Version: 13.0-STABLE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: kern
          Assignee: bugs_at_FreeBSD.org
          Reporter: jcaplan_at_blackberry.com

Overview
--------

After patching in fixes for all identified leaks, detaching and re-attaching
the same device consistently results in kmem allocation.

currently open leaks:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256714
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257218

Steps to Reproduce:
-------------------

#!/bin/bash

for i in {1..1000}; do
        echo $i
        devctl detach pci0:3:0:0
        devctl attach pci0:3:0:0
        sysctl vm.uma_kmem_total
done

Expected Result
---------------

Perhaps after some initial warming stage, detaching and re-attaching the same
device should not increase the amount of memory consumed by uma.

Actual Result
-------------

Even after many thousands of iterations, uma_kmem_total continues to increase

Build Date & Hardware
---------------------
FreeBSD freebsd 13.0-RELEASE FreeBSD 13.0-RELEASE #7
releng/13.0-n244733-ea31abc261f-dirty: Wed Jul 21 14:53:10 UTC 2021

Additional Information
----------------------

Seem to keep hitting keg_alloc_slab from cache_alloc_retry

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Wed Jul 21 2021 - 19:25:30 UTC

Original text of this message