[Bug 260735] 1b33aa1f5f99e1270d526ffa5b652250ec80a7ef (amd64 UEFI loader: stop copying staging area to 2M physical) maybe not effective in some cases

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 29 Dec 2021 13:10:21 UTC

--- Comment #8 from Stanislav <stanislso@yandex.com> ---
> Of course it may not be possible to determine that the memstick has booted to the installer (without video).

Actually, there is a way: After the boot wait for a few minutes, then press

 <Tab>, <Tab>, <Enter>

This will launch "Live CD". Type 

 root <Enter>

to drop into the command prompt. This can be done blindly. Then try to enter
the command

 reboot <Enter>

If the host reboots, then the system was operational.

I just tried this with success in a VM and then attempted to repeat it on the
hardware using the latest memstick

First of all, there is still no video output with the screen connected to an
HDMI or Display Port past the "EFI framebuffer information".

Second, the blind test described above did not give any result - the machine
did not reboot. It does, however, respond to <Ctrl-Alt-Del>.

An interesting aside, if I connect a really old 1024x768 VGA LCD monitor to the
VGA port and boot into the already-installed system, then after a while the
mouse pointer appears on the screen, and then, after another minute a legible
text login prompt appears as well. However, nothing, not even the boot option
screen or the POST screen are shown on the VGA display prior to that point.

On the other hand, a newer display connected to the HDMI or Display Port will
show both POST and the FreeBSD Boot options, but then nothing past EFI
framebuffer information. So this is indicative of problems with video mode
switching and the detection of display capabilities/resolutions.

And booting into memstick using that old VGA LCD monitor did not produce any
output to the screen at any point, however long I waited.

You are receiving this mail because:
You are the assignee for the bug.