[Bug 260249] Lunuxulator: Cannot run Linux version of Kerbal Space Program

From: <bugzilla-noreply_at_freebsd.org>
Date: Mon, 06 Dec 2021 03:40:44 UTC

            Bug ID: 260249
           Summary: Lunuxulator: Cannot run Linux version of Kerbal Space
           Product: Base System
           Version: 13.0-RELEASE
          Hardware: arm64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: bugs@FreeBSD.org
          Reporter: storm16@gmail.com

I have tried several times and several ways to run the GOG version of Kerbal
Space Program on the Linuxulator. I have read the documentation several times
and it feels like there are missing steps that are not in the documentation. I
have tried the following:

* Installed the entirety of the linux-c7 packages and attempted to run the app,
and the binary seems to hang in the terminal window, but the graphics never
appear, and I am unable to ctrl-c out of it.

* Installed Ubuntu 20.04 in /compat/ubuntu, installed my username with the same
UID/GID as my userid as on the FreeBSD side, and had the same behavior as with

* Installed Debian Bullseye, then converted it to Devuan Chimaera (to eliminate
the issue of systemd) in /compat/devuan, set up user in the same way as ubuntu
above. Same result.

I currently have /compat/linux (c7) and /compat/devuan.

I also set up an ubuntu jail as well as a devuan jail. On both of those, I
installed Kerbal in the jail, when I try to run glxgears or the KSP binary, I

storm@brahms:/var/log$ glxgears
X Error of failed request:  BadValue (integer parameter out of range for
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  31
  Current serial number in output stream:  32

I posted the jail issue to the forum, and apparently ssh X forwarding does not
support 3d graphics through the tunnel.

Can 3d graphics be run through the linuxulator? If so, how can I get kerbal tp
run? The Linux box I am running it on currently has a mobile i7, 16GB of RAM
and Intel graphics. My FreeBSD box has a full i7, 32GB of RAM and an nVidia

You are receiving this mail because:
You are the assignee for the bug.