[Bug 257722] Current RELEASE builds (11.4, 12.2, 13.0) give BTX boot crash, where 11.3 worked fine.

From: <bugzilla-noreply_at_freebsd.org>
Date: Mon, 09 Aug 2021 21:38:07 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257722

            Bug ID: 257722
           Summary: Current RELEASE builds (11.4, 12.2, 13.0) give BTX
                    boot crash, where 11.3 worked fine.
           Product: Base System
           Version: 12.2-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: misc
          Assignee: bugs_at_FreeBSD.org
          Reporter: jwdevel_at_gmail.com

I am trying to upgrade my system from 11.3 to a supported release (amd64).
My initial plan was to go to 11.4, then to 12.2. But as you will see, none of
the current supported releases can run the BTX loader. 11.3 seems to be the
last release that works on my system.

See attached images for what the physical console shows for each of the 3
failure cases.

I am more than happy to provide more details if it will help fix this.
In the meantime, I am working on rolling back to 11.3.

11.4 problem:

My upgrade went smoothly until I rebooted after installing the new userland.
Now, boot fails with a register dump and "BTX halted" every time.

I then tried creating a boot USB stick of 11.4, and indeed that has the same
failure to boot on my system.

So, I don't think it is a problem with my upgrade steps. I think 11.4 boot code
simply does not work with my system.

12.2 problem:

I thought perhaps that skipping 11.4 would work, so I made a 12.2-RELEASE USB
boot stick too. This also failed to boot, but in a different way.

This time, when the BTX code runs, the screen is filled with garbage ASCII and
beeps a few times, then halts. So, 12.x seems problematic, too.

13.0 problem:

Since this is the only other supported release, I tried it as well, again via
USB boot stick.

This one also fails, but it simply hangs, with no output, after the list of
BIOS drives.

----

Other notes:

* This is somewhat old hardware, but nothing that's unsupported, AFAIK. Again,
happy to provide details, but I'm not sure what would be most useful.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Mon Aug 09 2021 - 21:38:07 UTC

Original text of this message