Re: Boot from USB on RPi4 8GB?

From: Mark Millard via freebsd-arm <freebsd-arm_at_freebsd.org>
Date: Sun, 30 May 2021 13:50:16 -0700
On 2021-May-30, at 10:59, William Carson via freebsd-arm <freebsd-arm at freebsd.org> wrote:

>> . . .
>> I use a USB3 SSD that has small enough power requirements
>> to not require a powered hub. (I also use a 5.1V 3.5A
>> power supply as part of that context.) I've never tried
>> spinning rust or higher powered USB3 media.

I view the power supply that I use as just giving a little
more margin,  not as a way to increase what the devices
total to.

> . . . I'm not sure what's considered "high powered" but the Samsung tech specs say this particular model uses 5.7 W on average and 10.0 W maximum. But it does seem curious that the Raspberry PI OS will boot this disk without issue, so I don't think it's the drive. I also tried a Samsung 950 PRO using a different enclosure (QNINE NVME Enclosure, M.2 PCIe SSD (M Key) to USB 3.0 External Case), but it behaved the same.
. . .

Then you need to use a powered hub for that device.

https://www.raspberrypi.org/documentation/hardware/raspberrypi/power/README.md
lists:

"Maximum total USB peripheral current draw" as: 1.2A ,
which at 5.1V is 6W.

That figure is the total for all USB devices attached
that are not powered independently.

That document also says that a 5.1V supply is required,
not 5V.

The power supply that the RPi folks supply is 5.1V _at_ 3A
or 15.3W. Even the 5.1V 3.5A power supply that I use
only multiplies out to 17.85W.

===
Mark Millard
marklmi at yahoo.com
( dsl-only.net went
away in early 2018-Mar)
Received on Sun May 30 2021 - 20:50:16 UTC

Original text of this message