Re: FYI: Example USB3 boot failure on RPi4B ZFS-on-root system booting main: uhub_reattach_port notices involved

From: Mark Millard via freebsd-arm <freebsd-arm_at_freebsd.org>
Date: Mon, 24 May 2021 11:06:46 -0700
On 2021-May-24, at 09:01, tech-lists <tech-lists at zyxst.net> wrote:

> On Sat, May 22, 2021 at 08:19:28PM -0700, Mark Millard via freebsd-arm wrote:
>> . . .
>> mountroot> ?
>> 
>> List of GEOM managed disk devices:
>> 
>> 
>> mountroot>
>> 
>> The USB3 SSD was the only storage media present.
>> Port 3 apparently had the USB3 SSD boot media (the
>> same media that the FreeBSD loader got the kernel
>> from before the above).
> 
> This happened with my experimental rpi4-boot-to-zfs-only system too, a
> couple of days ago. Unfortunately I didn't note what it was made from in
> git. Maybe a week ago?
> 
>> Cutting power and starting over did not get the
>> problem again (so far).
> 
> If by "starting over" you mean cold booting,

Sorry for the horribly ambiguous wording. Yes: just
turning on the power again.

> then yeah same thing
> happened here. A buildworld/buildkernel/install has happened since then;
> it's now on n246839, and the problem hasn't so far re-occurred.

Side note:

I'll note that using the likes of just "n246839" to
identify a specific commit is messy so far as I
know (even given the branch is known).

===
Mark Millard
marklmi at yahoo.com
( dsl-only.net went
away in early 2018-Mar)
Received on Mon May 24 2021 - 18:06:46 UTC

Original text of this message