git: 15aa8688d036 - stable/14 - sound: Rename oss_audioinfo->real_device to oss_audioinfo->legacy_device

From: Christos Margiolis <christos_at_FreeBSD.org>
Date: Fri, 17 May 2024 19:31:17 UTC
The branch stable/14 has been updated by christos:

URL: https://cgit.FreeBSD.org/src/commit/?id=15aa8688d036a3ad769cd818ea5c93455c76fafa

commit 15aa8688d036a3ad769cd818ea5c93455c76fafa
Author:     Christos Margiolis <christos@FreeBSD.org>
AuthorDate: 2024-05-09 19:08:17 +0000
Commit:     Christos Margiolis <christos@FreeBSD.org>
CommitDate: 2024-05-17 19:30:36 +0000

    sound: Rename oss_audioinfo->real_device to oss_audioinfo->legacy_device
    
    The OSS manual now documents this field as "legacy_device".
    
    Sponsored by:   The FreeBSD Foundation
    MFC after:      3 days
    Reviewed by:    dev_submerge.ch
    Differential Revision:  https://reviews.freebsd.org/D45138
    
    (cherry picked from commit 24d5cc14dd60b49553ff3ee7830305621f782ff1)
---
 sys/dev/sound/pcm/dsp.c | 4 ++--
 sys/sys/soundcard.h     | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/sys/dev/sound/pcm/dsp.c b/sys/dev/sound/pcm/dsp.c
index fe816db54697..6e5fad048d40 100644
--- a/sys/dev/sound/pcm/dsp.c
+++ b/sys/dev/sound/pcm/dsp.c
@@ -2224,9 +2224,9 @@ dsp_oss_audioinfo(struct cdev *i_dev, oss_audioinfo *ai)
 			ai->mixer_dev = (d->mixer_dev != NULL) ? unit : -1;
 			/**
 			 * @note
-			 * @c real_device - OSSv4 docs:  "Obsolete."
+			 * @c legacy_device - OSSv4 docs:  "Obsolete."
 			 */
-			ai->real_device = -1;
+			ai->legacy_device = -1;
 			snprintf(ai->devnode, sizeof(ai->devnode), "/dev/dsp%d", unit);
 			ai->enabled = device_is_attached(d->dev) ? 1 : 0;
 			/**
diff --git a/sys/sys/soundcard.h b/sys/sys/soundcard.h
index 64f57742a52b..b5434b930215 100644
--- a/sys/sys/soundcard.h
+++ b/sys/sys/soundcard.h
@@ -1878,7 +1878,7 @@ typedef struct oss_audioinfo
 	int	card_number;
 	int	port_number;
 	int	mixer_dev;
-	int	real_device;	/* Obsolete field. Replaced by devnode */
+	int	legacy_device;	/* Obsolete field. Replaced by devnode */
 	int	enabled;	/* 1=enabled, 0=device not ready at this
 				   moment */
 	int	flags;		/* For internal use only - no practical